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OBJETIVOS

 Saber cómo instalar el software libre R Studio en el ordenador

 Ser capaz de manejarse en el entorno de R Studio y saber
realizar operaciones sencillas

 Ser capaz de definir distribuciones discretas y continuas en R
Studio

 Ser capaz de calcular diferentes probabilidades utilizando
funciones de probabilidad, densidad o distribución.
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Conceptos generales de R

• Se trata de un entorno diseñado para el procesado de datos, el cálculo, el análisis
estadístico y la obtención de gráficos.

• Es un lenguaje de programación completo que hace de R un programa muy
versátil.

• El lenguaje de programación R se engloba en el GNU, un Proyecto colaborativo
de software libre (https://www.gnu.org/ para más información).

• Se trata de un software libre por lo que los usuarios pueden ejecutar, copiar,
distribuir, cambiar y aportar mejoras al software con entera libertad.

• Toda la información acerca de R puede encontrarse en la siguiente página web:
https://www.r-project.org/

R Studio

• Es el entorno de trabajo que se utilizará este curso.

• Para poder usar R Studio se ha de tener instalado R previamente.

• Se trata también de un software libre y puede ejecutarse en diferentes sistemas
operativos (Windows, Linux, Mac).

• Del mismo modo, empleando RStudio Server se puede ejecutar desde la página
web.

https://www.gnu.org/
https://www.r-project.org/
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Instalación de R Commander

• La instalación se realiza por medio de la CRAN (R The Comprehensive Archive
Network: https://cran.r-project.org/). En la misma página web se obtiene la
información necesaria para instalar el programa.

WINDOWS

• Desde la página oficial de R descargue la última versión de R (4.1.3).

• Haga clic en “Download R for Windows” y posteriormente “install R for the first
time”.

• Descargue el archivo R-4.1.3-win.exe y haga clic sobre el mismo para comenzar
la instalación.

• Siga los pasos indicados por el programa de instalación.

Mac OSX

• Desde la página oficial de R descargue el paquete seleccionado de R
(R.4.1.3.pkg, R.4.1.3.arm.pkg).

• Haga clic en “Download R for macOS”

• Instale el paquete elegido siguiendo los pasos señalados.

Instalación de R

https://cran.r-project.org/
https://cran.r-project.org/
https://cran.r-project.org/
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Instalación de R Studio

• Desde la página web oficial de R Studio descargue la última versión en función
del sistema operativo que se emplee.

• Siga los siguientes pasos:

 Haga clic en el primer icono de la izquierda: Download RStudio Desktop
(Open Source License) FREE.

 Preguntará si se tiene instalado R. Si no se tuviera, se deberá instalar para
poder utilizar R Studio. (Siga los pasos indicados en la diapositiva
anterior).

 Una vez instalado R, descargue el paquete en función del sistema
operativo.

• Windows: Rstudio-2022.02.1-461.exe - Windows 10/11

• Mac OS: RStudio 1.3.1073.dmg - macOS 10.15+

 Siga los pasos indicados por el programa de instalación.

Instalación de R

https://www.rstudio.com/products/rstudio/download/
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• Tras clicar en el icono de R Studio, aparecerá la siguiente pantalla por
primera vez.

Figura 1. Pantalla inicial del software R Studio. 
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1. Gestión de la sesión

• En primer lugar se recomienda abrir un Script: File->New File-> R Script

(Ctrl+Shift+N)

• Se abrirá una nueva ventana y sobre ella se escribirán todos los comandos a utilizar.

• Para guardar lo escrito en el Script: File->Save as… Se le asigna el nombre deseado

y la ubicación donde se quiera guardar.

• Los archivos se guardarán con la extensión .R .

• Para abrir un Script previamente guardado: File->Open File->…

• Lo escrito en el Script se ejecutará en una ventana llamada Console.

• Se puede ejecutar línea a línea (Ctrl+Enter) o ejecutar todo lo escrito en el Script de

una sola vez (Ctrl+Alt+R). También puede elegirse qué parte del código ejecutar

empleando Code->Run Region->…

• Se puede incluso escribir en la ventana Console y ejecutar al mismo tiempo que se

escribe (no recomendado).

Primeros pasos con R
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1. Gestión de la sesión

• Mientras se esté trabajando (para guardar los archivos, para abrirlos, etc.) el usuario

se encuentra en un directorio de trabajo determinado.

• Para conocer el directorio de trabajo en el que se está trabajando: getwd()

• Para cambiar el directorio de trabajo: Session->Set Working Directory->Choose

Directory… (Ctrl+Shift+H)

• Para mostrar las órdenes de la sesión: history (inf) o visualizarlos en el panel History

(arriba a la derecha).

• Para guardar los objetos empleados: en el panel Environment (arriba a la derecha)

hacer clic en Save.

• Para obtener ayuda: Help->R Help o en el panel Help (abajo a la derecha) escribir la

duda que se tenga.

Primeros pasos con R
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2. Operaciones básicas

• Se pueden realizar operaciones aritméticas básicas.

• Notación de los operadores aritméticos: +,-,*,/ y ^ (suma, resta, multiplicación,
división y potenciación, respectivamente).

• Las operaciones de la línea se leerán de izquierda a derecha teniendo siempre en
cuenta la prioridad de los operadores. Se emplearán paréntesis para dar
prioridad a las operaciones que se estimen oportunas.

• En una misma línea pueden introducirse diferentes funciones u operaciones,
separadas por punto y coma (;) .

Ejemplo

Ejecutado en el panel Console

2*3-5 

[1] 1

5/4^3;-1^2-9;(-1)^2-9;(-1)^(2-9) 

[1] 0.078125

[1] -10 

[1] -8 

[1] -1 

(9-11)^2/(5-4)*3^2;(9-11)^2/((5-4)*3^2) 

[1] 36 

[1] 0.4444444

Primeros pasos con R



5.2.

13

2. Operaciones básicas

• En R existen numerosos comandos matemáticos y estadísticos.

• Al tiempo que se escribe un comando, R irá prestando ayuda para escribirlo de
forma correcta.

• Tras cada comando se emplearán paréntesis escribiendo dentro de ellos los
argumentos necesarios.

• Para introducir comentarios que no se quieran ejecutar, se dispondrá el símbolo #
frente a los mismos.

Ejemplo

>sqrt(7)#raíz cuadrada

[1] 2.645751 

>exp(6)#exponencial

[1] 403.4288 

>sin(pi/2)/cos(pi)#comandos de seno y coseno

[1] -1 

>log(7);log(2,7)#comando de logaritmo neperiano; logaritmo en base 2

[1] 1.94591 [1] 0.3562072 

>factorial(9)#comando de factorial

[1] 362880

>choose(6,3)#combinación

[1] 20

Ejecutado en el panel Console

Primeros pasos con R
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• Comandos de distribuciones discretas

Distribución Comando

Binomial binom

Geométrica geom

Binomial negativa nbinom

Hipergeométrica hyper

Poisson pois

Funciones Prefijo

Función de probabilidad d

Función de distribución p

Crear valores aleatorios r

Función cuantil q

Tabla 1: Comandos para distribuciones discretas en R.

Tabla 2: Prefijos para obtener diferente funciones.

• Prefijos
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Ejemplos

1. Sea una variable aleatoria que sigue una distribución binomial.
Parámetros n=7, p=0,15. Calcule:

a) La probabilidad de que tome el valor de 2.

> dbinom(2,size=7,prob=0.15)#Función de probabilidad
[1] 0.2096508

En modo simplificado

> dbinom(4,7,0.15)#Función de probabilidad en modo simplificado
[1] 0.2096508

b) La probabilidad de que tome como mucho el valor de 3.

> pbinom(3,7,0.15)#Función de distribución en modo simplificado
[1] 0.9878968

Distribuciones discretas
con  R
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Distribuciones discretas
con  R

Ejemplos

2. Sea una variable aleatoria que sigue una distribución geométrica.
Parámetro p=0,15. Calcule:

a) La probabilidad de que tome el valor de 3.

> dgeom(3,prob=0.15)#Función de probabilidad
[1] 0.09211875

En modo simplificado

> dgeom(3,0.15)#Función de probabilidad en modo simplificado
[1] 0.09211875

b) La probabilidad de que como mucho tome el valor de 4.

> pgeom(4,0.15)#Función de distribución en modo simplificado
[1] 0.5562947
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Distribuciones discretas
con  R

Ejemplos

3. Sea una variable aleatoria que sigue una distribución binomial
negativa. Parámetros n=12 y p=0,34. Calcule:

a) La probabilidad de que tome el valor de 6.

> dnbinom(6, size=12,prob=0.34)#Función de probabilidad
[1] 0.00244113

En modo simplificado

> dnbinom(6,12,0.34)#Función de probabilidad en modo simplificado
[1] 0.00244113

b) La probabilidad de que como mucho tome el valor de 12.

> pnbinom(12,12,0.34)#Función de distribución en modo simplificado
[1] 0.07754832
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Distribuciones discretas
con  R

Ejemplos

4. Sea una variable aleatoria que sigue una distribución
hipergeométrica. Parámetros N=30 (tamaño de la población), m=8
(número de éxitos en la población), n= 22 (número de fracasos en la
población) y k=6 (número de ensayos). Calcule:

a) La probabilidad de que tome el valor de 5.

> dhyper(5,m=8,n=22,k=6)#Función de probabilidad
[1] 0.00207486

En modo simplificado

> dhyper(5,8,22,6)#Función de probabilidad en modo simplificado
[1] 0.00207486

b) La probabilidad de que al menos tome el valor de 5.

 phyper(4,8,22,6,lower.tail=F)#Función de distribución en modo                     
simplificado y usando el comando lower.tail=F se calcula P(X>x) 
[1] 0.002122016
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Distribuciones discretas
con  R

Ejemplos

5. Sea una variable aleatoria que sigue una distribución de Poisson.
Parámetro l=6. Calcule:

a) La probabilidad de que tome el valor de 7.

> dpois(7,lambda=6)#Función de probabilidad
[1] 0.137677

En modo simplificado

> dpois(7,6)#Función de probabilidad en modo simplificado
[1] 0.137677

b) El valor mínimo de la variable aleatoria para una probabilidad
acumulada de 0,9. P(X ≤ x )=0,9

> qpois(0.9,6)#Función cuantil en modo simplificado
[1] 9
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• Prefijos

• Comandos de distribuciones continuas

Distribución Comando

Uniforme unif

Exponencial exp

Normal norm

Funciones Prefijo

Función de densidad d

Función de distribución p

Crear valores aleatorios r

Función cuantil q

Tabla 3: Comandos para distribuciones continuas en R.

Tabla 4: Prefijos para obtener diferentes funciones.
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Distribuciones continuas
con R

Ejemplos

6. Sea una variable aleatoria que sigue una distribución uniforme.
Parámetros a=6 y b=20. Calcule:

a) La probabilidad de que al menos tome el valor de 7 y como mucho el
valor de 10

> punif(10,min=6,max=20)-punif(7,min=6,max=20)#Función de distribución
[1] 0.2142857

En modo simplificado

> punif(10,6,20)-punif(7,6,20)#Función de distribución en modo
simplificado
[1] 0.2142857

b) El valor de la variable aleatoria que deja el 20% de la distribución a
su derecha.

> qunif(0.2,6,20,lower.tail=F)#Función cuantil en modo simplificado        
y usando el comando lower.tail=F se calcula P(X>x)=0.20 
[1] 17.2
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Distribuciones continuas
con R

Ejemplos

7. Sea una variable aleatoria que sigue una distribución exponencial.
Parámetro l=1/3. Calcule:

a) La probabilidad de que tome como mucho el valor de 5.

> pexp(5,rate=1/3)#Función de distribución
[1] 0.8111244

En modo simplificado

> pexp(5,1/3)#Función de distribución en modo simplificado
[1] 0.8111244

b) El valor de la variable aleatoria que deja el 50% de la distribución a
su izquierda.

> qexp(0.5,1/3)#Función cuantil en modo simplificado
[1] 2.079442
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Distribuciones continuas
con R

Ejemplos

8. Sea una variable aleatoria que sigue una distribución normal.
Parámetros m=35 y s=7 . Calcule:

a) La probabilidad de que la variable aleatoria tenga una diferencia
máxima de 5 respecto a la media.

> pnorm(40,mean=35,sd=7)-pnorm(30,mean=35,sd=7)#Función de distribución
[1] 0.5249495

En modo simplificado

> pnorm(40,35,7)-pnorm(30,35,7)#Función de distribución en modo
simplificado
[1] 0.5249495

b) La probabilidad de que tome como mucho el valor de 43.

> pnorm(43,35,7)#Función de distribución
[1] 0.8734




