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Data management in Gretl

Data are necessary to carry out any empirical econometric analysis. This lesson is
going to deal with how to organise available data so that they can be used to
estimate and validate econometric models with Gretl. The lesson is split into two
parts:
A. Data file management in Gretl, including
How to create new data files in Gretl format.

What a Gretl session is.

How to modify and save Gretl data files.

B. Data analysis using Gretl, including

Descriptive data analysis: summary statistics (means, variances, ...),
correlation matrices, normality tests, boxplots, ...

Graphics for data analysis (univariate and multivariate) to help understand
the nature of the relationships between the variables of interest.
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Learning objectives

To generate Gretl data files loading the data from different sources.

To modify data in Gretl.

To define new variables using the data available in a Gretl data file.

To simulate random samples.

To review basic probability and inference concepts.

To obtain the main descriptive statistics for one or more variables using Gretl.

To graph data using both time series plots and scattergrams.
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O Gretl data files.
© What is a Gretl session?
© Modifying Gretl data files.
o Add data.
o Define new variables.
@ Analysis of data: descriptive statistics.
9 Graphics for data analysis in Gretl.

O Univariate analysis.

@ Tasks: T3.1, T3.2, T3.3, T3.4 and T3.5
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1. Entering data manually.

2. Selecting a data set from a database.

1. User file:

o Gretl file
o Import data from other formats (Excel, Stata, EViews, CSV, ...)

2. Sample file.




Gretl data files.

The pulldown menu File includes all the commands related to creating and
opening data files.

File | Tools Datz View Add Sample Variable Model Help

Open data [E5 Userfile.. Ctrl+O

Append data.. :1 ] 3
[ Sample file...

B Savedsta Ctrl+S

B sove detose 1. cement.gdt
2. affairs.gdt

3. beauty.gdt

4. airfare.gdt

Ctrl+N 5. 401 ksubs.gdt

6.401k.gdt

-

Working directory...

Script files
Session files

Function files

v v o -

ol Quit Ctrl+Q

i

)

FEsREHLE ¢ 3BD
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1. To enter data in Gretl manually, go up to the Menu Bar and click

File -> New data set

See Example 3.1.1 for applications.

2. To select a time series data from a specific data base, click

File -> Databases




Gretl data files.
B. To open a data file.

1. To open a user file, go up to the Menu Bar and click
File -> Open data -> User file ...

You may import data in other formats, such as Excel, Stata, EViews,
csv, ...

See Example 3.1.2 for applications.

You may open a Gretl data file.

See Example 3.1.3 for applications.

2. To open a sample file, click

File -> Open data -> Sample file ...

See Example 3.1.4 for applications.
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What is a Gretl| session?

Concept of session.

A session is a common space where it is possible to save data files, graphs,
models and other information.

Each object saved in a session is represented as an icon. If the session is saved,
all the objects saved can be used in another working session.

It is possible to retrieve the information saved double-clicking on any icon of

the session.

Clicking on the fourth element of the Gretl's Toolbar, session icon view, you may
see all the icons saved in the session.
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What is a Gretl session?

Elements of the session.

When a data set is opened, Gretl generates by default a session including the
icons:

Data info with information about the data set. If this icon is empty, you can fill it in
and save it.

Data set that allows you to edit the data.

Summary that contains the main summary statistics for all the variables.
Correlations that contains the correlation matrix among all the variables.

Model table where it is possible to include the models estimated during the session.
Scalars where it is possible to save the scalars calculated during the session.

Notes where it is possible to write any comments on the work you are doing.

Graph page, where it is possible to save the graphs made during the session.
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If you want to save all the icons included in a Gretl session to use them for further

work, DO NOT forget to save the

session.

B et

E|l=|Iools Data View Add Sample Variable Moedel Help

Open data 3
Append data...
Save data
Save data gs...
Export data...
& SendTo..
{7 New dataset
&4 Clear data set

Ctrl+S

Ctrl+N

Working directary...

n—iés%i

»
4 | Open session...

| 4

hg percent
h rate

Eipams

ript files
ion files
Databases C
Eunction files b

d Quit cl-Q
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The pulldown menu Data includes all the commands related to adding
observations and/or variables to a Gretl data set.

Bt T e N ——
Eile Tools Data View Add Sample Variable Model Help
401k.gdt * Select all Ctrl+A
ID# ¢ Variab © Find variable... Ctrl+F
0 const
1 prate Define or edit list...
2 mrate  Setselection from list...
3 totpa
d |
Remove extra observations
Dataset info
Observation markers...
Variable labels...
Dataset structure...
Compact data...
Expand data...
Transpose data...
Sort data...
1534
Set missing value code...
B E Count missing values




Modifying Gretl data files.

Add data.

1. To enter new observations manually, go up to the Menu Bar and click
Data -> Add observatioms...

See Example 3.2.1 for applications.

2. To enter new variables manually, click
Data -> Edit values

See Example 3.2.1 for applications.

3. To add data from another file, for instance, from an Excel file, click
File -> Append data...
See Example 3.2.2 for applications.
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All the commands related to defining new variables using the available data in the
Gretl file may be found in the pulldown menu Add.

B —

Eile Tools Data View

Add  Sample Variable Model Help

401k.gdt *
ID# ¢ Variable name ¢ De:
0 const
1 prate pa

2 mrate
3 totpart

Logs of selected variables
Squares of selected variables

Lags of selected variables

FEirst differences of selected variables

Log differences of selected variables
Seasonal differences of selected variables

Index variable
Time trend
Panel unit index

Periodic dummies

Unit dummies

Time dummies

Observation range dummy

Dummies for selected discrete variables

Define matrix...




Modifying Gretl data files.

Define new variables.
1. Add new variables generated using the variables included in the data set.
Logarithms and squares of the variables in the file: ¥ — InY, Y2
For time series data:

Lags of a selected variable: Yi—1,Yi—o,...

First differences of a selected variable: AY =Y, — Y1
Differences of the logarithms of a selected variable: AlnY =InY; —InY:_;
Seasonal differences of a selected variable: AY =Y —Yis

(only for quarterly or monthly time series data)

See Example 3.2.3 for applications.
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Modifying Gretl data files.

Define new variables.

1. Add new variables generated using the variables included in the data set.

New variables can be generated as transformations (sums, products, ...) of
the variables included in the data set. Go up to the Menu Bar, click

Add -> Define new variable...

and write the expression for the new variable in the dialog box. For instance,
to obtain a new variable which is an average of variables X3 and X4 write

“ gretl: add var l&‘

Enter formula for new variable
(or just a name, to enter data manually)

mm=(3+x4)/2

Help Cancel OK

See Example 3.2.3 for applications.
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Modifying Gretl data files.

Define new variables.

2. Simulate variables.

It is possible to generate a new variable by simulating a random sample from
one of these distributions: uniform, normal, t, x2, F, gamma, binomial,
Poisson y Weibull. Go up to the Menu Bar, click

Add -> Random variable...
and select the distribution, its parameters and a name for the new variable in
the dialog box.
I gretl: add random variable | e

uniform | normal | t | chisquare | F | gamma  binomial | poisson | weibull

minimum |0
maximum 1

name W

Help Close oK

See Example 3.2.4 for applications.
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Descriptive statistics.

Some basic statistics concepts.

Random variable versus observation.

In Econometrics, the economic variables are considered as random variables, because
their actual values are not known until they are observed.
An observation is one of the possible outcomes of the random variable.

It is necessary to distinguish between variables whose values are not yet observed
(random variables) and those whose values have already been observed (observations).

It is important to keep in mind always that an observation is one of the many possible
values that a variable can take. Another draw from the random variable will usually
result in a different value being observed.

Random variables can be:

1. Discrete, taking any of a specified finite or countable list of values. For instance, the
number of kids.

2. Continuous, taking any numerical value in an interval or collection of intervals. For
instance, consumption, income, production, ...
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Descriptive statistics.

Some basic statistics concepts.

Probability distribution.

The probability distribution gives the relative frequency (or probability) with which
each possible value of the random variable is observed.

The probability distribution function of a random variable X, or simply
distribution function, is the mathematical function that assigns a probability to
each measurable subset of the possible outcomes of a random variable:

Fx(z) = P(X < z)

The density probability function (or, simply, density function) represented as f(x),
is the derivative of the probability distribution function.
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Descriptive statistics.

Some basic statistics concepts.

The probability function contains all the information about the random variable.
But, its mathematical form is usually quite complicated and it is common to
summarize this information by concentrating on some simple numerical
characteristics of the probability functions referred as parameters. For instance,
the mean and the variance.

Mean. The expected value of a random value X is the sum of the product of the
probability of each event ((p(.), f(.)) times the value of the event (z;, x).

Discrete variable > mip(w:)

u—E(X)—{

Continuous variable ffooo zf(x)

Variance is a measure of dispersion of a random variable X around the expected value
E(X).
V(X) = BIX - BOOP = o%
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Descriptive statistics.

Some basic statistics concepts.

Distribution graphs in Gretl.
Go up to the Menu Bar and click

Tools -> Distribution graphs

to represent the most common probability distributions.

Vi Sample Variable Model Help

File Tools Data Vi

Nods  Statistical tables

ID# 4 Pvaluefinder ‘
Distribution graphs
Plota curve

Test statistic calculator
Nonparametric tests
Seed for random numbers

Command log
Gretl console

Gnuplot

Start GNU R

INIST test suite »
Preferences ’
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Descriptive statistics.

Some basic statistics concepts.

Distribution graphs in Gretl.
It is necessary to select the distribution and provide its parameters.

The density function is represented by default, but it is possible to graph the
probability density function for the normal distribution exclusively by marking
CDF instead of density.

B grett: distribution graphs | ) S
[normal | t | chi-square | F | binomial| poisson | weibull

mean 0
std. deviation |1

CDF instead of density

Close oK
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Descriptive statistics.

Some basic statistics concepts.

Distribution graphs in Gretl.

The left-hand side graph shows the density function of a normal random variable
with mean 0 and variance 9. The right-hand side graph shows the density function

of a x?2 distribution with four degrees of freedom.

N0, 9) ——

Chi-square(®) ——
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Descriptive statistics.

Some basic statistics concepts.

Consider two random variables X and Y that follow a joint distribution f(X,Y).

Covariance. It is a measure of the linear association between two variables. If the
covariance is positive, there is a direct linear relationship between the variables,
and if the covariance is negative, there is an inverse linear relationship between the
variables. If there is no linear relationship, the covariance is zero.

cov(X,Y)=E[X —EX)|[Y — E(Y)] =0oxy
Correlation. It is a measure of the linear association between two variables. It

takes values between -1 and 1.

X, Y
corr(X,Y) = e 10) _ EY = pxy
VX)V(Y) oxoy
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Descriptive statistics.

Some basic statistics concepts.

If the distribution function of a random variable is known, it is possible to obtain
the mean and the variance. But, usually, both the values of X and its distribution
function are unknown.

Population: set of individuals relevant to the study.

Sample: subset of the population.

Characteristics of the distribution function. Population parameters of
interest:

mean, variance, covariance, correlation.

Estimation of the population parameters using the sample:

sample mean, sample variance, sample covariance, sample correlation.
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Descriptive statistics.

Summary statistics in Gretl.

The pulldown menu View includes all the commands necessary to estimate the
main parameters of the distribution function.

File Tools Data View Add Sample Variable Model Help
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401k.gdt * Icon view
I # 1 Variable nam| Graph specified vars
0 const
i p=e Multiple graphs
2 mrate Summary statistics
3 totpart Correlation matrix
Principal components
Mahalanobis distances
Cross-correlogram
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Go up to the Menu Bar and click

View -> Summary statistics

The output appears in the figure below.

BeDARDX
Mean
prate 87.363
mrate 0.73151
totpart 1354.2
totelg 1628.5
Std. Dev.
prate 16.717
mrate 0.77954
totpart 4629.3
totelg 5370.7
5% perc.
prate 53.775
mrate 0.11000
totpart 96.000
totelg 105.00

Median
95.700
0.46000
276.00
330.00

c.v.
0.19135
1.0657
3.4184
3.2979

95% perc.
100.00
2.3750
4516.8
5737.8

Minimum
3.0000
0.010000
50.000
51.000

Skewness
-1.5196
2.5944
7.7646
7.3226

IQ range
22.000
0.53250
594.00
715.25

Maximum
100.00
4.9100
58811.
70429.

Ex. kurtosis
2.2584
7.6139
70.374
62.535

Missing obs.
0
[

0
0




Descriptive statistics.

Summary statistics in Gretl.

Consider a sample of NV observations of the random variable X: X;, Xo,...

Mean ix =X = ]\}
N v\ 2
. S (X - X)
Vari X) = 52 2171
ariance V(X)=6% N1
Standard deviation 6x = /6%
ox

Coefficient of variation C.V. = —

s

Skewness '
— 53
N -1 0%
N 4
: 1 i1 (Xi — X)
Excess kurtosis =
N-1 ox —3
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Descriptive statistics.

Summary statistics in Gretl.

The quantile or order p (0 < p < 1) of a ranked set of data is the value z;, such that the
probability that the random variable will be less or equal than z, is at most p.

The quartiles of a ranked set of data values are the three points that divide the data set
into four equal groups, each group comprising a quarter of the data: the 25 % quantile,
(Q1), 50 % quantile (Q2) and the 75 % quantile (Q3).

The percentiles of a ranked set of data values are the ninety nine points that divide the
data set into 100 equal groups, each group comprising a hundreth of the data.

Median The middle value of a ranked set of data values: half the figures will fall below
the median and half above. It is the 50 % percentile and the second quartile.

1Q range The inter quartile range is the difference between the third and the first quartiles.

5% Percentile Value of the variable such that 5% of the ranked set of data are smaller.

95 % Percentile  Value of the variable such that 95 % of the ranked set of data are smaller.

See Example 3.3 for applications.
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Go up to the Menu Bar and click
View -> Correlation matrix

The output is shown in the figure below.

BeDaAamo X

Correlation Coefficients, using the observations 1 - 1534
5% critical value (two-tailed) = 0.0501 for n = 1534

prate mrate totpart totelg
1.0000 0.2733 0.0042 -0.0764 prate
1.0000 0.0186 -0.0007 mrate

1.0000 0.9761 totpart
1.0000 totelg

Each element of this matrix is the estimated correlation coefficient between two variables:
S, (Vi = V)(X2 — X2)

\/ZL (Y- Y)2 3N (X2 - X2)2

Py.x2 = 0.9472 =
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Gretl data files.
What is a Gretl session?
Modifying Gretl data files.
Add data.
Define new variables.
Analysis of data: descriptive statistics.
e Graphics for data analysis in Gretl.

Univariate analysis.

Tasks: T3.1, T3.2, T3.3, T3.4 and T3.5



Graphics for data analysis in Gretl.

Graphs in Gretl.

The pulldown menu View in the Main Bar includes the commands required to

make graphs in Gretl.

Eile Tools

Data
cement.gdt *
1D # 4 Variable nami

0 const
1 precem
2 ipcem
3
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View Add 3ample

Icon view

Variable

Model

L

Graph specified vars r

Multiple graphs

»

Help

Time series plot...
H-Y scatter...

Summary statistics
Correlation matrix
Cross Tabulation
Principal components
Mahalanobis distances

Cross-correlogram

-Y with impulses...
K- with factor separation...
X-Y with control...
Boxplots...
Factorized boxplot...
Q-Q plot...

3D plot...
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Graphics for data analysis in Gretl.

Time series graphs.

A time series graph is the plot of a time series variable against time.

1. You may plot several time series on one single graph, clicking

View -> Graph specified vars —> Time series plot ...

2. You may plot several time series in separate graphs, clicking

View -> Multiple graphs —> Time series ...

See Example 3.4.1 for applications.
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Graphics for data analysis in Gretl.

X-Y scatter.

A scatter represents the cloud of points (X,Y’), where the variable X is in the
abscissas axes and the variable Y is in the ordinate axes.

1. You may plot several pairs of variables on one single graph, clicking

View -> Graph specified vars —> X-Y scatter ...

2. You may plot several pairs of variables in separate graphs, clicking

View -> Multiple graphs —> X-Y scatters ...

See Example 3.4.2 for applications.

Pilar Gonzélez and Susan Orbe | OCW 2014 Lesson 3. Data management in Gretl

39 /55



Go up to the Menu Bar and click

View -> Graphs specified vars —> 3D plot ...

See Example 3.4.3 for applications.




Right-clicking on the graph yields a pulldown menu that offers a number of
options.

prepet

Save as Windows metafile (EMF)..  »
Save as PNG...

Save as postscript (EPS)...

Save as PDF...

Copy to clipboard »
Save to session as icon

Print »
60 | DisplayPDF

Edit
Close

100 -

80

40

L L L
1965 1970 1975

L
1980

1964031137 [ Right-clck on graph for menu

L L
1985 1990

ORS-NEASE S




Graphics for data analysis in Gretl.

Edit a graph in Gretl.

1. Save the graphs in a variety of formats:

Windows Metafile (EMF), color or monochrome.
PNG file.
Postscript (EPS) file.

PDF file.

2. Copy to clipboard to export to another file (Microsoft Word file, ...).
3. Save the graph in the session as an icon.

4. Zoom ... This option enables us to select a section of the graph to see it more
clearly. Right-clicking on the graph and selecting the option Restore full view, the
original graph is recovered.

5. Print the graph (color or monochrome).
6. Display the pdf file.

7. Edit the graph: colours, labels, dimensions, ...

See Example 3.4.4 for applications.

y
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Univariate analysis.

Variable menu.

First, highlight the variable you want to analyse using the cursor. The pulldown
menu Variable in the Menu Bar becomes active allowing us to obtain information

about different aspects of this variable.

cement.gdt *
ID# ¢ Varizble name 4 Descriptive label

0 const
1 precem BLS ppi for cement
2 ipcem industrial productic

3 propet ppi for crude petro

Monthly: f

@0~ 8

Tools Data View Add Sample Variable Model Help

Displey values
Edit attributes
Set missing value code...
Summary statistics
Normality test
Frequency distribution...
Estimated density plot...
Boxplot

Normal Q-Q plot...
Gini coefficient
Renge-mean graph

Time series plot
Panel plot..
Unit root tests
Correlogram

Periodogram
Filter

X-12-ARIMA analysis
TRAMO analysis
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Univariate analysis.

The pulldown menu Variable includes a complete set of options which is split in
two sections.

The first subset of options can be used with both cross-section and time series
data. The second subset of options is relevant only for time series data.

It should be noted that:
Some options of the menu Variable are included in other menus (Display values, Edit
attributes, Set missing value code, Summary statistics, Time series plot...).

The only options revised in this section are the ones related to the distribution of the
selected variable.

The rest of the options of this menu correspond to and advance level of
Econometrics.
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Univariate analysis.

Distributions.

The pulldown menu Variable includes several options that help analyse the
characteristics of the distribution of the selected variable.

file Tools Data View Add Sample Variable | Model Help

Boxplot

Normal @-Q plot...
Gini coeRicient
Range-mean graph

Time series plot
Panel plot...
Unit root tests
Correlogram
Periodogram
Filter

Monthly: | X-12-ARIMA analysis
TRAMO analysis

m@EFE~BE L8 Hurst exponent

cement.gdt * Display values

ID# 4 Variable name 4 Descriptive label Edit attributes
0 const Set missing value code...
1 precem BLS ppi for cement. Summary statistics
2 ipcem industrial productic (” Normality test

3 prepet ppi for crude petrol Frequency distributien...

Estimated density plot...
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Univariate analysis.
Normality tests.

Clicking Variable -> Normality test, the value of the statistics and the
p-values are obtained for a number of normality tests:

- Doornik-Hansen test - Shapiro-Wilk W
- Lilliefors test - Jarque-Bera test

Null hypothesis: the selected variable follows a normal distribution

Alternative hypothesis: the selected variable does not follow a normal
distribution

The p-value indicates whether there is evidence in the sample that the variable
follows a normal distribution. If the p-value is smaller than «, it may be concluded
that the selected variable does not follow a normal distribution at an a %
significance level.

See Example 3.5.1 for applications.
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Go up to the Menu Bar and click

Variable -> Frequency distributiomn ...

- gretl: frequency distribution

/prepet (n = 312, range 13.4 to 114.9) I
) Minimum value, left bin: @E
L Bin width: @E

@ Show data only

© Test agai e
© Testagainst g O
[¥] show plot

[ b J[ comce [ ox ]|

See Example 3.5.2 for applications.




Univariate analysis.

Distributions.
The dialog box is split into three sections:

In the first section we find:

The number of observations and the range of the selected variable.
Two options for the number of bins:
o To choose a specific number of bins (Gretl proposes a number by default).
o To choose the minimum value for the first (left) bin, and the width of the
bins.

In the second section, there are three options for the output:
Only the numerical results for the frequency distribution.
To run a test against the normal distribution (Doornik-Hansen test).
To run a test against the gamma distribution.

In the third section, you may decide whether you want Gretl to show the
frequency distribution plot. In the case of the tests, the graph of the estimated
density is included by default.
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Univariate analysis.

Estimated density.

Go up to the Variable pulldown menu and click
Variable -> Estimated density plot

A density estimation options (o)
© [Gaussian kemel

Epanechnikov kernel

bandwidth adjustment factor: 100

|
Help | Concel oK i

You have to choose a weight function (kernel) in the dialog box: Gaussian kernel
or Epanechnikov kernel.

The bandwith adjustment factor is used to increase or decrease the smoothness of
the weights. If you are not an expert, it is recommended not to change this
parameter.

See Example 3.5.3 for applications.
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The simple boxplot shows the three quartiles, Q1, Q2 (the median) and Q3, the
sample mean and the minimum and maximum values.

Maximum — 7.

«— Q3: third quartile
<«— Q2: median

o1 )
Minimum Q1: firstquartile




Go up to the Menu Bar and click

Variable -> Boxplot

-guﬂ:deﬁnegraph
© [simple boxplot;
©) With confidence i | for medi

) Factorized

[ Gomce [[ ox |

You have to choose the type of boxplot in the dialog box:
o Simple boxplot.
o Boxplot including a confidence interval for the median.

o Factorized boxplot. With this option you get as many boxplots as the number of categories of the discrete
variable used as factor.

See Example 3.5.4 for applications.
 Pilar Gonzalez and Susan Orbe | OCW 2014  Lesson 3. Data management in Grett  52/55



Univariate analysis.

Q-Q plot.

The Q-Q plot is a graphic tool to check whether the sample comes from a normal
distribution: the closer the data are to the diagonal line, the greater the evidence in favor
of the normal distribution is. Go up to the Menu Bar and click

Variable -> Normal Q-Q plot

Bl

Normal Q-Q plot

© use sample mean and variance for normal quantiles;

standardize the data

raw quantiles versus N(0, 1)

[ bep | [ cemea |[ ok ]

Gretl offers several options:

Use sample mean and variance for normal quantiles.
Standardize the data.

Use the raw quantiles versus the standard normal distribution.

See Example 3.5.5 for applications.
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Univariate analysis.

A shorcut.

Right-clicking on a selected variable yields a pulldown menu showing a set of
options to analyse the variable.

File Tools Data View Add Sample Variable Model Help
cement.gdt *
ID # ¢ Variable name 4 Descriptive label Al
0 const
2 ipcem industrial production index, cenr erplayjalics
3 prepet ppi for crude petroleum Summary:btistics
Time series plot
Frequency distribution
Correlogram
Periodogram
Edit attributes
Edit values
Copy to clipboard
Delete
Add log
Add difference
Define new variable...
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Gretl data files.
What is a Gretl session?
Modifying Gretl data files.
Add data.
Define new variables.
Analysis of data: descriptive statistics.
Graphics for data analysis in Gretl.

Univariate analysis.

@ Tasks: T3.1, T3.2, T3.3, T3.4 and T3.5
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