CAMPUS OF
INTERNATIONAL
EXCELLENCE

Universidad  Euskal Herriko
del Pais Vasco  Unibertsitatea

Example 3.4

Graphics for data analysis in Gretl

Pilar Gonzalez and Susan Orbe

Dpt. Applied Economics Il (Econometrics and Statistics)

Pilar Gonzélez and Susan Orbe | OCW 2014 Example 3.4 Graphics in Gretl



@ 3.4.1. Time series graphs.
@ Chicken consumption.
@ Visitors to Bilbao.

© 3.4.2. Scatterplots.
e 3.4.3. 3D scatterplot graphs.

@ 3.4.4. Editing graphs.

Pilar Gonzélez and Susan Orbe | OCW 2014 Example 3.4 Graphics in Gretl



Contents

@ 3.4.1. Time series graphs.
@ Chicken consumption.
@ Visitors to Bilbao.

Pilar Gonzélez and Susan Orbe | OCW 2014 Example 3.4 Graphics in Gretl



Example 3.4.1. Time series graphs. Chicken consumption.

Questions.

Open the data file chicken.gdt to make some time series plots of the variables

Y, X2, X3, X4 and X5.

a. Represent all the variables on a single graph. Save this graph as an icon in the

Gretl session.

b. Represent all the variables in separate small graphs. Save the output as an icon

in the Gretl session.

c. Save the session with the name Seschicken.

d. Interpret the results.
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Example 3.4.1. Time series graphs. Chicken consumption.

To plot several time series on a single graph, go up to the Menu Bar an click

View -> Graph specified vars -> Time series plot...
E gret (2| © fSm)
File Tools Data View Add Sample Varizble Model Help
chicken.gdt Icon view l
ID‘O< \:::Ie namj Graph specified vars 4 Time series plot... 4

Multiple graphs » X-Y scatter...
X-Y with impulses...

N
<

X2 Summary statistics ! :
3 3 Correlation matrix Xy Wf"" factor separation...
4 X4 Cross Tabulation X-Y with control...
505 Principal components §°xpl‘f'5"'
6 X6 Mahalanobis distances Factorized boxplot...
Cross-correlogram Q-Qplot...
3D plot...

Annual: Full range 1990 - 2012

@OE~REL 4 B0
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Example 3.4.1. Time series graphs. Chicken consumption.

Select the variables Y, X5, X5, X4 and X5 in the dialog box.

gretl: define graph e

Select variables to plot

v v

x X

3 3

X x4

5 X5

X6

Help ] [ T ] [ T ] [ oK
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Example 3.4.1. Time series graphs. Chicken consumption.

The five selected variables are plotted on a single graph. The X-axis (abscissas)
represents time. There are two Y-axes (ordinates), left (Y) and right (Y2), to be able to
represent the selected series using two scales.

The right ordinate axis represents Y (consumption) and the left ordinate axis represents
X2, X3, X4 and X5. It is not possible to see the variables X3, X4 and X5 in the graph
(even if they are there) because their range of values is much smaller than the range of
the variable Xs.

I orett: graph [ESHEEEX)

2500 T T 55
¥ (right) ——

2000 -

1500 [

1000 [

500

ol L n N
1990 1995 2000 2005 2010

2000.597 Right-click on graph for menu el JEASR
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Example 3.4.1. Time series graphs. Chicken consumption.

It should be noted that it is very important to take into account the range of values
when plotting data.

In this example it would more informative to plot Y (consumption) and X5 (income) on
one graph, and Y (consumption) and the three price series, X3, X4 and X5, on another
one.

grett graph grett graph [ESREE
2500 10 ss
¥ (right) —— ¥ (right) ——
X2 (ieft) X3 (left) —— ;
9F X4 (left) —— g
X5 (left) —— s /

2000

s

1500

1000

0 2 :
1990 1995 2000 2005 2010 19%0 1095 2000 2005 2010
Right-click on graph for menu HeBRZOX | Right-click on graph for menu COoRRE X
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Example 3.4.1. Time series graphs. Chicken consumption.

To save the graph as an icon to the session, right-click on the graph and select
the option Save to session as icon from the pulldown menu.

B orett: graph (o]
10 - T . v 55
¥ (right) ——
X4 (left)
g X5 (left) 7
X6 (left) - ,A/
/ 1 S0
k- /
e Save as Windows metafile (EMF)..  » /
Save a5 PNG...
7 Save as postscript (EPS)... 445
Save a5 PDF...
st Copy to clipboard »
Save to session as icon 1 40
st Zoom..
Print »
sf Display PDF 135
Edit
sk Close
{30
2F
1 25
1990 1995 2000 2005 2010
1996.8.150 Right-click on graph for menu RN NEASE 3
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Example 3.4.1. Time series graphs. Chicken consumption.

The session can be accessed from the Toolbar by clicking on the icon session icon
view. You may see the graph saved as the icon Graph 1.

gretl: icon view ESREON >
Data info Data set Summary Correlations
3 3 25
B8
Model table Scalars Notes Graph page
Graph1
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Example 3.4.1. Time series graphs. Chicken consumption.

To change the name of this icon, right-click on the icon Graph 1 and select the
option Rename from the pulldown menu. Give a name to the icon in the dialog

box, for instance, on a single graph.

gretl: icon view

(2O ]

B

Data info Data set Summary
Model table Scalars Notes

E Display

Edit plot commands
Rename

Delete

Copy

Gra

(Pl

Correlations

B5)
=[]

Graph page

gretl: rename object NES

Enter new name
(max. 31 characters)

on a single graph

Cancel l I oK
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Example 3.4.1. Time series graphs. Chicken consumption.

To represent several time series in separate small graphs, go up to the Menu Bar
and click

View -> Multiple graphs -> Time series ...

“ gretl (2) Lﬂlﬂﬂ

File Tools Data View Add Sample Variable Model Help

chicken.gdt Icon view ’
»

ID # 4 Variable nami ‘

Graph specified vars
0 const -
—— - _XVS“L_
| 2 X Summary statistics Time series.-
33 Correlation matrix m)
4 X4 Cross Tabulation
5 X Principal components
6 X6 Mahalanobis distances avian flu epidemic
Cross-correlogram

Annual: Full range 1990 - 2012
BOEACREL L ABED
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Example 3.4.1. Time series graphs. Chicken consumption.

Select the variables Y, X2, X3, X4 and X5 in the dialog box.

Pilar Gonzélez and Susan Orbe | OCW 2014

A gretk: define graph ]

Select variables to plot

v v

x X

B B

x4 x4

x5 X5

X6

Hlp | [ ger |[ cance ][ o
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Example 3.4.1. Time series graphs. Chicken consumption.

The window gretl:graph shows five separate graphs, one for each variable.

B grett: graph Lo o

In order to save this graph as an icon in the session follow the procedure explained
above. Give the name separate graphs to this icon.
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Example 3.4.1. Time series graphs. Chicken consumption.

To save the session, go up to the Menu Bar and click
File -> Session files -> Save session as...

Mot E=REel ™

File Tools Data View Add Sample Variable Model Help

Open data »
Append data... | <
[& savedata Ctrl+S
E Save data as. mption per capita (in kilograms)
L bme per capita (in euros)
S n (in euros/kilogram)
Send To... in euros/kilogram)
) New dataset Ctrl=N n euros/kilogram)
& Clear data set lu epidemic, =2 if avian flu epidemic
Working directory...
Script files »
Session files * | [ Open session...
Databases > E Sa .
Save session
Eunction files 4
[& Save session as...
o Quit Cti+Q

ik, gretl
2. salarios2.gretl
3. salarios.gretl

@2 R E 4. Sespizza.gretl

A
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Example 3.4.1. Time series graphs. Chicken consumption.

Look for the folder where you want to save the session (in this case, the Desktop)
and write the name of the session, Seschicken.

et

Neme: Seschicken

— =

Places ~ | [Name

€, Search B sespizza.gret!
@ Recently Used

[ grett =
.

F) Desktop

& Sistema (C:)

& Datos (D) -

-

“ Size

27kB Unknown

Cancel | [

Create Fo!devl

Modified »

Save
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Example 3.4.1. Time series graphs. Chicken consumption.

Results.

e All the variables increase steadily over time. The long-term behaviour of the
series is called trend. Therefore, we could say that these variables show all an
upward trend.

e Chicken consumption increases over the whole sample but for the years 2002
to 2005.

e Income per capita increases continuously throughout the sample. Its rate of
growth seems to be higher from 2002 onwards.

e The price of chicken oscillates around the value 1.6 until the year 2002. From
this year onwards, the price increases quite rapidly.

e The prices of pork and beef increase over the whole sample.
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Example 3.4.1. Time series graphs. Visitors to Bilbao.

Questions.

Open the file tourism.gdt and graph the variables TV, SPV, and F'V.

a. Represent the three variables on a single graph. Save the graph as an icon to
the session.

b. Represent the three variables in three separate graphs. Save the output as an
icon to the session.

c. Save the session with the name Sestourism.

d. Interpret the results.
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Example 3.4.1. Time series graphs. Visitors to Bilbao.

View -> Graph specified vars -> Time series plot ...

and select the variables TV, SPV and FV.

gretl: graph

90000 T T T

v
SPV
80000 [ FV —— A 4

|

70000 [ N4
I\ I

60000 [ \ Ap
LAAN M I

50000 -

LW

1)
o0 | W AP
A
v

17
r H

30000 [

20000 - k|

10000 [

° L L s L
1995 2000 2005 2010

Right-click on graph for menu op=R NEA=E §
AN

Z |
Bigger | DisplayPDF gy
Smaller
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Example 3.4.1. Time series graphs. Visitors to Bilbao.

There is a menu at the bottom of the graph window that enables us to:

e Enlarge the graph: Bigger.
e Reduce the size of the graph: Smaller.
e View the graph in pdf format: Display PDF.

e Change the characteristics of the graph: Edit.

Follow the procedure explained before to save this graph as as icon to the session.
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Example 3.4.1. Time series graphs. Visitors to Bilbao.

View -> Multiple graphs -> Time series ...

and select variables TV, SPV and FV.

B4 grett graph [ESR )
™ e
s0000 ss000
70000 ) I w0
60000 N J '
0
Dl =0 il
ped SRR Ju, LLIAL =
20000 ‘,,“p N T A
20000 (VY 15000 r
10000 10000
195 199 2002 2005 2010 199 199 2002 2005 200
W
<0000
35000 H
[ |
25000 {)"\‘!‘H‘
20000 | A
15000 U" llw‘\\ \‘
10000 f
5000 o
199e s 2002 2006 2010
Right-click on graph for menu - I=E 3

Follow the procedure explained before to save this graph as as icon to the session.

Finally, save the session in your own folder with the name Sestourism.
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Example 3.4.1. Time series graphs. Visitors to Bilbao.

Results (I).

The data in the file are tourist data, in particular, the number of visitors to
Bilbao. Furthermore, they are monthly data.

A visual inspection of the time series plot in slide 19 shows that the three
variables present a cyclical pattern, which is more regular in the case of total
visitors (red line) than in the case of foreign visitors (green line).

Looking at the data carefully, it may be concluded that the period of the cycle is
always one year with the peaks in the summer months (July and August) and the
troughs in the winter months (December, January, February).

This one-year periodic, repetitive, and generally regular pattern is called
seasonality. Therefore, it may be concluded that the series of visitors to Bilbao
show monthly seasonal behaviour.
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Example 3.4.1. Time series graphs. Visitors to Bilbao.

Results (II).

e |t may observed that the series of foreign visitors oscillates around a constant
level until 1998 without a clear seasonal pattern. From 1999 onwards, the level
of visitors increases and the seasonal pattern is quite clear (there is a
concentration of foreign visitors in summers).

e The evolution of the series of visitors coming from Spain is quite different. A
seasonal cycle may be observed from the beginning of the sample although it
changes over time. Spanish visitors are not concentrated in summers like
foreigners: there are other peaks in the annual cycle related to Eastern,
beginning of autumn, ... This is due to the fact that for the Spaniards Bilbao is
not only a summer destination but a week-end destination as well. Therefore
we find peaks of visitors in summers and in periods related to short holidays.

e Analysing the temporal evolution of the visitors, it may be concluded that the
number of visitors increases over time, that is, they present an upward trend.
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© 3.4.2. Scatterplots.
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Example 3.4.2. Scatterplots.

Questions.

a. Open the file pizza.gdt and graph:
e Consumption against income.
e Consumption against age.
e Income against age.
e Consumption against income and age.

Save all the graphs as icons to the session.
b. Save the session.
c. Interpret the results.

d. Compare the results obtained in this graphical analysis with the conclusions
you drew from the descriptive analysis carried out in Example 3.3.
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Example 3.4.2. Scatterplots.

To obtain scatterplots, go up to the Menu Bar and click

View -> Graphs specified vars -> X-Y scatter...

B el

File Tools Data View Add Sample Variable Model Help
pizza.gdt Icon view l

# 4 Variabl, “
1D ariable nami e R speciedvars » Time series plot

0 const -
Multiple graphs » | XY scatter..

2 F Summary statistics X-Vwrth!mpulses... .

3 HS Correlation matrix :: wvt: factoy :eparatlon".

4 c Cross Tabulation o "I"' T

5 P Principal components ;°"P ‘f"'; |

6 income Mshalanobis distances Eactorized boxplot,

7 age Cross-correlogram 39[;‘7"":‘“'

8 |_piza = log of pizza EHEEE

9  sqincome = income squared

10 sqage = age squared

1 f F*income

12 ]’ income*age

13 pizzaT pizza/1000

Undated: Full range 1 - 40

BZOE~BEL ABD
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Example 3.4.2. Scatterplots.

Choose in the dialog box the variable that goes in X-axis (income) and the
variable that goes in the Y-axis (pizza).

B grett: define graph (=] © ]
XY scatterplot
pizza X-axis variable
HS
C Y-axis variables
P pizza
income
age | @
|_pizza L—J
sq_income
sq_age
- @
1A
pizzaT
Help Clear ] Cancel ] oK
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Example 3.4.2. Scatterplots.

The output is a graph containing the cloud of points (X,Y’) and the OLS fitted
line (see Lesson 5).
Pizza consumption versus Income

A grett: graph.

[ESREE> )

pizza versus income (with least squares fit)

Y =129. 4 112X —— *

pizza

° Lt L L

50 100 150 200 250
income

Right-click on graph for menu CEeR - JEASR

Pilar Gonzélez and Susan Orbe | OCW 2014

Example 3.4 Graphics in Gretl



Example 3.4.2. Scatterplots.

Pizza consumption versus Age Income versus Age
B grett: graph [E=TEE™ greth: graph Lo
600 income versus age (with least squares fit)
500 -
wl . .
N 200 |-
- + +
% 300 H
200 . 100 * .
w00} AR t ) ol + ) +
+ et 4 b
t + + 1 N
+ + T re+ +
5 L L L s s ' s s ° L L L L L L L
| %9249 Right-click on graph for menu CER- HERSE 3 Right-click on graph for menu CReR HER=R

Follow the procedure explained above to save each graph as as icon to the Gretl
session.
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Example 3.4.2. Scatterplots.

To obtain several scatterplots on a single graph, go up to the Menu Bar and click

View -> Multiple graphs -> X-Y scatters...
B oretl (2| © )

File Tools Data View Add Sample Variable Model Help
pizza.gdt Icon view

EX] i Al
D Variable nam( T e 5

0 const Multip! . 5

i

e =

2 F Summary statistics SIME SEres...

3 HS Correlation matrix igh school diploma

4 C Cross Tabulation college diploma

5 P Principal components post graduate degree

6 income Mahalanobis distances llars

7  age s-correlogram

8 |pizza = log of pizza

9 sq_income = income squared

10 sq_age = age squared

1 A Ffincome

12 1A income*age

13 pizaT pizza/1000

Undated: Full range 1 - 40

BZOEABEL F aBD
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Example 3.4.2. Scatterplot

Choose in the dialog box the variable that goes in Y-axis (which is the same for all
the scatterplots) and the variables that go in the X-axis.

gretl: define graph B
multiple scatterplots
pizza Y-axis variable []
: % |
izza
s » |
c X-axis variables
P income
income age
age — 1
I_piza e A
sq_income
sq_age
§ [« ]
A
pizzaT
@ Use points
Use lines
Help Clear Cancel oK
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Example 3.4.2. Scatterplots.

The output window shows two scatterplots, the first one graphs consumption
against income and the second one consumption against age.

B grett: graph SRR

pizza
pizza

income age
Right-click on graph for menu ISR 4

Follow the procedure explained above to save this graph as as icon to the Gretl session.
Finally, save all the changes to the session file called Sespizza.
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Example 3.4.2. Scatterplots.

Results (comparing to Example 3.3.)

e The scatterplot of consumption against income shows a positive relationship between
these two variables, that is, richer clients consume more pizza. This result coincides
with the positive correlation coefficient between consumption and income obtained in
Example 3.3.

e The scatterplot of consumption against age does not show a clear relationship
between these two variables. Although consumption of pizza is low for clients older
than 45, you may observe high levels of consumption for a wide range of ages.

This result coincides with the value of the correlation coefficient between
consumption and age obtained in Example 3.3, -0.21, negative and small.

e The scatterplot shows a positive relationship between age and income. Remember
that in Example 3.3 we obtained a positive correlation coefficient between age and
income (0.4685).
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e 3.4.3. 3D scatterplot graphs.
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Example 3.4.3. 3D scatterplot graphs.

Questions.

Open the data file chicken.gdt and plot chicken consumption against income
and price of chicken.

View -> Graph specified vars -> 3D plot ...
Hoet B
File Tools Data View Add Sample Variable Model Help
chicken.gdt Icon view l
D24 Varisble nan e > Timeseries plot.. *
0 const B
Multiple graphs. P XVscatter..

XY with impulses...
‘Summary statistics e

Correlation matrix
Cross Tabulation

X-Y with factor separation...
X-Y with control...

EUEES

Boxplots...
principal components o o
Fhebaiatcis deteces O e
Cross-comrelogram Q-Qplot...

30 plot...
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Example 3.4.3. 3D scatterplot graphs.

Select the variable that goes in each axis.

EA gret: define graph [E‘Elg
3D plot
Y X-axis variable
X2
X3 X2
X4
X5

&

[] Show lagged variables

Y-axis variable

Z-axis variable

b |

Clear | [ conca | [ ok
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Example 3.4.3. 3D scatterplot graphs.

The result is a 3D graph where the surface shows the relationship among Y, X2
and X3.

Esrrergnm ol 0 i
™ @ @ o options - 4142

e 0010, 30000 e 10000 100000
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Example 3.4.3. 3D scatterplot graphs.

To rotate the graph, click on any vertex using the right mouse button.

et o
W& W @oen s &1 42

v 20000, 2000 e 10000, 100000
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@ 3.4.4. Editing graphs.
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Example 3.4.4. Editing graphs.

Questions.

Open the data file chicken.gdt, plot chicken consumption (Y) against income
(X2) and edit the graph as follows:

a. Delete the OLS fitted line.

b. Write the title “Pizza consumption versus income”.

c. Change the default font to Calibri 10 bold.

d. Name the Y-axis “Pizza consumption” and the X-axis, “Income”.

e. Set new limits for the X-axis, minimum 340 and maximum 2550.

f. Change the point + to a blue square.

g. Add the label | > 1500.
h. Add a dotted vertical line in  |=1500.

v
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Example 3.4.4. Editing graphs.

To change the characteristics of a graph, right-click

option Edit from the pulldown menu.

on the graph and select the

B4 gret: graph o ]
Y versus X2 (with least squares fit)
60
Y ='28.0 + 0.0113X ——

ss|

50 N
Save a5 Windows metafile (EMF)...

sl Save a5 PNG... ]
Save a5 postscript (EPS)...

- N Save a5 PDF...
sl e+ Copyto clipboard » ]
B Save to session as icon
Al data labels
o+

sl + Zoom.. ]

print ,
7
Display POF
+* i

sl OLS estimates ]
Edit
Close

25 . . ! ) .

500 1000 1500 2000 2500
x2
10244827 Right-click on graph for menu CORER-NEASE
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Example 3.4.4. Editing graphs.

The dialog box allows to change several aspects of the graph: title, axis, lines, add labels,

arrows, ...

“ gretl plot controls

Malr! X-axlsl V-axisl Linal Labelsl Arrowsl Palette

Title of plot |V versus X2 (with least squares fit)

key position | left top

B[]

fitted line  |lineary = a + b™
¥| Show full border

Show grid |horizontal

font: verdana 8 J

|| Set as default

vep | [ apey |[ ok |[ gl

ample 3.4 Graphics in Gretl
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Example 3.4.4. Editing graphs.

In the

tab, it is possible to

e Delete the OLS fit, selecting fitted line: none.

o Write

Title of plot: Pizza consumption versus income.

e Change the font left-clicking on and selecting in the new dialog box the font Calibri

Pil

10 bold.

A greti plot controls ) gret grph o i
Paza consumption versus income
Main | X-axis | V-axis | Lines | Labels | Arrows| Palette -
Title of plot | Pizza consumption versus income N +
sof- -
key position | left top El
fitted li L
itted line | none [~] . .
V] Show full border + *
Show grid |horizontal mor S
"
font: Calibri Bold 10 ES *
Set as default N
30| H‘
25 . .
s00 1000 1500 2000 2500
vep | [ sy J[ ok [ cuose x
Right-clickon graph for men HoERE X
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Example 3.4.4. Editing graphs.

In the tab, it is possible to

o Change the name of the axis, writing Title for axis: Income.

e Change the range of values, clicking on manual range and writing the new minimum and maximum

values.
4 oretl plot controls [ B gt goph e et
- —— iz consumption verssincome
V-axis | Lines | Labels | Arrows| palette| .
Title for axis | income ol N N N 1
auto axis range - ]
© manual range: + N
minimum 340 - S 1
maximum 2550 ot
sl |
® linear scale wf 1
logarithmic scale, base: | & -] *
sl . . . .
s 1000 1500 2000 500
Hep | [ sepy J[ ok [ cose | ncome
24564990 Right-click on graph for menu Rl NEA=R
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Example 3.4.4. Editing graphs.

In the tab, it is possible to change the name of the axis writing Title for axis: Pizza consumption.

gretl plot controls > B —
- Pizza consumption versus income
| Main | X-axis| V-axis Lines| Labels | Arrows | palette| P : . . :
Title for axis | Pizza consumption sl + . N ]
© auto axis range as 4
manual range: . *
ini 0 et + ]
minimum .
maximum W
st g
@ linear scale ol o J
logarithmic scale, base: | & E .
2 n n L n L
500 1000 1500 2000 2500
Help ] [ Apply ] I oK ] [ Close ] ncome:
Right-click on graph for menu. EeRARZOD X
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Example 3.4.4. Editing graphs.

In the

To change the colour of the point left-click on color. Choose a colour in the dialog box.

gretl plot controls

(S

Meain | X-axis | Y-axis| Lines

Labels | Arrows| Palette

line 1: legend
type |points [=] point
tinewidth [1 %] color (Il
line 2: formula |27 6047 + 0.0113(
legend |Y = 280 + 0.0113X
line width |1 < color
Addlin
[ men ][ el o« [ |

gret: graph color selection

+Id

o 449> > o0 WO X X +

’ | e 2 & Bec
| ssturtion:  [100 Green
| value: 0 - Blue

20012F

o [ conce

mple 3.4 Graphics in

tab, it is possible to change the type of point, selecting in the points pulldown menu a square.

A grett graph Lo |
Piza consumption versus income
s
.
50 - - 4
.

s 1
. .
2 -
i Yo,
- "W . ]
H .
H
¢ 157

35 - 4

.
.-
0| - 1
.
P - " .
500 1000 1500 2000 2500
Right-click on graph for menu CEER - NEASE §

retl




Example 3.4.4. Editing graphs.

To highlight the area of the plot where income is higher than €1500, open the tab and click Add. In
the new dialog box write text: Income > 1500 and indicate the position of this label by clicking first on the

icon mouse and then on the point of the plot where you want the label to be.
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Example 3.4.4. Editing graphs.

To add lines or arrows open the

tab and click Add. In the new dialog box, select the option

line is dotted. To indicate the position of the line, click on the icon mouse and then on the point of the plot
where the line starts and on the point where the line finishes.
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