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Example 3.2.1. Adding new data.

More observations. J

New data are available on the variables included in the file chicken.gdt.

year| 2012

Y 529
X2 | 2478.7

X3 2.82

Enter this new observation in the file chicken.gdt manually and save all the
changes.
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Example 3.2.1. Adding new data. Observations.

To add new observations, select the option Add observations from the Data

pulldown menu:

Data -> Add observatioms...

gretl
File Tools Data
chicken.gdt
ID# ¢ Variab €
0 const
1 v
2 X2
3 3
il (2 7]
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View Add Sample Variable

Select all

Find variable...
Define or edit Jist...
Set selection from list...

Display values
Edit values
Add observations...

Remove extra observations

Dataset info
Observation markers...
Variable labels...

Dataset structure...
Compact data...
Expand data...
Transpose data...

Sort data...

Set missing value code...
Count missing values

O | B S
Model Help
Ctrl+A
Ctrl+F J

ros)

-2011
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Example 3.2.1. Adding

Add observations

ew data. Observations.

oS

Number of observations to add:

g

o |

o |

Number of new observat

Gonzalez and Susan Orl

jons: 1

[ gretl: edit data =8
x Y, 19%0
Y x 3

im0 27.8 397.5 1.69
I em 29.9 413.3 1.52
| e 29.8 439.2 1.61
[ 30.8 459.7 1.58
[T 31.2 492.9 1.49
19 3.3 528.6 1.52
[ 199 35.6 560.3 1.57
I 36.4 624.6 1.51
| om 36.7 666.4 1.54
[ 38.4 7.8 1.6
J— 40.4 768.2 1.54
[y 40.3 843.3 1.59
[ 0 4.8 911.6 1.59
I am 40.4 931.1 2.08
[ 00 4.7 1021.5 1.9
I s 40.1 1165.9 2.33

2.7 1349.6 2.2
[ 44.1 1449.4 2.26
[ 8 46.7 1575.5 2.55
[ 50.6 1759.1 2.46
[ o0 se.1 1994.2 2.36
I am 51.7 2258.1 2.66
I

>

new empty row is added
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Example 3.2.1. Adding new data. Observations.

Enter data manually and click on the icon Apply.

gretl: edit data (= | O )
& % X2, 2012
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Example 3.2.1. Adding new data.

More variables.

The prices of substitute goods, such as pork and beef, could be relevant to explain
chicken consumption. Let's denote:

X4: price of pork (in euros/kilogram).
X5: price of beef (in euros/kilogram).

Furthermore, the avian flu epidemic that lasted from 1999 to 2003 (both years
included) may have affected as well the temporal evolution of chicken
consumption. A binary variable has been defined to quantify this qualitative
information:

X6: = 1 if no avian flu epidemic, = 2 if avian flu epidemic
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Example 3.2.1. Adding new data. Variables.

The table below shows data on variables X4, X5 and X6.

year| 1990 | 1991 | 1992 | 1993 | 1994 | 1995 | 1996 | 1997 | 1998 | 1999 | 2000

X4 | 2.028 | 2.08 | 216 | 2212 | 2.188 | 2548 | 2.792 | 2.636 | 258 2.8 | 2928
X5 | 3.132 | 3.168 | 3.168 | 3.168 | 3.096 | 3.208 | 3.216 | 3.356 | 3.42 | 3.748 | 4.244
X6 1 1 1 1 1 1 1 1 1 2 2

year| 2001 | 2002 | 2003 | 2004 | 2005 | 2006 | 2007 | 2008 | 2009 | 2010 | 2011 | 2012
X4 | 2712 | 3164 | 3.816 | 3.768 | 4.94 | 5196 | 4.704 | 5236 | 519 | 512 | 564 | 6728
X5 | 4192 | 456 | 4964 | 5104 | 5.716 | 5744 | 5568 | 6.62 | 8132 | 8784 | 8.864 | 9.304
X6 2 2 2 1 1 1 1 1 1 1 1 1
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Example 3.2.1. Adding new data. Variables.

Questions.

a. Enter data on variables X4, X5 and X6 in the file chicken.gdt manually.
b. Label the new variables.

c. Define X6 as a discrete variable.

d. Write this information about the data file in the Gretl session:

Data come from file Table 7.9. (Gujarati sample folder).
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Example 3.2.1. Adding new data. Variables.

To add more variables, select the option Edit values from the Data pulldown
menu.

Data -> Edit values

gretl E‘E&

File Tools Data View Add Sample Variable Model Help

chicken.gdt Select all Ctrl+A
ID# 4 Variab @ Find variable... Ctri+F ‘
0 const
1 v Define or edit list... kilograms)
2 X Set selection from list... Fos)
3 a3

Display values
Edit values
Add observations...

Remove extra observations

Dataset info
Observation markers...
Variable labels...

Dataset structure...
Compact data
Expand data...
Transpose data...

Sort data 2011

(i) ELd Set missing value code...
—_— Count missina values
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Example 3.2.1. Add new data. Variables.

B grett: edit data E=3Tal™ ) "B gret: et data E=3Eal™ )
T 3,212 + 9K X4, 2012
Add Observation B v X B
Insert Observation 397.5 i 27.8 397.5 1.69
413.3 1 20.9 413.3 1.8
439.2 2.8 439.2 161
459.7 o 1m 3.8 459.7 1.58
492.9 312 492.9 1.49
528.6 s 1.3 528.6 1.5
560.3 [ 1% 35.6 560.3 1.57
624.6 3.4 624.6 151
666.4 o 1m 3.7 666.4 1.54
7.8 1w 3.4 77.8 1.6
768.2 0.4 768.2 154
843.3 I am %3 8433 1.59 3
9116 4.8 9116 1.59
%1.1 T w3 0.4 9311 2.68
1021.5 Ty 4.7 1021.5 1.9
1165.9 0.1 1165.9 2.33
1349.6 [ e 2.7 1349.6 2.2
1449.4 I 4.1 1449.4 2.26
1575.5 4.7 1575.5 2.55
1759.1 [ am 50.6 1759.1 2.46
1004.2 6.1 1094.2 2.3
258.1 517 258.1 2.66 i
2478.7 a2 52.9 278.7 2.82 6.728) -
Click on the icon -+ Once the name of the variable is written,
and select Add Variable enter the data

Repeat this procedure for variables X5 and X6.
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Example 3.2.1. Adding new data. Variables.

| grett: edit data ihE)
$9OR 6, 212
Y © B " 5 3 -
ey 2.9 3.3 12 2.8 3.168 1
| 2.8 2.2 16 2.1 3.168 1
.8 507 158 221 3.168 1
a2 .9 149 2.1 3.0 1
53 8.6 122 2.5% 3268 1
5.6 0.3 157 2.9 3206 1
®.4 6.6 151 2.6% 3.3% 1
.7 656.4 15 2.5 3.2 1
e s 16 2.8 378 2
0.4 766.2 154 2.0 s.2u 2 B ol L
@3 3.3 159 2.m 412 2|
s s L5 e s N Fle Tooks Data View Add Semple Verable Model Help
0.4 %L1 2.08 3.816 .96 2 IR
ID # ¢ Variable name ¢ Descriptive label Al
@7 1025 1% 3768 5104 1 P
0L 29 .5 9 ) L
Q27 13496 2.2 5.5 5.7 1 2 disposable income per capita (i euros)
@1 1449.4 2.26 4.704 5.568 1 3 8 price of chicken (in euros/kilogram)
4.7 1575.5 2.55 5.2% 6.62 1 4 X
5.6 1759.1 2.4 512 812 1 SIS
s0.1 19%¢.2 2.3 s 8.78 1 e
517 2581 2.6 s.64 8.804 1
ae P, re P, ot file Annuak Full range 199 - 2012
i y @ (2 ) ARAELEaBD
Once the data are entered, The main window shows the three new
click on the icon Apply variables without any descriptive label
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Example 3.2.1. Adding new data. Variables.

To edit the variable characteristics, highlight the variable, right-click and select
the option Edit attributes from the pulldown menu.

Then follow the procedure explained in Example 3.1.3.

The result is shown in the figure below.

gre(l EM
File Tools Data View Add Sample Variable Model Help

chicken.gdt

ID # 4 Variable name ¢ Descriptive label Al
0 const

disposable income per capita (in euros)
price of chicken (in euros/kilogram)
price of pork (in euros/kilogram)

price of beef (in euros/kilogram)

aun e W
FEESK

=1 if no avian flu epidemic, =2 if avian flu epidemic

Annual: Full range 1990 - 2012
@BROE~BAEL 2 aB5
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Example 3.2.1. Adding new data. Variables.

To define the variable Xg as a discrete variable, highlight the variable X6,
right-click and select the option Edit Attributes from the pulldown menu. Then,
mark Treat this variable as discrete.

gretl: variable attributes E)
Name: | X6 1D number: 6 S
Description:

=1 if no avian flu epidemic, =2 if avian flu epidemic
Display name (shown in graphs):
Compaction method (for reducing frequency):  not set E]

[¥] Treat this variable as discrete

Cgoe J[ox )

Don't forget to save all the changes in
the file chicken.gdt before quitting Gretl !
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Example 3.2.1. Adding new data. Variables.

To enter and save information about the data file, click on the icon session icon
view in the main window Toolbar. Then, double-click on the icon Data Info.

B8 grett: icon view E@lﬂ
Data info Summary Correlations
3 3 Ele
=]=]
Model table Scalars Notes Graph page
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Example 3.2.1. Adding new data. Variables.

Given that there is no previous information about this data file, you are asked
whether you want to add some.

B grett: icon view = B %

gretl: add info

The data file contains no informative comments. |
Would you like to add some now?

Clicking Yes brings up an empty window where you can write some notes. To
save this information click on the left icon (Save) in the menu bar of the edit
data info window.
grett: edit data info (2| E
HeX0UD0AB 9N

pata come from file Table 7.9 (Gujarati sample folder)
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@ 3.2.2. Importing data from other files.

Pilar Gonzélez and Susan Orbe | OCW 2014 Example 3.2 Modifying Gretl data files



Example 3.2.2. Importing data from other files.

Visitors to Bilbao.

Consider that both the Hospitality Price Index and the economic situation may be

relevant factors to explain the temporal evolution of the number of visitors to
Bilbao.

The Excel data file tourism.x1s (sheet called Other variables) contains
information on:

HPIR: monthly variation rate of the Hospitality Price Index in Biscay.
IPI: Spanish Industrial Production Index (raw data).
IPIR: annual variation rate of Spanish IPI.

Add these data to the Gretl file tourism.gdt. Label the new variables and save
all the changes in the data file tourism. gdt.

Pilar Gonzélez and Susan Orbe | OCW 2014 Example 3.2 Modifying Gretl data files




Example 3.2.2. Importing data from other files.

You may import data from an Excel file to an existing Gretl file, selecting the
option Append data from the File pulldown menu.

File -> Append data...

“ gretl E‘M
File Tools Data View Add Sample Variable Model Help
Open data »
Append data... el L]
E Save data Ctrl+S
@ Sove datazs. [ —
Export data...
Send To...
1 New data set Ctrl+N

é Clear data set
Working directory...

Script files

>
Session files 4
Databases »

>

Function files hly: Full range 1993:03 - 2012:12

& Quit aQ [f 2 B D
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Example 3.2.2. Importing data from other files.

Select the folder where your Excel file is (in this case, the Desktop), choose the

file turismo.x1s where the data are and open it using the Open button at the
bottom of the window.

B gretlexe ]

Location: | tourism.xls

Places + | Name ~ Size Modified »

?\ Search h tourism.xls 573kB Unknown

@ Recently Used
ly

[ Desktop =

[ Desktop

i

& Sistema (C)
« Datos (D)

=

Excel files (*ds) []
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Example 3.2.2. Importing data from other files.

From this dialog box, select:

o the sheet of the Excel file where the data are (Other variables).

e the column and the raw where the data start (including the row with the
names of the variables).

gretl: spreadsheet import g

Start import at:

column: |1 row: |1

(A)
Sheet to import:

Visitors series

| Produce debugging output
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Example 3.2.2. Importing data from other files.

The main window shows the three new variables imported.

gretl E@g

File Tools Data View Add Sample Variable Model Help

tourism.gdt *

ID # ¢ Variable name ¢ Descriptive label il
0 const

2 SPV

3 W

4 HPRR

5 IP1

6 IPIR

Monthly: Full range 1993:03 - 2012:12
@2 rBELE 2 aBD
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Example 3.2.2. Importing data from other files.

To edit the characteristics of the variables, select a variable, go up to the Menu
Bar and click Variable -> Edit attributes.

Replicate the procedure explained in Example 3.1.3.

The result is shown in the figure below.

gretl E@&
File Tools Data View Add Sample Variable Model Help
tourism.gdt *

ID # ¢ Variable name ¢ Descriptive label <
0 const
1 TV total number of visitors
2 SPV visitors coming from Spain
4 HPIR monthly variation rate of Hospitality Price Index (HPI) in Biscay
5 1IPI Spanish Industrial Production Index (raw data)
6 IPIR annual variation rate of Spanish IP

Monthly: Full range 1993:03 - 2012:12
@O ~BEL 2 8B 5

Don't forget to save all the changes in
the file tourism.gdt before quitting Gretl !
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© 3.2.3. Generating new variables.
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Example 3.2.3. Generating new variables.

Pizza consumption.

1. Load your file pizza.gdt.

2. Add the logarithm of pizza consumption.

3. Add the squares of income and age.

4. Add the variables FI = (F x income) and IA = (income X age).

5. Add the variable pizza consumption measured in thousands of dollars instead
of in dollars (pizzaT).

6. Save all the changes in your Gretl file pizza.gdt.
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Example 3.2.3. Generating new variables.

To add logarithms, highlight the desired variables, and select the option Logs of
selected variables from the Add pulldown menu.

Add -> Logs of selected variables

B gret |

File Tools Data View Add Sample Variable Model Help

pizza.gdt Logs of selected variables
ID# 4 Variable name ¢ De:  Squares of selected variables 3
0 const Lags of selected variables
1 piza a First difference: elected variables
2 F =1 Log differences lected variables
3 HS =1 Seasonal differences of selected variables
4c - Index variabl
SBE _ Index variable
. Time trend
6 income an
Panel unit index
7 age ag

Random variable...

Periodic dummies
Unit dummies

Time dummies

Observation range dummy

Dummies for selected discrete variables

Define new variable...
G (2 7] B fx ) Define matrix...
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Example 3.2.3. Generating new variables.

To add squares, highlight the desired variables and select

Add -> Squares of selected variables

W oo

File Tools Data View Add Sample Varisble Model Help

pizza.gdt * Logs of selected variables
ID# 4 Variable name 4 Det  Squares of selected variables Rl
0 const Lags of selected variables
1 pizza an  First differences of selected variables
2 F = Log differences of selected variables
3 Hs = Seasonal differences of selected variables
e < Z]  Indexvariabl
5D _ Index variable
= Time trend
6 income al
Panel unit index
7 age ag|
8 |pizza =1  Random variable...

Periodic dummies
Unit dummies

Time dummies

Observation range dummy

Dummies for selected discrete variables

Define new variable...

@ (2 ) = fx T Define matrix..

Note that the logarithm of pizza consumption, generated previously, is shown in the main
window with the name assigned by default, |_pizza.
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Example 3.2.3. Generating new variables.

To generate a new variable from others included in the data file, go up to the
Menu Bar and click

Add -> Define new variable...

gretl (2| & ]

File Tools Data View Add Sample Variable Model Help

pizza.gdt * Logs of selected variables

ID # 4 Variable name ¢ De{ Squares of selected variables A
0 const L f sele les
1 piza an
2 F =
3 HS =
4 C =1 X
5 Index variable

P = =
Time trend
|6 _income ____an) Panel unit index
age ag

|_pizza | Random variable...
i

w0 ~

9 sq_income =1
10 sq_age =

Observation range dummy
Dummies for selected discrete variables

Define new variable...

il (2 7] ) fx ]  Define matrix..
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Example 3.2.3. Generating new variables.

E¥ gretl: add var (]

Enter formula for new variable
(or just a name, to enter data manually)

[ Hep [ cance J[ ok |

Write down the formula for the new variable in the dialog box using the following
operators:

Operators
Addition + Subtraction -
Multiplication * Division /
Square root sqrt(x) Exponent G
Logarithms log(x) Exponential (e®)  exp(x)
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Example 3.2.3. Generating new variables.

gretl: add var S

Enter formula for new variable
(or just a name, to enter data manually)

FI=F*income

I Help ] l Cancel l [ oK

Variable F'I

B4 greti: add var et

Enter formula for new variable
(or just a name, to enter data manually)

IA=income*age|

[ bep J[ comea |[ o

Variable TA

" grett: add var Cx)

Enter formula for new variable
(or just a name, to enter data manually)

pizzaT=pizza/1000]

Hep || Gamca |[ ok

Variable pizzaT (thousands of dollars)
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Example 3.2.3. Generating new variables.

The main window shows the three new variables with the names assigned in the
formulas. The label of each variable is given by the formula used to generate it and it
may be changed editing the attributes.

"R o
Eile Tools Data View Add Sample Variable Model Help
pizza.gdt
ID # 4 Variable name ¢ Descriptive label <
0 const
2 F if female
3 HS =1 if highest degree received is high school diploma
4 C =1 if highest degree received is a college diploma
5 P =1 if highest degree received is a post graduate degree
6 income annual income in thousands of dollars
7 age age in years
8 |Ipizza = log of pizza
9 sqincome = income squared
10 sq_age = age squared
1 [ F*income
12 1A income*age
13 pizzaT pizza/1000
Undated: Full range 1 - 40
@ROR~BEL 2 aB 5

ii Do no forget to save all the changes in
the data file pizza.gdt before quitting Gretl!
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@ 3.2.4. Simulating variables.
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Example 3.2.4. Simulating variables.

New data file.

1. Create a new data set of 500 observations (cross-section).
2. Simulate u from a normal distribution of mean 0 and variance 16.

3. Simulate X5 from a uniform distribution between 20 and 50, and X3 from a
Poisson distribution of mean 3.

4. Simulate variable Y as follows:
Y =—-4+ X, —-5X3+u

5. Write down some notes about the simulation of the data set and save them
in the session.

6. Save the data in a Gretl file called simulate.gdt.
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Example 3.2.4. Simulating variables.

To create a new data set, go up to the Menu Bar and click

File -> New data set

From the dialog windows shown below, you tell Gret the number of observartions
and the structure of the data set.

“ Data structure wizard E
Structure of dataset
gretl: create data set &
Time series
Number of observations: | 500| - S Panel
[ Cancel ] ’ OK l { Cancel ] [ Forward }
Write the number of observations Select the type of data
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Example 3.2.4. Simulating variables.

Confirm the characteristics of the file (number of observations and type of data), clicking
Apply. DO NOT mark start entering data values because you are not going to enter any
data. The data will be artificially generated.

The main window shows only an index that goes form 1 to 500.

ot [ e

File Tools Data View Add Sample Veriable Model Help
Unsaved data

ID# 4 Variable name 4 Descriptive label ‘
0 const
1 index index variable

Undated: Full range 1 - 500

@20FE~BAEL 8 AaBG
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Example 3.2.4. Simulating variables.

To simulate a random sample from a specific distribution, select the option
Random variable from the Add pulldown menu.

Add -> Random variable...

B gt oo .

File Tools Data View Add Sample Variable Model Help

Unsaved data Logs of selected variables

ID # ¢ Variable name 4 De¢ Squares of selected variables <
0 const Lags of selected variables
1 index in{  First differences of selected variables

Log differences of selected variables

Seasonal differences of selected variables

Index variable

Time trend

Panel unit index

Random variable...

Periodic dummies

Unit dummies

Time dummies

Observation range dummy

Dummies for selected discrete variables
Define new variable...

m (2 ] ofx m Define matrix...
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Example 3.2.4. Simulating variables.

Select the normal distribution tab, write down its parameters (mean = 0, std. deviation
=4) and give a name to the new variable (u).

gretl: add random variable (2] O [

uniform| normal | + [ chi-square | | gamma binomial poisson | weibul

mean 0
std. deviation 4

name | o

‘ Help Close oK

Select the uniform distribution tab, write down its parameters (minimum = 20,
maximum = 50) and give a name to the new variable (X2).

Bl oreti: add random variable (2B js

uniform | normal | t | chi-square | F | gamma| binomial | poisson [ weibull

minimum |20
maximum |50

name X2
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Example 3.2.4. Simulating variables.

Select the Poisson distribution tab, write down its parameter (mean = 3) and give a
name to the new variable (X3).

A grett: 2dd random variable oG

e o) g v o s I e |

mean 3

name X3

Help Close oK

To generate variable Y, go up to the Menu Bar, select Add -> Define new variable
and write down the formula.

gretl: add var @

Enter formula for new variable
(or just a name, to enter data manually)

Y=-4+X2-5"X3+u

Hep | [ canee ][ o

Pilar Gonzélez and Susan Orbe | OCW 2014 Example 3.2 Modifying Gretl data files



Example 3.2.4. Simulating variables.

The main window shows all the simulated variables with their assigned names.

The label of the variables is given by the distribution they come from or the
formula used to generate them.

H gret @

File Tools Data View Add Sample Variable Model Help

Unsaved data

ID# ¢ Variable name 4 Descriptive label <
0 const
1 index index variable
2 u randgen(N,0,4)
3 X randgen(u,20,50)
4 3 randgen(P,3)
5 Y -4+X2-5"X3+u

Undated: Full range 1 - 500
@2E~RELE P aBD
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Example 3.2.4. Simulating variables.

Click on the icon session icon view in the main window Toolbar. Then click on the
icon Data info.

Write down the information in the empty window and then click on the left icon

(Save).

gretl: edit data info [ESECNE ]
B8 & D0OXR ® DR

These data set consits of simulated data.
Variable Y is generaged as:
Y =-4+X2-5X3+u
where
X2 comes from a uniform distribution between 20 and 50

X3 comes from a Pisson distribution with mean 3
u comes from a normal distribution with zero mean and variance 16
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Example 3.2.4. Simulating variables.

To save these data in a Gretl file, click

File -> Save data as

Select the folder to save the file (in this case, the Desktop), write the name of the
file, simulate.gdt, and click Save.

A gretiexe oo
Name: simulate.gdt
Save in folder: \J[Users - [~) Desktop Create Folder
Places ~ | [Name  Size  Modified
4 Search G chicken.gdt 18kB Unknown
@ Recently Used £ ¢ pizzagdt 52kB  Unknown
[ gret! € tourism.gdt 11.0kB Unknown |=
[E) Desktop ~ -
& -

Gretl datafiles (*.gdt) [~]

Compression level (0 = none) 0

[ cancel Save
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