Creacion y distribucion de aplicaciones

Esta leccion describe el proceso de crear un instalador y una aplicacién
independiente para sus proyectos de LabVIEW.
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C. Construccion de la aplicacién y el instalador



A. Caracteristicas de LabVIEW para el desarrolio de proyectos

Historial del VI

Jerarquia del Vi

LabVIEW ofrece varias caracteristicas que puede usar para gestionar sus
proyectos con mas eficacia.

Una de las herramientas mas ttiles de LabVIEW para el desarrollo
orientado a equipos es la ventana History. Use la ventana History para
mostrar el historial de desarrollo de un VI, incluidos los ndmeros de
revisién. Seleccione Edit»VI Revision History para abrir la ventana
History. También puede imprimir el historial de revisién o guardarlo en un
archivo HTML, RTF o de texto. El nimero de revisién empieza en cero y
aumenta cada vez que guarde el VI. Registre y siga los cambios que realice
en el VIen la ventana History a medida que los efectie. Seleccione Edit»
VI Revision History para abrir la ventana History. (

Seleccione File» VI Properties y Revision History en el mend desplegable
Category. La pigina Revision History del cuadro de didlogo VI /
Properties y la pdgina Revision History del cuadro de didlogo Options
contienen opciones similares. Use el cuadro de didlogo VI Properties para
configurar opciones del VI actual. Use la pagina Revision History del

cuadro de didlogo Options para configurar opciones para todos los VIs

nuevos. 1

Ahorrar memoria es una ventaja importante de separar su aplicacion
principal en subVlIs. El uso de subVIs facilita la lectura, depuracidn, ,
comprension y mantenimiento del diagrama de bloques de alto nivel. (

Por lo tanto, intente que el diagrama de bloques de su VI de nivel superior y
no supere los 500 KB de tamafio. En general, reduzca el tamaio de los |
subVls. Para comprobar el tamafo de un VI, seleccione File» VI Properties
y Memory Usage en el ment desplegable Category. Normalmente debe
dividir un VI en varios subVIs si el diagrama de bloques de su VI es
demasiado grande para caber completamente en la pantalla.

La ventana VI Hierarchy muestra la jerarquia de llamadas para todos los
VIs en memoria. La ventana muestra definiciones de tipos, variables
globales, clases y VIs de miembros dindmicos de LabVIEW, bibliotecas
compartidas de XControls, archivos .m a los que hace referencia desde
nodos MathScript, VIs Express y referencias de VI estéticas. Seleccione (
View» VI Hierarchy para ver la ventana VI Hierarchy. Use esta ventana

para ver los subVIs y otros nodos que conforman los VIs en memoria y para
buscar la jerarqufa del VI.




Use la barra de herramientas en la parte superior de la ventana VI Hierarchy
para mostrar u ocultar varias categorias de objetos utilizados en la jerarquia,
como variables globales o Vls incluidos con LabVIEW, asi como si la
jerarquia se expande horizontal o verticalmente. Un VI que contiene subVlIs
tiene un botén de flecha en su flanco inferior. Haga clic en esta fecha para
mostrar u ocultar subVIs. Aparece un botdn de flecha roja cuando se ocultan
todos los subVIs. Aparece un botén de flecha negra cuando se muestran
todos los subVls.

La ventana VI Hierarchy de la figura 7-1 contiene la jerarquia del proyecto
Weather Station creado en este curso. Los VlIs del directorio de LabVIEW
vi.1lib no se muestran. Haga clic con el botén derecho en una zona en
blanco de la ventana y seleccione Show All VIs en el menti contextual para
mostrar toda la jerarquia.

® @66 OO
ﬁ V1l Hierarchy
File Edit wiew ]’_W:»l:' yindow ﬂelv
(8] [a]<€] FIES
N .
) &)
(‘l’v‘"l
Lt
e
Y
v
< 3
1 Rehacer el esquema 4 Incluir VI Lib
2 Esguema vertical 5 Incluir globales
3 Esquema horizontal 6 Incluir definiciones tipo

Figura 7-1. Ventana VI Hierarchy



Cuando mueve el cursor por los objetos de la ventana VI Hierarchy,
LabVIEW muestra el nombre de cada VI en una ayuda. Puede usar la
herramienta de posicionamiento para arrastrar un VI de la ventana VI
Hierarchy al diagrama de bloques para utilizar el VI como un subVIen otro
VI. También puede seleccionar y copiar un nodo o varios al portapapeles y
pegarlos en otros diagramas de bloques. Haga doble clic en un VI de la
ventana VI Hierarchy para ver el panel frontal de ese VI. La ventana

VI Hierarchy es una vista dindmica de lo que estd en memoria. Si
reorganiza elementos de la jerarquia, LabVIEW no guarda la nueva posicién
de los elementos. Cuando cierra la ventana VI Hierarchy, se regeneran las
posiciones originales.

También puede buscar un VI en la jerarquia escribiendo el nombre del
elemento que desee encontrar en cualquier parte de la ventana. Cuando
escriba el texto, aparecerd la cadena de caracteres de busqueda, mostrando
el texto a medida que escribe. LabVIEW resalta un elemento a la vez cuyo
nombre empieza por la cadena de caracteres de busqueda. Si hay mds de
un elemento con un nombre que empieza por la cadena de caracteres de
basqueda, pulse la tecla <Intro> para buscar el siguiente elemento que
coincida con la cadena de caracteres de busqueda. Pulse las teclas
<Mayts-Intro> para buscar el elemento anterior que coincida con la cadena
de caracteres de busqueda.

Use la ventana VI Hierarchy como herramienta de desarrollo al planificar o
implementar su proyecto. Por ejemplo, tras desarrollar un diagrama de flujo
de los VIs necesarios para una aplicacién, puede crear desde la parte inferior
de la jerarquia hasta arriba cada uno de estos VIs para que tenga todas las
entradas y salidas necesarias en sus paneles frontales y los subVIs llamados
en sus diagramas de bloques. Esto crea la jerarquia de la aplicacién bdsica
que ahora aparece en la ventana VI Hierarchy. A continuacion, puede
empezar a desarrollar cada subVI, como codificar con color sus iconos, que
también se colorea en la ventana VI Hierarchy para reflejar su estatus. Por
ejemplo, los iconos blancos pueden representar VIs sin alterar, los iconos
rojos subVIs en desarrollo y los iconos azules VIs completos.

Comparacion de Vis

El Professional Development System de LabVIEW incluye una utilidad
para determinar las diferencias entre dos VIs cargados en la memoria.
Seleccione Tools»Compare»Compare VIs para mostrar el cuadro de
didlogo Compare VIs.

En este cuadro de didlogo puede seleccionar los VIs que desee comparar, asi
como las caracteristicas de los VIs que desee comprobar. Cuando compara
los VIs, ambos VIs muestran una ventana Differences que enumera todas las
diferencias entre ambos VIs. En esta ventana, puede seleccionar varias

diferencias y detalles que puede rodear con un circulo para mayor claridad.




Ejercicio 7-1  Concepto: herramientas de gestion de proyectos
de LabVIEW

Objetivo
Examinar algunas de las funciones integradas de LabVIEW para la gestién
de proyectos.

Descripcion

Puede utilizar las herramientas de LabVIEW para determinar el disefio y
la arquitectura de la aplicacién. Esto es importante al prepararse para
modificar una aplicacién. Asimismo, puede simplificar la documentacion de
una aplicacion de desarrollo incluyendo el historial de revision del VI 'y

la jerarquia del VI.

En este ejercicio explore algunas de las funciones integradas en LabVIEW
para gestionar aplicaciones.

Historial de Revisiones del VI
1. Abra el VI Weather Station UL

O Abraweather Station.lvproj en el directorio
<Exercises>\LabVIEW Basics II\Course Project.

Q En la ventana Project Explorer, haga doble clic en Wweather
Station UI.vi.

b

Seleccione Edit»VI Revision History para abrir la ventana History
del VL.

3. Haga clic en el botén Reset para borrar el historial actual. Haga clic en
Yes para confirmar la eliminacién del historial y reiniciar el nimero de
revision.

4. Enel cuadro de texto Comment de la ventana History, escriba Initial
Application Createdy haga clic en el botén Add. Su comentario
aparece en el cuadro de texto History, junto con una fecha y una marca
de hora. Cierre la ventana History.



Jerarquia del VI

1. Seleccione View»VI Hierarchy. Aparece la jerarquia de la aplicacion.

3 VI Hierarc hy
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2. Experimente expandiendo y contrayendo la jerarquia. Observe que
cuando hace clic en las flechitas negras y rojas de la jerarquia, se
expanden o contraen ramas de ésta. Quizd vea iconos con una flecha
roja, que indican que llama a uno o més subVls.

3. Examine el funcionamiento de los botones en la barra de herramientas.
* Use los botones Layout para organizar la jerarquia.

e Use los botones Include para incluir varios componentes de
la aplicacion.

* Use el botén Redo Layout para volver a dibujar la ventana del
esquema y minimizar el cruce de lineas y maximizar la simetria.




4. Haga doble clic en cualquier icono del subVI de la jerarquia para
mostrar el subVI apropiado. Cierre el subVI seleccionado y también
la ventana VI Hierarchy.

5. Cierre los VIs. No guarde ningiin cambio.

Fin del ejercicio 7-1



B. Preparacion de la aplicacion

Cadigo externo

Nombres de rutas

Salir de LabVIEW

Una aplicacién independiente permite al usuario ejecutar los VIs sin instalar
el sistema de desarrollo de LabVIEW. Los instaladores distribuyen

la aplicacién independiente. Los instaladores pueden incluir el LabVIEW
Run-Time Engine, que es necesario para ejecutar aplicaciones
independientes. Sin embargo, también puede descargar LabVIEW
Run-Time Engine en ni . com.

Para crear una aplicacion profesional e independiente con Vs, debe tener
en cuenta varias cuestiones de programacion.

Saber qué cédigo externo utilizan sus aplicaciones. Por ejemplo, ;llama a
cualquier DLL de sistema o personalizada o a bibliotecas compartidas?

( Va a procesar argumentos de linea de comandos? Se trata de ejemplos
avanzados que van mas alld del dmbito de este curso, pero debe tenerlos
en cuenta para la aplicacion. Consulte el tema Using External Code in
LabVIEW en la Ayuda de LabVIEW.

Piense en los nombres de rutas que utiliza en el VI. Suponga que lee datos
desde un archivo durante la aplicacién y la ruta al archivo estd muy
codificada en el diagrama de bloques. Una vez creada una aplicacion,

el archivo se embebe en el ejecutable, cambiando la ruta del archivo.

Ser consciente de estas cuestiones le ayudard a crear aplicaciones mas
robustas en el futuro.

En una aplicacién independiente, el VI de nivel superior debe salir de
LabVIEW o cerrar el panel frontal cuando termine de ejecutarse. Para salir
completamente y cerrar el VIde nivel superior, debe llamar a la funcién Quit
LabVIEW en el diagrama de bloques del VI de nivel superior.

Ayuda en linea para sus aplicaciones de LabVIEW

Mientras da los toques finales a su aplicacién, debe ofrecer ayuda en linea
al usuario. Cree descripciones para los VIs y sus objetos, como controles e
indicadores, para describir la finalidad del VI u objeto y dar a los usuarios
instrucciones para utilizar el VI u objeto.




Use las siguientes funciones, situadas en la paleta Help, para mostrar u
ocultar programdticamente la ventana Context Help y crear enlaces desde
VIs a archivos HTML o archivos de ayuda compilados:

Use la funcion Get Help Window Status para restituir el estado y
la posicion de la ventana Context Help.

Use la funcioén Control Help Window para mostrar, ocultar o recolocar
la ventana Context Help.

Use la funcion Control Online Help para mostrar el indice, saltar a un
tema concreto del archivo o cerrar la ayuda en linea.

Use el VI Open URL. in Default Browser para mostrar un URL o archivo
HTML en el explorador web predeterminado.

C. Construccion de la aplicacion y el instalador

Las especificaciones de construccién en LabVIEW crean aplicaciones e
instaladores independientes.

Aplicaciones independientes: use aplicaciones independientes para

ofrecer a otros usuarios versiones ejecutables de VIs. Las aplicaciones
resultan ttiles cuando desea que otros usuarios ejecuten VIs sin instalar
el sistema de desarrollo de LabVIEW. Las aplicaciones (Windows) tienen
la extension . exe. Las aplicaciones (Mac 0S) tienen la extension . app.

Instaladores: (Windows) Use instaladores para distribuir aplicaciones
independientes, bibliotecas compartidas y distribuciones de cédigo
fuente que cree con Application Builder. Los instaladores que incluyen
el LabVIEW Run-Time Engine son titiles si desea que los usuarios
puedan ejecutar aplicaciones o usar bibliotecas compartidas sin instalar
LabVIEW.

Especificaciones de Construccion en LabVIEW

Use Build Specifications en la ventana Project Explorer para crear
especificaciones de construccion para distribuciones de codigo fuente y
otros tipos de construcciones de LabVIEW. Una especificacion de
construccion contiene toda la configuracién para la creacién, como archivos
para incluir, directorios para crear y configuraciones para Vls.

@ Nota Si anteriormente oculté Build Specifications en la ventana Project Explorer,
debe mostrar el elemento de nuevo para acceder a €l en la ventana Project Explorer.

@ Consejo (Windows y UNIX) En funcidn de la naturaleza de su aplicacidn, puede requerir
la presencia de archivos que no sean de VI para que funcione correctamente. Los archivos
que suelen ser necesarios son un archivo de preferencias (. ini) para la aplicacién y
archivos de ayuda a los que puedan llamar los VlIs.



Requisitos del sistema

Las aplicaciones que cree con Build Specifications normalmente tienen los
mismos requisitos del sistema que el sistema de desarrollo de LabVIEW.
Los requisitos de memoria varian en funcién del tamafio de la aplicacion
creada.

Puede distribuir estos archivos sin el sistema de desarrollo de LabVIEW;
sin embargo, los usuarios de aplicaciones independientes y de bibliotecas
compartidas deben tener LabVIEW Run-Time Engine instalado.

Implementacion de Especificaciones de Construccion

Debe crear especificaciones de construccién en la ventana Project
Explorer. Expanda My Computer, haga clic derecho en Build
Specifications, seleccione New y escriba la construccion que desee
configurar desde el ment contextual. Use las paginas de los cuadros de
didlogo Source Distribution Properties, Application Properties, Shared
Library Properties, (Windows) Installer Properties o Zip File Properties
para configurar los ajustes de la especificacién de construccién. Tras definir
esta configuracion, haga clic en el botén OK para cerrar el cuadro de
didlogo y actualizar la especificacion de construccion en el proyecto.

La especificacién de construccion aparece en Build Specifications. Haga
clic con el botén derecho en una especificacion y seleccione Build desde
el ment contextual para completar la construccién. También puede
seleccionar Build All en el mend contextual para construir todas las
especificaciones en Build Specifications. Si vuelve a construir una
especificacién determinada, LabVIEW sobrescribe los archivos existentes
de la construccién anterior que forman parte de la construccion actual.

@ Nota Puede duplicar especificaciones de construccién en la ventana Project Explorer.
Haga clic derecho en el elemento de la especificacién de construccion que desee duplicar
y seleccione Duplicate en el ment contextual para crear una copia del elemento Build
Specification. También puede arrastrar y soltar elementos de especificacién de
construccién para reorganizar el orden de construccién en la misma Build Specification.

Consulte el VI Build Targets via Command Line en el directorio
labview\examples\project\programatically build para ver un
ejemplo de construir una especificacién de construccion de un proyecto
desde la linea de comandos.

Revise las advertencias y recomendaciones para aplicaciones y bibliotecas
compartidas y para instaladores antes de crear especificaciones de
construccién con Application Builder.

Consulte la Ayuda de LabVIEW para obtener informacién adicional acerca
de las alarmas y recomendaciones para aplicaciones e instaladores.




Ejercicio 7-2 Concepto: creacion de una aplicacion

Objetivo

Descripcion

independiente

Crear una aplicacién independiente con LabVIEW.

Crear una aplicacion independiente y un instalador simplifica el despliegue
de una aplicacion en varias maquinas. Para desplegar la aplicacion, primero
prepare el c6digo, cree una Application (. exe) Build Specification y
después cree una Installer Build Specification.

Configuracion de la ventana de la aplicacion de alto nivel
1. Abrael VI Weather Station UL

U Abraweather Station.lvproj en el directorio
<Exercises>\LabVIEW Basics II\Course Project

U En la ventana Project Explorer, haga doble clic en weather
Station UI.vi.
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Seleccione File»VI Properties para ver el cuadro de didlogo VI
Properties.

3. Seleccione Window Appearance en el menu desplegable superior.
4. Dé un nombre a la ventana, como Weather Station.

5. Seleccione Top-level application window. Esto da al panel frontal un
aspecto profesional cuando se abre como un ejecutable.

6. Guarde el VI.




Liamada a la funcion Quit LabVIEW
1. Abray modifique el diagrama de bloques para llamar a la funcién Quit
LabVIEW cuando termine la aplicacién.
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Figura 7-3. Diagrama de bloques

U Afiada la funcién Quit LabVIEW al diagrama de bloques para que
sea la ultima funcién que se ejecute. Esta funcién sale de LabVIEW
y de la aplicacién tras ejecutarse.

U Encierre la funcién Quit LabVIEW en una estructura Flat Sequence.

Cablee el VI Simple Error Handler al flanco de la estructura
Sequence para forzar el orden de ejecucion.

2. En la ventana Project, seleccione File»Save All para guardar todos
los VIs.

3. Abrael panel frontal y ejecute el V1. Cuando haga clic en el botén Stop,
el VI se parard y LabVIEW se cerrara.

4. Reinicie LabVIEW y abra Weather Station.lvproj situadoenel
directorio <Exercises>\LabVIEW Basics II\Course Project.




Modificacion de la ruta del archivo

1. Modifique la ruta en cuestion para tener la misma funcionalidad una vez
construido el ejecutable eliminando un componente adicional de la ruta.
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O Abrael Initialize Weather Station.wvi desde la ventana

Project Explorer.

Cambie al diagrama de bloques.

o o o O

Guarde y cierre el V1.

Cablee el diagrama de bloques como en la figura 7-4.

Anada una funcién adicional Strip Path al diagrama de bloques.




Application (EXE) Build Specification
1. Haga clic con el botén derecho en Build Specifications en la ventana

Project Explorer y seleccione New»Application (EXE) en el ment
contextual.

s8]

Modifique el nombre del archivo del directorio objetivo y de destino
para la aplicacién en la categoria Information.

U Seleccione la categoria Information.
U Cambie Target filename a WeatherStation.exe.

(1 Escriba <Exercises>\LabVIEW Basics II\Course
Project\Executable en el Destination directory.

@ Consejo No necesita crear el directorio. LabVIEW crea cualquier directorio que
especifique.

3. Especifique el VI de nivel superior.
U Seleccione la categoria Source Files.
O Seleccione Weather Station ULvi en el arbol Project Files.

1 Haga clic en la flecha junto a la lista Startup VIs para afiadir el VI
seleccionado a la lista Startup Vls.

U Haga clic en OK.

4. Enla ventana Project Explorer, haga clic derecho en la especificacion de
construccion My Application que acaba de crear y seleccione Build en
el menu contextual.

5. Haga clic en Done en la ventana Build Status.

6. Vayaa <Exercises>\LabVIEW Basics II\Course Project\
Executable en el Explorador de Windows y ejecute
WeatherStation. Pare cuando termine.



Especificacion de construccion del instalador

1. Haga clic con el botén derecho en Build Specifications en la ventana
Project Explorer y seleccione New»Installer en el ment contextual.

2. Modifique Installer destination en la categoria Product Information.
U Seleccione la categoria Product Information.

O Escriba <Exercises>\LabVIEW Basics II\Course
Project\Installer como el Installer destination.

3. Especifique la Executable Build Specification.
O Haga clic en la categoria Source Files.
Q Seleccione la especificacion de construccién My Application.

O Seleccione Weather Station en ProgramFilesFolder en el arbol
Destination View.

QO Haga clic en la flecha junto al arbol Project View para colocar el
ejecutable y los archivos de soporte de éste en ProgramFilesFolder
en el directorio Weather Station como se ve en la figura 7-5.
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Figura 7-5. Categoria Source Files del instalador



Prueba

Afiada el LabVIEW Run-Time Engine de NI al instalador modificando
la categoria Additional Installers.

U Seleccione la categoria Additional Installers.
O Seleccione el instalador NI LabVIEW Run-Time Engine 8.xx.

Afada un acceso directo al ment Inicio modificando la categoria
Shortcuts.

U Seleccione la categoria Shortcuts.
U Haga clic en el botén + para afiadir un acceso directo.

U Seleccione Weather Station.exe en el cuadro de didlogo Select
Target File y haga clic en OK.

U Haga clic en OK.

En la ventana Project Explorer, haga clic derecho en la especificacion de
construccion My Installer y seleccione Build en el ment contextual.

Haga clic en Done.

Ejecute el archivo setup . exe en el directorio <Exercises>\
LabVIEW Basics II\Course Project\Installer\Volume.
Un asistente le guiard en el proceso de configuracién. El ejecutable se
crea dentro del directorio <Program Files>\Weather Station.

Para ejecutar la aplicacidn, seleccione Inicio»Programas»Weather
Station»Weather Station.

Fin del ejercicio 7-2



Resumen

LabVIEW incluye Application Builder, que permite crear instaladores y
ejecutables independientes. Application Builder estd disponible en los
Professional Development Systems o como paquete de complemento.

Para crear una aplicacion profesional e independiente con VlIs, debe
tener en cuenta varias cuestiones:

~ La arquitectura de su VI

— Cuestiones concretas de programacion del VI
— El proceso de construccién de aplicaciones

— El proceso de construccion de instaladores

Use la ventana VI Revision History para registrar comentarios y
modificaciones a un VIy el inicio de sesion del usuario que, cuando se
usa con VI Revision History, registra quién realizé cambios en un VL.
Puede acceder a la ventana VI Revision History cuando desee
seleccionando Tools»VI Revision History.

La ventana VI Hierarchy ofrece una introduccién rdpida y concisa de los
VIs utilizados en su proyecto.
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