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A. Utilidades de ayuda de LabVIEW

Use la ventana Context Help, la Ayuda de LabVIEW y el NI Example
Finder para ayudarle a crear y modificar VIs. Consulte la Ayuda de
LabVIEW y los manuales para obtener informacion adicional acerca
de LabVIEW.

Ventana Context Help

La ventana Context Help muestra informacién bdsica sobre los diferentes
objetos de LabVIEW cuando mueve el cursor sobre cada uno de ellos. Para
ver la ventana Context Help, seleccione Help»Show Context Help, pulse
las teclas <Ctrl-H> o haga clic en el boton Show Context Help Window de
la barra de herramientas.

Cuando mueva el cursor sobre los objetos del panel frontal y del diagrama
de bloques, la ventana Context Help mostrard el icono para subVls,
funciones, constantes, controles e indicadores, con cables acoplados a cada
terminal. Cuando mueva el cursor sobre las opciones del cuadro de didlogo,
la ventana Context Help mostrard sus descripciones.

En la ventana Context Help, las etiquetas de terminales obligatorios
aparecen en negrita, los terminales recomendados como texto sin formato y
los opcionales aparecen atenuados. Las etiquetas de terminales opcionales
no aparecen si hace clic en el botén Hide Optional Terminals and Full
Path, mostrado a la izquierda, en la ventana Context Help.

Context Help
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Figura 3-1. Ventana Context Help

Haga clic en el botén Show Optional Terminals and Full Path situado
en la esquina inferior izquierda de la ventana Context Help para ver los
terminales opcionales de un panel de conectores y la ruta completade un VI.
Los terminales opcionales aparecen como cables cortados, informdndole
de que existen otras conexiones. El modo detallado muestra todos

los terminales, como en la figura 3-2.
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Figura 3-2. Ventana Context Help detallada

Haga clic en el botén Lock Context Help para bloquear el contenido actual
de la ventana Context Help. Cuando se bloquea el contenido, si mueve

el cursor sobre otro objeto, no cambiard el contenido de la ventana. Para
desbloquear la ventana, haga clic de nuevo en el botén. También puede
acceder a esta opcién desde el menu Help.

Si existe un tema en la Ayuda de LabVIEW asociado a un objeto que se
describe en la ventana Context Help, aparecerd un enlace azul Detailed
help en la ventana Context Help. Asimismo, el botén More Help se
encontrard activado. Haga clic en el enlace o en el botdn para mostrar
LabVIEW Help y obtener informacién adicional sobre el objeto.

Puede acceder a la Ayuda de LabVIEW haciendo clic en el botén More Help
de la ventana Context Help, seleccionando Help»Search the LabVIEW
Help o haciendo clic en el enlace azul Detailed Help en la ventana Context
Help. También puede hacer clic con el botén derecho en un objeto y
seleccionar Help en el menu contextual.

LabVIEW Help contiene descripciones detalladas de la mayoria de
las paletas, ments, herramientas, VIs y funciones. También incluye
instrucciones paso a paso para utilizar las funciones de LabVIEW.
La Ayuda de LabVIEW incluye enlaces a los siguientes recursos:

o LabVIEW Documentation Resources, que describe documentos en linea
e impresos para ayudar a los usuarios nuevos y con experiencia e incluye
versiones en PDF de todos los manuales de LabVIEW.

* Recursos de soporte técnico en el sitio Web de National Instruments,
como NI Developer Zone, KnowledgeBase y Product Manuals Library
(Biblioteca de Manuales de Producto).



Use NI Example Finder para explorar o buscar ejemplos instalados en su
ordenador o en NI Developer Zone en ni.com/zone. Estos ejemplos
demuestran como utilizar LabVIEW para realizar numerosas tareas de
prueba, medidas, control y disefio. Seleccione Help»Find Examples o haga
clic en el enlace Find Examples de la seccién Examples de la ventana
Getting Started para lanzar NI Example Finder.

Los ejemplos pueden mostrarle cémo utilizar VIs o funciones especificas.
Puede hacer clic con el botén derecho en un VI o funcién del diagrama

de bloques o en una paleta fijada y seleccionar Examples desde el menu
contextual para ver un tema de ayuda con enlaces a ejemplos para ese VI o
funcién. Puede modificar un VIs de ejemplo para ajustarse a una aplicacion
o puede copiar y pegar desde uno o mas ejemplos en un VI que haya creado.
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Figura 3-3. NI Example Finder




Ejercicio 3-1

Objetivo

Descripcion

Concepto: uso de la ayuda

Familiarizarse con el uso de la ventana Context Help, LabVIEW Help y
NI Example Finder.

Este ejercicio consta de una serie de tareas disefladas para ayudarle a
familiarizarse con las herramientas de la Ayuda de LabVIEW. Complete
estos pasos.

NI Example Finder

1. Tiene un dispositivo GPIB en el ordenador y quiere aprender a
comunicarse con €l mediante LabVIEW. Use NI Example Finder
para buscar un VI que se comunique con un dispositivo GPIB.

I 0 R I A N

Q

o

Abra LabVIEW.

Seleccione Help»Find Examples para abrir NI Example Finder.
Confirme que la opcién Task estd seleccionada en la ficha Browse.
Haga doble clic en la carpeta Hardware Input and Output.
Seleccione DAQmx»Analog Measurements»Voltage.

Seleccione Acq&Graph Voltage-Int Clk.vi. Tenga en cuenta que
hay una descripcion del VI en la ventana Information, para poder
comprobar que este VI satisface sus necesidades.

Haga doble clic en Acq&Graph Voltage-Int Clk.vi para abrir
el VL

Cierre el VI tras terminar de explorarlo.

Desea profundizar en el uso de VIs Express para filtrar sefiales.

Use NI Example Finder para buscar un VI apropiado.

Q

NI Example Finder atin debe de estar abierto desde al paso anterior.
En caso contrario, abralo.

U Haga clic en la ficha Search de NI Example Finder.

Escriba express en el campo Enter keyword(s) para buscar VI
que contengan VIs Express.



O
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Haga doble clic en el resultado Express que aparece en el campo
Double-click keyword(s).

Esta palabra clave se asocia con muchos VIs de ejemplo, como
demuestra el nimero de VIs encontrados. Puede seleccionar
cualquiera de estos VIs y leer la descripcion en la ventana
Information.

Haga doble clic en Express Filter.vi para abrirlo.

Ventana Context Help

3. Use la ventana Context Help para aprender sobre los VIs Express
utilizados en el VI Express Filter.

a

Abra el diagrama de bloques seleccionando Window»Show Block
Diagram.

Abra la ventana Context Help seleccionando Help»Show Context
Help.

Mueva la ventana Context Help a una zona cémoda que no oculte
parte del diagrama de bloques.

Coloque el cursor del ratén sobre el VI Express Simulate Signal.
El contenido de la ventana Context Help cambia para mostrar
informacion sobre el objeto sobre el que estd el raton.

Mueva el ratén sobre otro VI Express. Observe que el contenido de
la ventana Context Help cambia en funcién de la ubicacién del
cursor del ratén.

Mueva el raton sobre uno de los VIs Express Tone Measurements.

Examine la informacién de configuracion en la ventana Context
Help. Esta informacidn le indica cémo estd configurado el VI
Express.

Haga doble clic en el VI Express Tone Measurements para abrir
el cuadro de didlogo de configuracién. Tenga en cuenta que las
selecciones del cuadro de didlogo de configuracién coinciden con
la informacién de la ventana Context Help.

Haga clic en el botén OK para cerrar el cuadro de didlogo de
configuracion.




4. Ancle la ventana Context Help para poder mover el ratén sin que
cambie el contenido de ella. La ventana Context Help debe mostrar
informacién sobre el VI Express Simulate Signal.

O Mueva el ratén sobre el VI Express Simulate Signal.

@ Para anclar la ventana de ayuda contextual, seleccione el botén Lock
en la esquina inferior izquierda de la ventana.

Consejo Si cambia el contenido de la ventana antes de bloquearla, evite pasar el ratén
por otros objetos que se encuentren de camino a la ventana Context Help. Mueva la
ventana mas cerca del objeto en cuestion para ver la ayuda contextual de ese elemento.

U Mueva el ratén sobre otro objeto. Tenga en cuenta que el contenido
de la ventana no cambia mientras estd seleccionado el botén Lock.

O Deseleccione el botén Lock para reanudar el funcionamiento
normal de la ventana.

5. Modifique Description and Tip asociado con el control Simulated
frequency para cambiar el contenido de la ventana Context Help.

O Seleccione Window»Show Front Panel para abrir el panel frontal
del VL.

Mueva el ratén sobre el control Simulated frequency.
Lea el contenido de la ventana Context Help.

Haga clic con el botén derecho sobre el control Simulated
frequency.

Seleccione Description and Tip en el menu contextual.

Sustituya el texto del cuadro Description "'Simulated frequency"
por el texto Esta es la descripcidén del control.

Q Sustituya el texto del cuadro Tip "'Simulated frequency'' por
el texto Este es el campo “consejo” del control.

Haga clic en el botén OK.
Mueva el ratdn sobre el control Simulated frequency.

Compruebe que el contenido de la ventana Context Help cambi6
para coincidir con el texto que escribié en el campo Description
del cuadro de didlogo Description and Tip.



U Ejecute el VL.
W Mueva el cursor del ratén sobre el control Simulated frequency.

W Compruebe que el consejo de la herramienta que aparece coincide
con el texto que escribid en el campo Tip del cuadro de didlogo
Description and Tip.

O Haga clic en el botén Stop.

LabVIEW Help

6. Use la Ayuda de LabVIEW para ver informacién adicional sobre el
VI Express Filter.

Q Seleccione Window»Show Block Diagram para abrir el diagrama
de bloques del VI Express Filter.

U Haga clic con el botén derecho en el VI Express Filter y seleccione

Help en el menit contextual. Abrird el tema de la Ayuda de LabVIEW
para el VI Express Filter.

Nota Para acceder a la Ayuda de LabVIEW para este tema, también puede seleccionar
el enlace Detailed Help de la ventana Context Help mientras selecciona el VI Express
Filter o hacer clic en el signo de interrogacién de la ventana Context Help.

U Explore el tema. Por ejemplo, ;qué finalidad tiene la opcién del
cuadro de didlogo Phase Response?

U Cierre la ventana LabVIEW Help.

7. Cierre el VI Express Filter cuando termine. No guarde los cambios.

Fin del ejercicio 3-1




B. Corregir Vis rotos

Si un VI no se ejecuta, es un VI roto o no ejecutable. El boton Run aparece
roto (se muestra a la izquierda) cuando el VI que estd creando o modificando
contiene errores.

Si el botén sigue apareciendo roto tras terminar de cablear el diagrama
de bloques, el VI estd roto y no puede ejecutarse.

Buscar causas de VIs rotos

Las advertencias no impiden que ejecute un V1. Estdn disefiadas para
ayudarle a evitar posibles problemas en VIs. Sin embargo, los errores
pueden romper un VI. Debe resolver los errores antes de poder ejecutar
el VL.

Haga clic en el botén Run o seleccione View»Error List para averiguar por
qué se ha roto un VI. La ventana Error list muestra cada uno de los errores.
La seccién Items with errors muestra los nombres de todos los elementos
en memoria, como librerias de proyectos y VIs que contienen errores. Si dos
0 mas elementos tienen el mismo nombre, esta seccién muestra la ubicacién
en concreto de cada elemento. La seccién errors and warnings muestra los
errores y las advertencias del VI que seleccione en la seccion Items with
errors. La seccion Details describe los errores y en algunos casos
recomienda cémo corregirlos. Haga clic en el boton Help para ver un tema
de la Ayuda de LabVIEW que describa el error en detalle e incluya
instrucciones paso a paso para corregirlo.

Haga clic en el botén Show Error o haga doble clic en la descripcién del
error para resaltar la zona del diagrama de bloques o del panel frontal que
contenga el error.
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Figura 3-4. Ejemplo de cuadro de didlogo Error List

Causas habituales de Vls rotos

Esta lista contiene razones habituales de rotura de un VI mientras
lo modifica:

» Eldiagrama de bloques contiene un cable roto por un desajuste de tipos
de datos o un extremo suelto o desconectado.

Consulte el tema Correcting Broken Wires de la Ayuda de LabVIEW
para obtener informacion acerca de corregir cables rotos.

e Un terminal obligatorio del diagrama de bloques no esté cableado.

Consulte el tema Using Wires to Link Block Diagram Objects en
la Ayuda de LabVIEW para obtener informacién acerca de configurar
entradas y salidas obligatorias.

e Un subVI estd roto o modific6 su panel de conectores tras colocar su
icono en el diagrama de bloques del VI.

Consulte el tema Creating SubVis de LabVIEW Help para obtener
informacién acerca de subVlIs.




C. Técnicas de depuracion

Si un VI no estd roto, pero obtiene datos inesperados, puede utilizar las
siguientes técnicas para identificar y corregir problemas con el VI o el flujo
de datos del diagrama de bloques:

®

Cablee los parametros de salida y entrada de error en la base de la
mayoria de los VIs y funciones integrados. Estos pardmetros detectan
errores encontrados en cada nodo del diagrama de bloques e indican si
ocurri6 un error y dénde. También puede utilizar estos pardmetros en
los Vs que cree.

Para eliminar todas las advertencias del V1, seleccione View»Error List
y marque la casilla de verificacién Show Warnings para ver todas las
advertencias del V1. Determine las causas y corrijalas en el VI.

Haga triple clic en el cable con la herramienta de operaciones para
resaltar toda su ruta y asegurarse de que los cables se conecten a los
terminales apropiados.

Use la ventana Context Help para comprobar los valores
predeterminados de cada funcién y subVI en el diagrama de bloques.
Los VIs y las funciones pasan los valores predeterminados si no estdn
cableadas las entradas recomendadas u opcionales. Por ejemplo, una
entrada booleana podria configurarse en TRUE si no estd cableada.

Use el cuadro de didlogo Find para buscar subVlIs, texto y otros objetos
para corregir en el VI.

Seleccione View»Browse Relationships»This VI’s Hierarchy para
buscar subVlIs sin cablear. A diferencia de las funciones sin cablear, los
VIs sin cablear no siempre generan errores a menos que configure una
entrada como obligatoria. Si coloca por error un subVI sin cablear en el
diagrama de bloques, se ejecuta cuando lo hace el diagrama de bloques.
Por lo tanto, el VI podria realizar acciones adicionales.

Resalte las ejecuciones para ver el movimiento de datos por el diagrama
de bloques.

Ejecute paso a paso el VI para ver cada accién suya en el diagrama
de bloques.

Use la herramienta de sonda para observar valores de datos intermedios
y para comprobar la salida de errores de VIs y funciones, en especial
las que realizan E/S.

Use puntos de interrupcion para pausar la ejecucion, para poder ejecutar
paso a paso o insertar sondas.
Suspenda la ejecucion de un subVI para modificar valores de controles

e indicadores, para controlar el nimero de veces que se ejecuta o para
volver al principio de la ejecucion del subVI.



Determine si los datos que pasa una funcidén o subVI estdn sin definir.
Esto suele suceder con los ntiimeros. Por ejemplo, en un punto del VIuna
operacion podria haber dividido un nimero por cero, devolviendo Inf
(infinito), mientras que las siguientes funciones o subVlIs esperaban
ndmeros.

Siel VI se ejecuta con mds lentitud de la esperada, confirme que
desactivo resaltar la ejecucion en subVIs. Asimismo, cierre los paneles
frontales y los diagramas de bloques del subVI cuando no los esté
utilizando, ya que las ventanas abiertas pueden afectar a la velocidad
de ejecucidn.

Compruebe la representacion de controles e indicadores para ver si se
estd produciendo desbordamiento, porque convirtié un niimero de coma
flotante en un niimero entero o éste en un nimero entero de menos bits.
Por ejemplo, podria cablear un ntimero entero de 16 bits en una funcién
que s6lo acepte nimeros enteros de 8 bits. Esto hace que la funcién
convierta el nlimero entero de 16 bits en una representacién de 8 bits,
con lo que podria perder datos.

Determine si algtin bucle For ejecuta accidentalmente cero iteraciones y
produce arrays vacios.

Compruebe que inicializé correctamente registros de desplazamiento,
a menos que deseara que guardaran datos desde una ejecucién del bucle
a otra posterior.

Compruebe el orden de los elementos de clusters en los puntos de origen
y de destino. LabVIEW detecta los desajustes de tipos de datos y

de tamaios de cluster durante la edicidn, pero no detecta desajustes

de elementos del mismo tipo.

Compruebe el orden de ejecucion de los nodos.

Verifique que el VI no contenga subVlIs ocultos. Podria haber ocultado
un subVI accidentalmente colocdndolo directamente sobre otro nodo o
disminuyendo el tamafio de una estructura sin mantener a la vista

el subVL

Contraste el conjunto de subVIs que utiliza el VI con los resultados de
View»Browse Relationships»This VI’s SubVIs y View»Browse
Relationships»Unopened SubVIs para determinar si existen subVlIs
adicionales. Abra también la ventana VI Hierarchy para ver los subVlIs
de un VI. Para ayudarle a evitar resultados incorrectos por VlIs ocultos,
especifique entradas obligatorias para los VlIs.




Resaltado de ejecucion

Vea una animacién de la ejecucion del diagrama de bloques haciendo clic en
el botén Highlight Execution, mostrado a la izquierda.

El resaltado de la ejecucion muestra el movimiento de datos en el diagrama
de bloques desde un nodo a otro utilizando las burbujas que se mueven a
lo largo de los cables. En los nodos MathScript, el resaltado de la ejecucion
muestra la progresién desde una linea de script a otra mediante una flecha
azul que parpadea junto a la linea que se estd ejecutando actualmente. Use
el resaltado de la ejecucidn junto con la ejecucion paso a paso para ver cOmo
se mueven los valores de datos de nodo a nodo a través de un VI.

@ Nota Elresaltado de la ejecucidn reduce enormemente la velocidad de ejecucion del VI.

i édd&sub‘vi Block [}i;'tgram .

File Edit View Project Cperate Tools ‘Window Help

[

Figura 3-5. Ejemplo de uso de resaltado de la ejecucion

Ejecucion paso a paso

Ejecute paso a paso un VI para ver cada una de sus acciones en el diagrama
de bloques mientras se ejecuta el VI. Los botones de ejecucion paso a paso,
mostrados a continuacién, afectan a la ejecucién sélo en un VI o subVIen
el modo de ejecucion paso a paso.
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Entre en el modo de ejecucién paso a paso haciendo clic en el botén Step
Into o Step Over en la barra de herramientas del diagrama de bloques.
Mueva el cursor sobre el botén Step Into, Step Over o Step Out para ver
una ayuda que describe el siguiente paso si hace clic en ese botén. Puede
ejecutar los subVlIs paso a paso o ejecutarlos de forma normal.
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Cuando ejecuta un VI paso a paso, los nodos parpadean para indicar
que estan listos para ejecutarse. Si el VI contiene un nodo MathScript,
parpadeard una flecha azul junto a lineas de script para indicar que estan
listas para ejecutarse. Si ejecuta un VI paso a paso con el resaltado de
ejecucion activado, aparecera un simbolo de ejecucion, mostrado a

la izquierda, en los iconos de los subVIs que se estdn ejecutando en ese
momento.

Herramientas de sonda

HEF

Use la herramienta de sonda, mostrada a la izquierda, para comprobar
valores intermedios en un cable mientras se ejecuta un VI. También puede
utilizar Ia herramienta de sonda para ver los datos de un script en un nodo
MathScript cuando se ejecuta un VI.

Use la herramienta de sonda si tiene un diagrama de bloques complicado
con una serie de operaciones, alguna de las cuales podria producir datos
incorrectos. Use la herramienta de sonda con el resaltado de la ejecucion,
la ejecucién paso a paso y los puntos de interrupcion para determinar si
los datos son incorrectos y en qué punto. Si dispone de datos, la sonda
inmediatamente actualiza y muestra los datos durante el resaltado de

la ejecucidn, la ejecucién paso a paso o cuando pause en un punto de
interrupcién. Cuando se pause la ejecucién en un nodo por la ejecucion paso
a paso o por un punto de interrupcidn, también puede sondar el cable que
acaba de ejecutar para ver el valor que fluy6 por ese cable.

Tipos de sondas

Puede comprobar los valores intermedios de un cable cuando se ejecuta un
VI utilizando una sonda genérica, un indicador de la paleta Controls para
ver los datos, una sonda suministrada, una sonda suministrada personalizada
o creando una nueva sonda. Puede ver los datos de un script en un nodo
MathScript mientras se ejecuta un VI utilizando la sonda LabVIEW
MathScript.

Genéricas

Use la sonda genérica para ver los datos que pasan por un cable. Haga clic
con el botén derecho en un cable y seleccione Custom Probe»Generic
Probe desde el menti contextual para usar la sonda genérica.

La sonda genérica muestra los datos. No puede configurar la sonda genérica
para responder a los datos.

LabVIEW muestra la sonda genérica cuando hace clic con el botén derecho
en un cable y selecciona Probe, a menos que ya especificara una sonda
personalizada o suministrada para el tipo de datos.




Puede depurar una sonda personalizada de modo similar a un VI. Sin
embargo, una sonda no puede sondar su propio diagrama de bloques, ni el
diagrama de bloques de cualquiera de sus subVIs. Al depurar sondas, use
la sonda genérica.

Uso de indicadores para ver datos

También puede utilizar un indicador para ver los datos que pasan por un
cable. Por ejemplo, si ve datos numéricos, puede utilizar un grafico como
sonda para ver los datos. Haga clic con el boton derecho en un cable y
seleccione Custom Probe»Controls desde el ment contextual y seleccione
el indicador que desea usar. También puede hacer clic en el icono Select

a Control de la Paleta de Controles y seleccionar cualquier control
personalizado o definicidn de tipo guardado en el ordenador en un directorio
compartido de un servidor. LabVIEW trata las definiciones de tipos como
controles personalizados cuando los utiliza para ver datos sondados.

Si el tipo de datos del indicador que seleccione no coincide con el tipo de
datos del cable donde hizo clic con el botén derecho, LabVIEW no colocara
el indicador en el cable.

Suministradas

Las sondas suministradas son VIs que muestran informacién exhaustiva
sobre los datos que pasan por un cable. Por ejemplo, la sonda VI Refnum
devuelve informacién sobre el nombre del VI, suruta y el valor hexadecimal
de la referencia. También puede utilizar una sonda suministrada para
responder en funcién de los datos que pasan por un cable. Por ejemplo, use
una sonda Error en un cluster de error para recibir el estado, el cédigo, el
origen y la descripcién del error y especificar si desea configurar un punto
de interrupcién condicional si tiene lugar un error o una advertencia.

Las sondas suministradas aparecen en la parte superior del menti contextual
Custom Probe. Haga clic con el botén derecho en un cable y seleccione
Custom Probe desde el menti contextual para seleccionar una sonda
suministrada. Sélo aparecen en el menu contextual las sondas que coinciden
con el tipo de datos del cable donde hizo clic con el bot6én derecho.

Consulte el VI Using Supplied Probes en labview\examples\general\
probes. 11b para ver un ejemplo de uso de sondas suministradas.



Personalizadas

Use el cuadro de didlogo Create New Probe para crear una sonda en
funcién de una sonda existente o para crear una nueva. Haga clic con el
botén derecho en un cable y seleccione Custom Probe»New desde el mend
contextual para ver e] cuadro de didlogo Create New Probe. Cree una sonda
cuando desee tener mds control sobre cémo LabVIEW sonda los datos que
fluyen por un cable. Cuando crea una nueva sonda, el tipo de datos de

la sonda coincide con el tipo de datos del cable donde hizo clic con el botén
derecho. Si desea modificar la sonda que cred, debe abrirla desde

el directorio donde la guardé.

Tras seleccionar una sonda desde el ment contextual Custom Probe,
navegue hasta €l utilizando la opcién de la paleta Select a Control o cree
una nueva sonda con el cuadro de didlogo Create New Probe. Esa sonda serd
la predeterminada para ese tipo de datos y LabVIEW la cargard cuando haga
clic con el botén derecho en un cable y seleccione Probe en el mend
contextual. LabVIEW sélo carga las sondas que coinciden exactamente con
el tipo de datos del cable donde hizo clic con el botén derecho. Es decir, una
sonda numérica de coma flotante de doble precisién no puede sondar un
cable de un nlimero entero sin signo de 32 bits, aunque LabVIEW puede
convertir los datos.

@ Nota Sidesea que una sonda personalizada sea la predeterminada para un tipo de datos
concreto, guarde la sonda en el directorio user . 1ib\_probes\default. No guarde
sondas en el directorio vi . 1ib\_probes porque LabVIEW sobrescribird esos archivos
cuando actualice o reinstale.

Puntos de interrupcion

L

Use la herramienta de punto de interrupcién, mostrada a la izquierda, para
colocar un punto de interrupcién de un VI, nodo, cable o linea de script en
un nodo MathScript y pausar la ejecucién en esa ubicacion.

Cuando configura un punto de interrupcion en un cable, la ejecucion se
pausa una vez que los datos pasan por el cable y el botén Pause aparece rojo.
Sitde un punto de interrupcién en el diagrama de bloques para pausar

la ejecucién una vez que se ejecuten todos los nodos del diagrama de
bloques. El borde del diagrama de bloques aparece rojo y parpadea para
reflejar la colocacién de un punto de interrupcion.

Cuando un VI se pausa en un punto de interrupcién, LabVIEW pone en
primer plano el diagrama de bloques y usa un marco para resaltar el nodo,
cable o linea de script que contiene el punto de interrupcién. Cuando mueve
el cursor sobre un punto de interrupcidn, la zona negra del cursor de

la herramienta de punto de interrupcién aparece blanca.




Cuando llega a un punto de interrupcidn durante la ejecucion, el VI se pausa
y el botén Pause aparece rojo. Puede realizar las siguientes acciones:

e Seguir paso a paso la ejecucion con los botones de ejecucion paso a
paso.

e Sondar cables para comprobar los valores intermedios.
e Cambiar los valores de los controles del panel frontal.

* Hagaclic en el botén Pause para seguir ejecutando hasta el préximo
punto de interrupcién o hasta que termine de ejecutarse el VI.

Suspender la ejecucion

Suspenda la ejecucion de un subVI para modificar valores de controles e
indicadores, para controlar el nimero de veces que se ejecuta el subVI antes
de volver al que le llama o para volver al principio de la ejecucion del subVI.
Puede hacer que todas las llamadas a un subVI empiecen con la ejecucién
suspendida o puede suspender una llamada concreta a un subVI.

Para suspender todas las llamadas a un subVl, dbralo y seleccione Operate»
Suspend when Called. El subVI se suspenderd autométicamente cuando
lo llame otro VI. Si selecciona este elemento de menu cuando ejecute paso
a paso, el subVI no se suspendera inmediatamente. El subVI se suspendera
cuando lo llamen.

Para suspender una llamada a un subVI concreto, haga clic derecho en el
nodo del subVI en el diagrama de bloques y seleccione SubVI Node Setup
en el mend contextual. Active la casilla de verificacién Suspend when
called para suspender la ejecucidn sélo en esa instancia del subVI.

La ventana VI Hierarchy, que se abre seleccionando View»VI Hierarchy,
indica si un VI estd pausado o suspendido. Un simbolo de flecha, mostrado
a continuacién, indica un VI que se esté ejecutando con normalidad o paso
a paso.

*

Un simbolo de pausa, mostrado a continuacién, indica un VI pausado o
suspendido.

Un simbolo de pausa verde, o un simbolo hueco en blanco y negro, indica
un VI que se pausa cuando le llaman. Un simbolo de pausa rojo, o un
simbolo relleno en blanco y negro, indica un VI que se estd pausando. Un
simbolo de signo de exclamacidn, mostrado a continuacioén, indica que el VI
estd suspendido.

¥
*

Un VI puede suspenderse y pausarse a la vez.



Deferminar ia instancia actual de un suhVi

Cuando pausa un subVI, el mend desplegable Call list de la barra

de herramientas muestra la cadena de llamadas desde el VI superior al
subVI. Esta lista no es la misma que ve cuando selecciona Browse»

This VI’s Callers, que enumera todos los VIs que llaman al subVI
independientemente de si se estdn ejecutando o no. Use el mend Call list
para determinar la instancia actual del subVI si el diagrama de bloques
contiene mas de una instancia. Cuando selecciona un VI del menu Call list,
se abre su diagrama de bloques y LabVIEW resalta la instancia actual del
subVL

D. Datos sin definir o inesperados

Los datos sin definir, que son NaN (no un niimero) o Inf (infinito), invalidan
todas las operaciones siguientes. Las operaciones de coma flotante
devuelven los dos siguientes valores simbdlicos que indican cdlculos
imperfectos o resultados sin sentido:

° NaN (no un nimero) representa un valor de coma flotante que producen
las operaciones no validas, como obtener la raiz cuadrada de un niimero
negativo.

* Inf (infinito) representa un valor de coma flotante que producen
las operaciones vdlidas, como dividir un niimero entre cero.

LabVIEW no comprueba las condiciones de desbordamiento o
subdesbordamiento de valores enteros. El desbordamiento y el
subdesbordamiento para nimeros de coma flotante se rige por IEEE 754,
norma para la aritmética de coma flotante de tipo binario.

Las operaciones de coma flotante propagan la fiabilidad de NaN e Inf.
Cuando convierte explicita o implicitamente NaN o Inf en valores enteros
o booleanos, los valores no tienen sentido. Por ejemplo, dividir 1 entre cero
produce Inf. Convertir Inf en un niimero entero de 16 bits produce el valor
32.767, que parece ser un valor normal.

Antes de convertir datos en tipos de datos de nimeros enteros, use

la herramienta de sonda para comprobar los valores intermedios de coma
flotante y ver su validez. Compruebe si hay NaN cableando la funcién
Comparison, Not A Number/Path/Refnum?, al valor que sospecha que no
es vilido.

No confie en valores especiales como NaN, Inf o arrays vacios para
determinar si un VI produce datos sin definir. Confirme que el VI produce
datos definidos haciendo que el VI informe de un error si encuentra una
situacién que probablemente produzca datos sin definir.




Por ejemplo, si crea un VI que utiliza un array de entrada para autoindexar
un bucle For, determine qué desea que haga el VI cuando el array de entrada
esté vacio: producir un codigo de error de salida, sustituir datos definidos
por el valor que cree el bucle o utilizar una estructura Case que no ejecute
el bucle For si el array esta vacio.

E. Comprobacion y gestion de errores

Aunque confie mucho en el VI que cree, no puede predecir todos los
problemas que puede encontrar un usuario. Sin un mecanismo para
comprobar los errores, sélo sabe que el VI no funciona correctamente.

La comprobacién de errores indica donde y por qué se generan los errores.

Gestion de errores automatica

Cada error tiene un cédigo numérico y un mensaje de error correspondiente.

De forma predeterminada, LabVIEW controla automaticamente cualquier
error cuando un VI se ejecuta suspendiendo la ejecucion, resaltando el
subV1 o la funcién donde ocurri6 el error y mostrando un cuadro de didlogo
de error.

Para desactivar la gestién de errores automadtica para el V1actual, seleccione
File»VI Properties y seleccione Execution en el menu desplegable
Category. Para desactivar la gestién de errores automatica de cualquier VI
nuevo que cree, seleccione Tools»Options y Block Diagram en la lista
Category. Para desactivar la gestion de errores automadtica de un subVI o
funcién de un VI, cablee su pardmetro error out al pardmetro error in de
otro subVI o funcién o a un indicador error out.

Gestion manual de errores

Puede elegir otros métodos de gestién de errores. Por ejemplo, si vence

el tiempo limite de un VI de entrada y salida del diagrama de bloques, quiza
no desee que se detenga toda la aplicacién y mostrar un cuadro de didlogo
de error. Quizd desee también que el VI vuelva a intentarlo durante cierto
tiempo. En LabVIEW puede tomar estas decisiones de control de errores en
el diagrama de bloques del VI.

Use los VIs y las funciones de gestién de errores de LabVIEW de la paleta
Dialog & User Interface y los pardmetros error in y error out de

la mayorfa de los VIs y funciones para gestionar errores. Por ejemplo,

si LabVIEW encuentra un error, puede mostrar el mensaje de error en varios
tipos de cuadros de didlogo. Use el control de errores junto con

las herramientas de depuracidn para buscar y gestionar errores.



Los Vlsy las funciones producen errores de uno de dos modos: con c6digos
de error numéricos o con cluster de error. Normalmente las funciones usan
codigos de error numéricos y los VIs usan clusters de error, habitualmente
con entradas y salidas de error.

Cuando realiza cualquier tipo de E/S, piense que pueden ocurrir errores.
Casi todas las funciones de E/S devuelven informacién de error. Incluya
la comprobacién de errores en los VIs, especialmente para operaciones de
E/S (archivo, serie, instrumentacion, adquisicién de datos y comunicacion)
y cree un mecanismo para gestionar bien los errores.

Use los Vs, las funciones y los pardmetros de gestién de errores de
LabVIEW para gestionar los errores. Por ejemplo, si LabVIEW encuentra
un error, puede mostrar el mensaje de error en un cuadro de didlogo.
También puede solucionar el error programéticamente, después borrar el
error cableando la salida error out del subVI o funcién a la entrada error
in del VI Clear Errors. Use el control de errores junto con las herramientas
de depuracidn para buscar y gestionar errores. National Instruments
recomienda encarecidamente usar técnicas de gestion de errores.

Clusters de errores

Use los controles e indicadores de clusters de error para crear entradas y
salidas de error en subVls.

Los clusters error in y error out incluyen los siguientes componentes
de informacidn:

* status es un valor booleano que produce TRUE si ocurri6 un error.

e code es un nimero entero con signo de 32 bits que identifica el error
numéricamente. Un cédigo de error que no sea cero junto con un status
de FALSE indica una advertencia en lugar de un error.

* source es una cadena de caracteres que identifica donde ocurrio el error.

La gestion de errores en LabVIEW sigue el modelo de flujo de datos.

Al igual que los valores de datos fluyen por un VI, también lo hace

la informacién de errores. Cablee la informacién de error desde el principio
del VI al tinal. Incluya un VI de gestion de errores al final del VI para
determinar si el VI se ejecut6 sin errores. Use los clusters error in y error

out en cada VI que utilice o cree para pasar la informacion del error por
el VL.

Mientras se ejecuta el VI, LabVIEW comprueba si hay errores en cada nodo
de ejecucion. Si LabVIEW no encuentra errores, el nodo se ejecuta con
normalidad. Si LabVIEW detecta un error, el nodo pasa el error al siguiente
nodo sin ejecutar esa parte del cédigo. El siguiente nodo hace lo mismo y
asi sucesivamente. Al final del flujo de ejecucién, LabVIEW informa

del error.




Explicacion de errores

Cuando ocurre un error, haga clic con el botdn derecho en el borde del
cluster y seleccione Explain Error del menu contextual para abrir el cuadro
de didlogo Explain Error. El cuadro de didlogo Explain Error contiene
informacién sobre el error. El menti contextual incluye una opcién Explain
Warning si el VI contiene advertencias pero no errores.

También puede acceder al cuadro de didlogo Explain Error desde el menu
Help»Explain Error.

Los VIsyy las funciones producen errores de uno de dos modos: con ¢6digos
de error numéricos o con cluster de error. Normalmente las funciones usan
cédigos de error numéricos y los VIs usan clusters de error, habitualmente
con entradas y salidas de error.



Ejercicio 3-2 Conceptio: depuracion

Objetivo

Use las herramientas de depuracién de LabVIEW.

Descripcion

Complete estos pasos para cargar un VI roto y corregir los errores. Use
la ejecucion paso a paso y el resaltado de la ejecucién para revisar el VI.

1. Abray examine el VI Debug Exercise (Main).
U Seleccione File»Open.

J Abra Debug Exercise (Main) .wvi en el directorio
<Exercises>\LabVIEW Basics I\Debugging.

Aparecerd este panel frontal.
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Figura 3-6. Panel frontal de Debug Exercise (Main).vi

= O El botén Run de la barra de herramientas aparece roto, indicando
ik que el VI estd roto y no puede ejecutarse.




2. Abray examine el diagrama de bloques del VI Debug Exercise (Main).

U Seleccione Window»Show Block Diagram para abrir el diagrama
de bloques de la figura 3-7.
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Figura 3-7. Diagrama de bloques de Debug Exercise (Main).vi

= — La funcién Random Number (0-1) produce un niimero aleatorio
entreel Oyell.

[~ — La funcién Multiply multiplica el nimero aleatorio por 10, 0.

— La constante numérica es el nimero multiplicado por el niimero
aleatorio.

— EI VI Debug Exercise (Sub), situado en el directorio
<Exercises>\LabVIEW Basics I\Debugging)\
Supporting Files, suma 100, 0y calcula la raiz cuadrada
del valor.

3. Busque y solucione cada error.

U Haga clic en el botén Run roto para ver la ventana Error list,
que enumera todos los errores.

Ll Seleccione una descripcion de error en la ventana Error list.
La seccién Details describe el error y en algunos casos recomienda
cémo corregirlo.

U Haga clic en el botén Help para ver un tema de LabVIEW Help que
describa el error en detalle e incluya instrucciones paso a paso para
corregirlo.



U Haga clic en el botén Show Error o haga doble clic en la
descripcion del error para resaltar la zona del diagrama de bloques
o del panel frontal que contenga el error.

(1 Use la ventana Error list para solucionar cada error.

4. Seleccione File»Save para guardar el VI.

5. Abra el panel frontal haciendo clic en €l o seleccionando Window»
Show Front Panel.

6. Haga clic en el botén Run.

7. Seleccione Window»Show Block Diagram para abrir el diagrama
de bloques.

8. Anime el flujo de datos a través del diagrama de bloques.

U Haga clic en el botén Highlight Execution en la barra de
herramientas para habilitar el resaltado de la ejecucion.

() Haga clic en el boton Step Into para iniciar la ejecucién paso a paso.
ba El resaltado de la ejecucion muestra el flujo de datos en el diagrama
de bloques desde un nodo a otro utilizando las burbujas que se
mueven a lo largo de los cables. Los nodos parpadean para indicar
que estan listos para ejecutarse.

U Haga clic en el botén Step Over después de cada nodo para revisar
todo el diagrama de bloques. Cada vez que haga clic en el bot6n Step
Over, se ejecutard el nodo actual y se pausard en el siguiente nodo.

U Los datos aparecen en el panel frontal a medida que ejecuta
las diferentes secciones del V1. El VI genera un ndmero aleatorio y
lo multiplica por 10, 0. El subVI suma 100, 0 y calcula la raiz
cuadrada del resultado.

Q Cuando un borde parpadeante rodea todo el diagrama de bloques,
of haga clic en el botén Step Out para detener la ejecucién paso a paso
~ del VI Debug Exercise (Main).

9. Ejecute paso a paso el VI'y su subVL

U Hagaclic en el botén Step Into para iniciar la ejecucion paso a paso.

S U Cuando parpadee el VI Debug Exercise (Sub), haga clic en el botén
Step Into. Observe el botén Run en el subVI.




10.

Q

Abra el diagrama de bloques del VI Debug Exercise (Main)
haciendo clic en él. Aparecera un simbolo verde en el icono del
subVI del diagrama de bloques del VI Debug Exercise (Main),
indicando que el subVI se esta ejecutando.

Abra el diagrama de bloques del VI Debug Exercise (Sub) haciendo
clic en él.

Haga clic en el botén Step Out dos veces para terminar de revisar
paso a paso el diagrama de bloques del subVI. El diagrama de
bloques del VI Debug Exercise (Main) se activa.

Haga clic en el botén Step Out para detener la ejecucion paso a
paso.

Use una sonda para comprobar valores intermedios en un cable
mientras se ejecuta un VI.

Use la herramienta de sonda para hacer clic en cualquier cable.
Aparece la ventana Probe.

LabVIEW incrementa automdticamente los nimeros de la ventana
Probe y muestra el niimero correspondiente en un simbolo en
el cable donde hizo clic.

Ejecute paso a paso el VI de nuevo. La ventana Probe muestra
los datos que pasan por el cable.

Coloque puntos de interrupcién en el diagrama de bloques para pausar
la ejecucion en esa ubicacion.

Q

Use la herramienta de punto de interrupcién para hacer clic en nodos
o cables. Sittie un punto de interrupcion en el diagrama de bloques
para pausar la ejecucion una vez que se ejecuten todos los nodos del
diagrama de bloques.

Haga clic en el botén Run para ejecutar el VI. Cuando llega a un
punto de interrupcién durante la ejecucion, el VI se pausa y el botén
Pause aparece rojo.

Haga clic en el botén Continue para seguir ejecutando hasta el
préximo punto de interrupcién o hasta que termine de ejecutarse
el VL.

Use la herramienta de punto de interrupcion para hacer clic en
los puntos de interrupcién que configuré y eliminarlos.



11. Haga clic en el boton Highlight Execution para desactivar el resaltado
de la ejecucion.

12. Seleccione File»Close para cerrar el V1'y todas las ventanas abiertas.

Fin del ejercicio 3-2




Autorrevision: cuestionario

1. (Co6mo desactiva la gestién de errores automatica?
a. Seleccionando Operate»Disable Error Handling.
b. Activando el resaltado de ejecucion.

c. Cableando el clister de error de salida de un subV1 al cluster de error
de entrada de otro subVI.

d. Marcando la casilla de verificacion Show Warnings de la ventana
Error list.

2. ¢Cuales de los siguientes elementos forman parte del contenido del
cluster de error? (varias respuestas)

a. Status: booleano
b. Error: cadena de caracteres
¢. Code: numero entero de 32 bits

d. Source: cadena de caracteres






Autorrevision: respuestas al cuestionario

1. ;Cdémo desactiva la gestién de errores automdtica?
Seleccionando Operate»Disable Error Handling.
b. Activando el resaltado de ejecucion.

c¢. Cableando el clister de error de salida de un subVI al clister
de error de entrada de otro subVl.

d. Marcando la casilla de verificacion Show Warnings de la ventana
Error List.

2. ¢Cudles de los siguientes elementos forman parte del contenido del
cluster de error? (varias respuestas)

a. Status: booleano
b. Error: cadena de caracteres
¢. Code: numero entero de 32 bits

d. Source: cadena de caracteres



