Explorando LabVIEW

Temas

Esta leccién muestra cémo navegar por el entorno LabVIEW. Describe
el uso de ments, barras de herramientas, paletas, herramientas, ayuda y
cuadros de didlogo comunes de LabVIEW. También aprendera a ejecutar un
V1y conceptos generales de un panel frontal y diagrama de bloques. Al final
de esta leccidn, creard un VI simple que adquiera, analice y presente datos.
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A. Instrumentos virtuales (Vis)

Los programas LabVIEW se denominan instrumentos virtuales o Vls,
porque su aspecto y funcionamiento imitan a los instrumentos fisicos, como
osciloscopios y multimetros. LabVIEW contiene un conjunto general de
herramientas para adquirir, analizar, mostrar y almacenar datos, asi como
herramientas para ayudarle a resolver problemas de c6digo que escriba.

B. Partes de un Vi

Los VIs de LabVIEW contienen tres componentes principales: la ventana
del panel frontal, el diagrama de bloques y el panel de iconos/conectores.

Ventana del panel frontal

La ventana del panel frontal constituye el interfaz del usuario del VI.

La figura 2-1 muestra un ejemplo de una ventana del panel frontal. Puede
crear la ventana del panel frontal con controles e indicadores, que son

los terminales interactivos de entrada y salida del VI, respectivamente.
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Figura 2-1. Panel frontal de VI

Ventana de diagrama de bloques

Tras crear la ventana del panel frontal, puede afiadir c6digo usando
representaciones graficas de funciones para controlar los objetos del panel
frontal. La figura 2-2 muestra un ejemplo de una ventana de diagrama de
bloques. La ventana del diagrama de bloques contiene este cédigo fuente




gréifico. Los objetos del panel frontal aparecen como terminales en
el diagrama de bloques.
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Figura 2-2. Diagrama de blogues

Panel de iconos y conectores

El panel de iconos y conectores muestra como usar y ver un VIen otro VI.
Un VI que se utiliza en otro VI se denomina subVI, que es similar a una
funcién en un lenguaje de programacion basado en texto. Para utilizar un V1
como subVI, debe tener un panel de iconos y conectores.

Cada VI muestra un icono en la esquina superior derecha de la ventana
del panel frontal y de la ventana del diagrama de bloques. A la izquierda
se muestra un ejemplo del icono predeterminado. Un icono es una
representacion grafica de un V1. El icono puede contener texto e imdgenes.
Si utiliza un VI como un subVl, el icono identifica el subVI en el diagrama
de bloques del VI. El icono predeterminado contiene un niimero que indica
cuéantos VIs nuevos abrid tras lanzar LabVIEW.

T Para utilizar un VI como subVI, debe crear un panel de conectores,

H | H mostrado a la izquierda. El panel de conectores es un conjunto de terminales
del icono que corresponde con los controles e indicadores de ese VI, similar
a la lista de pardmetros de una llamada de funcién en lenguajes de
programacion basados en texto. Acceda al panel de conectores haciendo clic
con el botdn derecho en el icono de la esquina superior derecha de la ventana
del panel frontal. No es posible acceder al panel de conectores desde

el icono de la ventana del diagrama de bloques.




C. Inicioc de un VI

Cuando lance LabVIEW, aparecerd la ventana Getting Started. Use esta
ventana para crear nuevos VIs y proyectos, seleccionar los archivos
LabVIEW abiertos mds recientemente, buscar ejemplos y utilizar la ayuda
de LabVIEW. También puede acceder a informacién y recursos para
aprender mds sobre LabVIEW, como manuales especificos, temas de ayuda
y recursos en ni . com/manuals.

La ventana Getting Started se cierra cuando abre un archivo existente o
crea un nuevo archivo. Puede mostrar la ventana seleccionando View»
Getting Started Window.
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Puede configurar LabVIEW para que abra un VI nuevo al inicio en lugar de
mostrar la ventana. Seleccione Tools»Options, seleccione Environment
en la lista Category y marque la casilla de verificacion Skip Getting
Started window on launch.

Nota Los elementos de la ventana Getting Started varian segun la versién de
LabVIEW y de las herramientas adicionales que instale.

Creacidn o apertura de un VI o proyecto

Puede empezar en LabVIEW desde un VI o proyecto nuevo, abriendo un VI
o proyecto existente y modificadndolo, o abriendo una plantilla para empezar
su nuevo VI o proyecto.

Creacion de nuevos proyectos y Vis

Para abrir un nuevo proyecto desde la ventana Getting Started, seleccione
Empty Project en la lista New. Se abrird un nuevo proyecto sin nombre y
podrd afiadirle archivos y guardarlo.

Para abrir un nuevo VI que no esté asociado a un proyecto, seleccione Blank
VI en la lista New de la ventana Getting Started.

Creacion de un VI desde una plantilla

Seleccione File»New para mostrar el cuadro de didlogo New, que muestra
las plantillas de VI integradas en LabVIEW. También puede mostrar

el cuadro de didlogo New haciendo clic en el enlace New de la ventana
Getting Started.
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Abrir un VI existente
Seleccione Browse en la lista Open de la ventana Getting Started para
navegar hasta un VI existente y abrirlo.
@ Consejo Los VIs que modifique en este curso se encuentran en el directorio

<Exercises>\LabVIEW Basics I.




Cuando se cargue el VI, podré aparecer un cuadro de didlogo de estado
similar a la figura 2-5.
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Figura 2-5. Cuadro de didlogo que indica el estado de la carga de Vs

La seccién Loading enumera los subVIs del VI segiin se cargan en memoria
y muestra el niimero de subVls cargados hasta ahora. Puede cancelar
la carga en cualquier momento, haciendo clic en el botén Stop.

Si LabVIEW no puede encontrar inmediatamente un subVI, empezard a
buscar en todos los directorios especificados en la ruta de bisqueda del VI.
Puede modificar la ruta de la busqueda del VI seleccionando Tools»
Options y después Paths en la lista Category.

LabVIEW puede hacer caso omiso de un subVI haciendo clic en el botén
Ignore Item, o puede hacer clic en el botén Browse para buscar el subVI
que falte.



Guardar un Vi

Para guardar un nuevo VI, seleccione File»Save. Si ya guard6 su VI,
seleccione File»Save As para acceder al cuadro de didlogo Save As. Desde
el cuadro de didlogo Save As, puede crear una copia del VI o eliminar el VI
original y sustituirlo por el nuevo.
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@ Nota Consulte el tema Save As Dialog Box de la ayuda de LabVIEW para mostrar

informacién detallada sobre cada opcién del cuadro de didlogo Save As.
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D. Explorador de proyectos

Use proyectos para agrupar archivos de LabVIEW asi como otro tipo

de archivos, crear especificaciones de construccion de ejecutables o
instaladores y descargar archivos en destinos. Cuando guarda un proyecto,
LabVIEW crea un archivo de proyecto (. lvpro3j), que incluye referencias
a los archivos que contiene, informacién de configuracién, informacién

de construccién de ejecutables, informacién de descarga, entre otros.

Es necesario utilizar un proyecto para crear aplicaciones y librerias
compartidas. También debe utilizar un proyecto para trabajar con una
plataforma en tiempo real (RT), de array de puertas programable in situ
(FPGA) o agenda electrénica (PDA). Consulte la documentacion del
modulo especifico para obtener informacién adicional acerca de usar
proyectos con los moédulos de tiempo real, FPGA y PDA de LabVIEW.

Ventana del explorador de proyectos

Use la ventana Project Explorer para crear y modificar proyectos en
LabVIEW. Seleccione File»xNew Project para mostrar la ventana Project
Explorer. También puede seleccionar Project»New Project o Empty
Project en el cuadro de didlogo New para mostrar la ventana Project
Explorer.

La ventana Project Explorer incluye dos paginas: Items y Files. La pdgina
Items muestra los elementos del proyecto segtin han sido incluidos en el
mismo. La pagina Files muestra los elementos del proyecto que tienen un
archivo correspondiente en el disco. Puede organizar nombres de archivos y
carpetas en esta pagina. Las operaciones que realice en la pagina Files
reflejan y actualizan el contenido del disco. Puede cambiar de una pigina a
la otra haciendo clic con el botén derecho en una carpeta o elemento bajo un
destino y seleccionando Show in Items View o Show in Files View en

el menu contextual.

La ventana Project Explorer incluye los siguientes elementos de forma
predeterminada:

e Project root: contiene el resto de elementos de la ventana Project
Explorer. Esta etiqueta en la raiz del proyecto incluye el nombre de
archivo del proyecto.

~ My Computer: representa el ordenador local como un destino
de] proyecto.

— Dependencies: incluye los elementos que requieren los VIs de un
destino.



@

— Build Specifications: incluye configuraciones para distribuciones
de codigo y otros tipos de distribuciones disponibles en los toolkits
y médulos de LabVIEW. Si tiene instalada la versién PDS
(Professional Development System) o el Application Builder
de LabVIEW, puede usar Build Specifications para configurar
aplicaciones independientes, librerfas compartidas, instaladores
y archivos comprimidos.

Consejo  Un destino es cualquier dispositivo que pueda ejecutar un VI,

Cuando afada otro destino al proyecto, LabVIEW creard otro elemento
en la ventana Project Explorer para representar la nueva plataforma.
Cada destino incluye también las secciones Dependencies y Build
Specifications. Puede afiadir archivos bajo cada uno de los destinos.

Barras de herramientas de proyectos

Use los botones de las barras de herramientas Estandar, Proyecto,
Instalacién y Control de cédigo fuente para realizar operaciones en
un proyecto de LabVIEW. Las barras de herramientas estdn disponibles
en la parte superior de la ventana Project Explorer, como muestra

la figura 2-7. Quizd tenga que expandir la ventana Project Explorer
para mostrar todas las barras de herramientas.

- e

3 Project Expim'er - Weathe S"taii‘on“.lvproj "

File Edit view Project Operate|| Tools Window Help
. LT o o o : I : :
jgwim-v o ]

Items | Fies |

Project: Weather Station.lvproj <
Wy Computer |
Weather Station ULwvi
Determine Warnings, vi
Temperature Simulator.vi
wWeather Station States.ctl

Depandencies <§

"% Build Specifications «g————

® O ©® 6

BWN -

Raiz de proyectos
Destino

Dependencias

Crear especificaciones

Barra de herramientas estandar

Barra de herramientas de proyectos

Barra de herramientas de construccion

Barra de herramientas de control de cédigo fuente

O~NO O

Figura 2-7. Ventana Project Explorer




Consejo La barra de herramientas Control de cédigo fuente sélo estd disponible si
= tiene el control de codigo fuente configurado en LabVIEW.

Puede mostrar u ocultar barras de herramientas desde View»Toolbars y
seleccionando las barras de herramientas que desea mostrar u ocultar.
También puede hacer clic con el botén derecho en una zona abierta de cada
barra de herramientas para seleccionar la que desee mostrar o ocultar.

Creacidn de un proyecto en LabVIEW

Complete los pasos siguientes para crear un proyecto.

l.

[N

Seleccione File»New Project para mostrar la ventana Project
Explorer. También puede seleccionar Project»Empty Project en
el cuadro de didlogo New para mostrar la ventana Project Explorer.

Afada elementos que desee incluir en el proyecto bajo un destino.

Seleccione File»Save Project para guardar el proyecto.

Anadir archivos existentes a un proyecto

Puede afiadir archivos existentes a un proyecto. Use el elemento
My Computer (u otro destino) en la ventana Project Explorer para afiadir
archivos como VIs o archivos de texto a un proyecto de LabVIEW.

Afiada elementos que desee incluir en el proyecto de estos modos:

Haga clic con el botén derecho en My Computer y seleccione Add»
File desde el menu contextual para afadir un archivo. También puede
seleccionar Project»Add To Project»File desde el ment Project
Explorer para afiadir un archivo.

Haga clic con el bot6n derecho en el destino y seleccione Add»Folder
(Auto-populating) desde el menti contextual para afiadir una carpeta
de relleno automadtico. También puede seleccionar Project»Add To
Project»Add Folder (Auto-populating) para afiadir una carpeta de
relleno automatico. LabVIEW controla y actualiza continuamente

la carpeta segun los cambios realizados en el proyecto y en el disco.

Haga clic con el botdén derecho en el destino y seleccione Add»Folder
(Snapshot) desde el menu contextual para afiadir una carpeta virtual.
También puede seleccionar Project»Add To Project»Add Folder
(Snapsheot) para afiadir una carpeta virtual. Cuando seleccione un
directorio del disco, LabVIEW creard una nueva carpeta virtual en

el proyecto con el mismo nombre que el directorio del disco. LabVIEW
también crea elementos en el proyecto que representan el contenido

de todo el directorio, incluidos los archivos y el contenido de
subdirectorios. Si selecciona una carpeta del disco, afiadira el contenido
de toda la carpeta, incluyendo archivos y el contenido de las subcarpetas.



Nota Tras afiadir una carpeta virtual del disco a un proyecto, LabVIEW no actualiza
automaticamente la carpeta en el proyecto si realiza cambios en la carpeta del disco.

e Haga clic con el botén derecho en el destino y seleccione New» VI
desde el menu contextual para afiadir un nuevo VI. También puede
seleccionar File»New VI o Project»Add To Project»New VI para
afadir un VI nuevo.

* Seleccione el icono del VI en la esquina superior derecha de una
ventana de panel frontal o de diagrama de bloques y arrastre el icono
al destino.

e Seleccione un elemento o carpeta del sistema de archivos de su
ordenador y arrdstrelo al destino.

Eliminar elementos de un proyecto

Puede eliminar elementos de la ventana Project Explorer de las siguientes
maneras:

e Haga clic con el botén derecho en el elemento que desee eliminar y
seleccione Remove from Project del ment contextual.

e Seleccione el elemento que desea eliminar y pulse <Delete>.

e Seleccione el elemento que desee eliminar y haga clic en el botén
Remove from Project de 1a barra de herramientas estandar.

@ Nota Eliminar un elemento de un proyecto no implica eliminarlo del disco.

Organizar elementos de un proyecto

La ventana Project Explorer incluye dos paginas: Items y Files. La pagina
Items muestra los elementos del proyecto que existen en el arbol de
proyecto. La pagina Files muestra los elementos del proyecto que tienen un
archivo correspondiente en el disco. Puede organizar nombres de archivos y
carpetas en esta pagina. Las operaciones de proyectos de la pagina Files
reflejan y actualizan el contenido del disco. Puede cambiar de una pagina a
la otra haciendo clic con el botén derecho en una carpeta o elemento bajo un
destino y seleccionando Show in Items View o Show in Files View en

el ment contextual.

Use carpetas para organizar elementos en la ventana Project Explorer.
Puede afiadir dos tipos de carpetas en un proyecto de LabVIEW: virtuales y
de relleno automdtico. Las carpetas virtuales organizan elementos del
proyecto. Haga clic con el botén derecho en Project Root o en el destino y
seleccione New» Virtual Folder desde el ment contextual para crear una
carpeta virtual. Las carpetas de relleno automatico se actualizan en tiempo
real para reflejar el contenido de las carpetas del disco. Afiada una carpeta
de relleno automdtico al proyecto para mostrar elementos del proyecto como
aparecen en el disco.




Las carpetas de relleno automatico sélo se ven en la pagina Items de

la ventana Project Explorer. Puede ver el contenido del disco de una
carpeta de relleno automaético pero no puede realizar operaciones en el disco
como cambiar el nombre, reorganizar y eliminar elementos del proyecto.
Para realizar operaciones del disco en elementos de una carpeta de relleno
automdtico, use la pdgina Files de la ventana Project Explorer. La pagina
Files muestra la ubicacién de las carpetas del proyecto en el disco.

Las operaciones de proyectos de la pdgina Files reflejan y actualizan el
contenido del disco. Igualmente, LabVIEW actualiza automdticamente

la carpeta de relleno automdtico en el proyecto si realiza cambios en

la carpeta del disco fuera de LabVIEW.

Es posible ordenar elementos en una carpeta. Para ello, haga clic con el
botén derecho en una carpeta y seleccione Arrange By»Name desde

el menu contextual para ordenar elementos por orden alfabético. Haga clic
con el botén derecho en una carpeta y seleccione Arrange By»Type desde
el menu contextual para ordenar elementos por tipo de archivo.

Ver archivos de un proyecto

Cuando afiade un archivo a un proyecto de LabVIEW, LabVIEW incluye
una referencia al archivo del disco. Haga clic con el botén derecho en un
archivo de la ventana Project Explorer y seleccione Open desde el menu
contextual para abrir el archivo en su editor predeterminado.

Haga clic con el botén derecho en el proyecto y seleccione View»Full Paths
desde el ment contextual para mostrar dénde estan guardados en el disco
los archivos a los que hace referencia un proyecto.

Use el cuadro de didlogo Project File Information para mostrar dénde se
encuentran en el disco los archivos a los que hace referencia un proyecto.
Seleccione Project»File Information para mostrar el cuadro de didlogo
Project File Information. También puede hacer clic con el botén derecho
en el proyecto y seleccionar View»File information desde el menu
contextual para mostrar el cuadro de didlogo Project File Information.

Guardar un proyecto
Puede guardar un proyecto de LabVIEW de los siguientes modos:

» Seleccione File»Save Project.
* Seleccione Project»Save Project.

* Haga clic con el botén derecho en el proyecto y seleccione Save en
el menu contextual.

* Hagaclic en el botén Save Project en la barra de herramientas Project.



Debe guardar los nuevos archivos que no hayan sido guardados previamente
en un proyecto antes de poder guardar éste. Cuando guarde un proyecto,
LabVIEW no guardard dependencias como parte del archivo del proyecto.

@ Nota Realice una copia de seguridad de un proyecto cuando vaya a hacer revisiones
importantes en éL.

E. Ventana del panel frontal

Cuando abra un VI nuevo o existente, aparecerd la ventana del panel frontal
del VI. La ventana del panel frontal es la interfaz del usuario para el VI.
La figura 2-8 muestra un ejemplo de una ventana de panel frontal.
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Figura 2-8. Ejemplo de un panel frontal

Controles e indicadores

Puede crear el panel frontal con controles e indicadores, que son

los terminales interactivos de entrada y salida del VI, respectivamente.
Ejemplos de controles son mandos, botones de comando, dials y otros
dispositivos de entrada. Los indicadores son graficos, LED y otras
visualizaciones. Los controles simulan dispositivos de entrada de
instrumentos y ofrecen datos al diagrama de bloques del VI. Los indicadores
simulan dispositivos de salida de instrumentos y muestran datos que
adquiere o genera el diagrama de bloques.




La figura 2-8 muestra los siguientes objetos: dos controles: Number of
Measurements y Delay (sec). Tiene un indicador: un griafico XY llamado
Temperature Graph.

El usuario puede cambiar el valor de entrada de los controles Number of
Measurements y Delay (sec). El usuario puede ver el valor que genera
el VI en el indicador Temperature Graph. El VI genera los valores para
los indicadores basdndose en el cédigo creado en el diagrama de bloques.
Aprenderd esto en la seccidon Controles ¢ indicadores numéricos.

Cada control o indicador tiene un tipo de datos asociado. Por ejemplo,

el control deslizante horizontal Delay (sec) es un tipo de datos numérico.
Los tipos de datos mds utilizados son numérico, booleano y cadena de
caracteres. Aprenderd otros tipos de datos en la leccion 4, Implementacion
de un VI

Controles e indicadores numeéricos

El tipo de datos numérico puede representar niimeros de varios tipos, como
entero o real. Los dos objetos numéricos comunes son el control numérico
y el indicador numérico, como se ve en la figura 2-9. Objetos como

los medidores y los dials también representan datos numéricos.

1 Botones de incremento/decremento 3 Indicador numérico
2 Control numérico

Figura 2-9. Controles e indicadores numéricos

Para introducir o cambiar valores en un control numérico, haga clic en

los botones de incremento y decremento con la herramienta de operaciones
o haga doble clic en el nimero con la herramienta de etiquetado o

de operaciones, escriba un nuevo niimero y pulse la tecla <Intro>.



Controles e indicadores hooieanos

El tipo de datos booleano representa datos que sélo tienen dos estados
posibles, como TRUE y FALSE u ON y OFF. Use los controles e
indicadores booleanos para escribir y mostrar valores booleanos.

Los objetos booleanos simulan conmutadores, botones de comando y LED.
Los objetos booleanos de tipo conmutador vertical y de tipo LED redondo
aparecen en la figura 2-10.

Yattical Teagle Switch Found LED

Figura 2-10. Controles e indicadores booleanos

Controles e indicadores de cadena de caracteres

El tipo de datos cadena de caracteres es una secuencia de caracteres ASCII.
Use controles de cadena de caracteres para recibir texto del usuario como
una contrasefia 0 un nombre de usuario. Use indicadores de cadena de
caracteres para mostrar texto al usuario. Los objetos de cadena de caracteres
mds comunes son tablas y cuadros de entrada de texto, como se ve en

la figura 2-11.
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Figura 2-11. Controles e indicadores de cadena de caracteres




Paleta de controles

La Paleta de Controles contiene los controles e indicadores que utiliza para
crear el panel frontal. Se accede a la Paleta de Controles desde la ventana
del panel frontal seleccionando View»Controls Palette. La Paleta de
Controles se divide en varias categorias; puede mostrar alguna de ellas o
todas segtn sus necesidades. La figura 2-12 muestra una visualizacion

de la Paleta de controles con todas las categorias mostradas y la categoria
Modern expandida. Durante este curso, trabajard exclusivamente en

la categoria Modern.
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Figura 2-12. Paleta de Controles

Para mostrar o ocultar categorias (subpaletas), seleccione el botén View
en la paleta y seleccione o deseleccione en la opcién Always Visible

Categories. Aprenda mas sobre el uso de la paleta Controls en
el ejercicio 2-2.
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Todos los objetos de LabVIEW tienen asociados menus contextuales,
conocidos también como mends abreviados, menids emergentes y menus de
botén derecho. Cuando cree un VI, use los elementos del ment contextual
para cambiar el aspecto o el comportamiento de los objetos del panel frontal
y del diagrama de bloques. Para acceder al meni contextual, haga clic con
el botén derecho en el objeto.

La figura 2-13 muestra un ment contextual para un medidor.
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Create P =
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Data Operations b
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Fit Control bo Pane
Scale Object with Pane
Representation
Data Range. ..
Format & Precision. ..
Add Needle

Scale

Properties

Figura 2-13. Men( contextual para un medidor

Cuadros de dialogo de propiedades

Los objetos de la ventana del panel frontal también tienen cuadros de
didlogo de propiedades que puede utilizar para cambiar el aspecto o el
comportamiento de los objetos. Haga clic con el botén derecho en un objeto
y seleccione Properties en el menu contextual para acceder al cuadro de
didlogo de propiedades de un objeto. La figura 2-14 muestra el cuadro de
didlogo de propiedades para el medidor de la figura 2-13. Las opciones
disponibles en el cuadro de didlogo de propiedades para un objeto son
similares a las opciones del mend contextual de ese objeto.
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Figura 2-14. Cuadro de didlogo de propiedades para un medidor

Puede seleccionar varios objetos en el panel frontal o en el diagrama de
bloques y modificar las propiedades que compartan los objetos. Para
seleccionar varios objetos, use la herramienta de posicionamiento para
arrastrar un rectangulo de seleccion alrededor de todos los objetos que desee
modificar o mantenga pulsada la tecla <Mayis> mientras hace clic en cada
objeto. Haga clic con el botén derecho en un objeto de la seleccion y
seleccione Properties en el menu contextual para acceder al cuadro de
didlogo Properties. El cuadro de didlogo Properties solo muestra fichas y
propiedades que comparten los objetos que seleccione. Seleccione objetos
similares para mostrar mas fichas y propiedades. Si selecciona objetos que
no comparten ninguna propiedad comun, el cuadro de didlogo Properties
no mostrara fichas ni propiedades.



Barra de herramienias de Ia veniana del panel frontal

A Precaucion

Cada ventana tiene una barra de herramientas asociada. Use los botones
de la barra de herramientas de la ventana del panel frontal para ejecutar y
modificar el VI.

La siguiente barra de herramientas aparece en la ventana del panel frontal.
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Haga clic en el botén Run para ejecutar un VI. LabVIEW compila el VI,
si es necesario. Puede ejecutar un VI si el boton Run aparece como una
flecha blanca continua, como se ve a la izquierda. La flecha blanca continua
también indica que puede utilizar el VI como un subVI si crea un panel

de conectores para el VI.
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Mientras se ejecuta el VI, el botén Run aparece como se muestra a la
izquierda si el VI es de alto nivel, lo que significa que no tiene VIs que
le llamen y por lo tanto no es un subVI.

Si el VI que se estd ejecutando es un subV1, el botén Run aparece como a
la izquierda.

El botén Run aparece roto cuando el VI que estd creando o modificando
contiene errores. Si el botén Run sigue apareciendo roto tras terminar de
cablear el diagrama de bloques, el VI estd roto y no puede ejecutarse. Haga
clic en este botén para mostrar la ventana Error list, que enumera todos
los errores y advertencias.

Haga clic en el boton Run Continuously para ejecutar el VI hasta que anule
o pause la ejecucion. También puede hacer clic en el botén de nuevo para
desactivar la ejecucién continua.

Mientras se ejecuta el VI, aparece el botén Abort Execution. Haga clic
en este botén para detener el VI inmediatamente si no hay otro modo de
detenerlo. Si mds de un VI de alto nivel en ejecucién utiliza el VI, el botén
aparece atenuado.

El boton Abort Execution detiene inmediatamente el VI, antes de que

termine la iteracion actual. Si aborta un VI que utiliza recursos externos, como

el hardware externo, podria dejar los recursos en un estado desconocido por no
restablecerlos o liberarlos correctamente. Disefie VIs con un botén de parada para evitar
este problema.
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Haga clic en el bot6n Pause para pausar un VI en ejecucién. Cuando haga
clic en el botén Pause, LabVIEW resaltard en el diagrama de bloques

la ubicacion donde pausd la ejecucién y el botén Pause aparecerd en rojo.
Haga clic en el botén Pause de nuevo para seguir ejecutando el VI.

Seleccione el ment desplegable Text Settings para cambiar los ajustes de
fuente para las partes seleccionadas del VI, como el tamafio, estilo y color.

Seleccione el menu desplegable Align Objects para alinear objetos a
lo largo de los ejes, como el vertical, el borde superior, borde izquierdo, etc.

Seleccione el ment desplegable Distribute Objects para espaciar objetos
uniformemente, incluidos los espacios, la compresion, etc.

Seleccione el ment desplegable Resize Objects para cambiar varios objetos
del panel frontal al mismo tamaiio.

Seleccione el menu desplegable Reorder cuando tenga objetos solapados
y desee definir cudl estd enfrente o detrds de otro. Seleccione uno de

los objetos con la herramienta de posicionamiento y después seleccione
Move Forward, Move Backward, Move To Front o Move To Back.

= Seleccione el botén Show Context Help Window para cambiar
g la visualizacion de la ventana Context Help.
Enter Text aparece para recordarle que existe un nuevo valor para sustituir
¥ auno antiguo. El botén Enter Text desaparece cuando hace clic en él, pulsa
la tecla <Enter> o hace clic en el espacio de trabajo del panel frontal o
del diagrama de bloques.
@ Consejo La tecla <Intro> del teclado numérico termina una entrada de texto,

mientras que la tecla <Intro> principal afiade una nueva linea. Para modificar este
comportamiento, seleccione Tools»Options, seleccione Environment de la lista
Category y marque la opcién End text entry with Enter key.



F. Ventana de diagrama de bloques

Entre los objetos del diagrama de bloques se incluyen los terminales,
subVls, funciones, estructuras y cables, los cuales transfieren datos entre
otros objetos del diagrama de bloques.
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Figura 2-15. Ejemplo de un diagrama de bloques y el panel frontal correspondiente

Los objetos de la ventana del panel frontal aparecen como terminales en el
diagrama de bloques. Los terminales son puertos de entrada y de salida que
intercambian informacioén entre el panel frontal y el diagrama de bloques.
Los terminales son andlogos a los pardmetros y constantes en lenguajes de
programacion basados en texto. Existen terminales de control o de indicador
y terminales de nodo. Los terminales de control y de indicador estidn
asociados a los controles e indicadores del panel frontal. Los datos que
introduce en los controles del panel frontal (a y b en la figura 2-15)

entran en el diagrama de bloques mediante los terminales de control.

A continuacidn, los datos entran en las funciones Add y Subtract. Cuando
las funciones Add y Subtract completan sus cdlculos, producen nuevos
valores de datos. Los valores de datos fluyen a los terminales indicadores,
donde actualizan los indicadores del panel frontal (a+b y a~b en

la figura 2-15).




Los terminales de la figura 2-15 pertenecen a los controles e indicadores del
panel frontal. Como los terminales representan las entradas y salidas de su
VI, los subVls y las funciones también tienen terminales, mostrados a

la izquierda. Por ejemplo, los paneles de conectores de las funciones Add y
Subtract tienen tres terminales de nodo. Para mostrar los terminales de

la funcidn en el diagrama de bloques, haga clic con el botén derecho en

el nodo de la funcién y seleccione Visible Items»Terminals en el ment
contextual.

Controles, indicadores y constantes

Los controles, indicadores y constantes actiian como entradas y salidas
del algoritmo del diagrama de bloques. Considere la implementacion del
algoritmo para el drea de un tridngulo:

Area = .5 * Base * Altura

En este algoritmo, Base y Altura son entradas y Area es una salida, como
se ve en la figura 2-16.

Area of a Triangle

Area (o2}
n

oeen Height <

%= Base >

Figura 2-16. Panel frontal del area de un triangulo

La constante .5 no aparece necesariamente en la ventana del panel frontal,
salvo posiblemente como documentacién del algoritmo.



La figura 2-17 muestra una posible implementacién de este algoritmo en un
diagrama de bloques de LabVIEW. Este diagrama de bloques tiene cuatro
terminales distintos constituidos por dos controles, una constante y

un indicador.

[Determines the area of a triangle. |

Area (om™2)

Height: (oo Triangular Multiplie

1 Controles 2 Indicador 3 Constante l

Figura 2-17. Diagrama de bloques del drea de un triangulo con vista
de iconos de los terminales

Tenga en cuenta que los terminales del diagrama de bloques Base (cm) y
Altura (cm) tienen un aspecto distinto del terminal Area (cm?2). Existen
dos caracteristicas distintivas entre un control y un indicador en el diagrama /
de bloques. La primera es una flecha en el terminal que indica la direccién

del flujo de datos. Los controles tienen flechas que muestran los datos que

salen del terminal, mientras que el indicador tiene una flecha que muestra \
los datos que entran al terminal. La segunda caracteristica distintiva es el
borde alrededor del terminal. Los controles tienen un borde mds grueso y
los indicadores uno mds fino.

Puede ver terminales con o sin la vista de icono. La figura 2-18 muestra el
mismo diagrama de bloques sin utilizar la vista de icono de los terminales;
sin embargo, existen las mismas caracteristicas distintivas entre

los controles y los indicadores.

[Determines the area of a triangle, |

Area (cm™Z)

Figura 2-18. Diagrama de bloques del drea de un triangulo sin vista
de iconos de los terminales




Nodos del diagrama de hloques

Los nodos son objetos del diagrama de bloques que tienen entradas o salidas
y realizan operaciones cuando se ejecuta un VI. Son andlogos a las
instrucciones, operadores, funciones y subrutinas en lenguajes de
programacioén basados en texto. Los nodos pueden ser funciones, subVIs o
estructuras. Las estructuras son elementos de control de procesos, como
las estructuras Case, los bucles For o los bucles While. Las funciones Add y
Subtract de la figura 2-15 son nodos de funcion.

Funciones

Las funciones son los elementos operativos fundamentales de LabVIEW.
Las funciones no tienen ventanas de panel frontal ni de diagrama de bloques
pero si paneles de conectores. Al hacer doble clic en una funcién sélo se
selecciona ésta. Una funcién tiene un fondo amarillo pdlido en su icono.

SubVis

Los subVIs son Vs que crea para usar dentro de otro VI o a los que accede
en la paleta Functions.

Cualquier VI puede utilizarse como un subVI. Al hacer doble clic en un
subV1 del diagrama de bloques, aparece la ventana del panel frontal.

El panel frontal incluye controles e indicadores. El diagrama de bloques
incluye cables, iconos, funciones, posiblemente subVlIs y otros objetos de
LabVIEW. La esquina superior derecha de la ventana del panel frontal y de
la ventana del diagrama de bloques muestra el icono para el VI. Es el icono
que aparece cuando sitia el VI en un diagrama de bloques como un subVI.

Los subVIs también pueden ser VIs Express. Los VIs Express son nodos
que requieren un cableado minimo porque los configura con cuadros de
didlogo. Use VIs Express para tareas comunes de medicién. Puede guardar
la configuracion de un VI Express como un subVI. Consulte el tema Express
Vis de la ayuda de LabVIEW para mostrar informacién detallada sobre

la creacion de un subVI a partir de una configuracién de un VI Express.

LabVIEW usa iconos de colores para distinguir entre VIs Express y otros
VIs del diagrama de bloques. Los iconos para VIs Express aparecen en el
diagrama de bloques como iconos rodeados de un campo azul mientras que
los iconos de subVlIs tienen un campo amarillo.

Nodos expandibles frente a iconos

Puede mostrar VIs y VIs Express como iconos o como nodos expandibles.
Los nodos expandibles aparecen como iconos rodeados de un campo de
color. Los subVIs aparecen con un campo amarillo y los VIs Express con
un campo azul. Use iconos si desea conservar espacio en el diagrama de
bloques. Use nodos expandibles para facilitar el cableado y para ayudar en



la documentacidn de diagramas funcionales. De forma predeterminada,
los subVls aparecen como iconos en el diagrama de bloques y los VIs
Express aparecen como nodos expandibles. Para mostrar un subVI o VI
Express como un nodo expandible, haga clic con el botén derecho en el
subVI o VI Express y quite la marca junto al elemento del ment contextual
View As Icon.

Puede cambiar el tamafio del nodo expandible para facilitar mas el cableado,
pero también requiere un espacio considerable en el diagrama de bloques.
Complete los pasos siguientes para cambiar el tamaifio de un nodo en

el diagrama de bloques:

1. Mueva la herramienta de posicionamiento sobre el nodo. Aparecen
los controladores de tamafio arriba y abajo del nodo.

2. Mueva el cursor sobre un controlador de tamafio para cambiar el cursor
al de cambio de tamafio.

3. Useel cursor de cambio de tamafio para arrastrar el borde del nodo hacia
abajo para mostrar mds terminales.

4. Suelte el botén del raton.
Para cancelar una operacién de cambio de tamafio, arrastre el borde del nodo

mas alld de la ventana del diagrama de bloques antes de soltar el botén del
raton.

La figura 2-19 muestra el VI Basic Function Generator como un nodo
expandible con un tamaifio diferente.

LA 2SR BALASAEL

Figura 2-19. VI Basic Function Generator en varios modos de visualizacion

@ Nota Si muestra un subVI o VI Express como un nodo expandible, no puede ver
los terminales de ese nodo ni habilitar el acceso a la base de datos para ese nodo.



Cables

Con los cables se transfieren datos entre objetos del diagrama de bloques.
En la figura 2-15, los cables conectan los terminales de control y de
indicador a la funcién Add y Subtract. Cada cable tiene un solo origen de
datos, pero puede cablearlo a numerosos VIs y funciones que leen los datos.
Los cables tienen distintos colores, estilos y grosores, en funcién de sus
tipos de datos.

Un cable roto aparece como una linea negra discontinua con una X roja en el

b . S .
medio, como se ve a la izquierda. Los cables se rompen por varias razones,
como al intentar cablear dos objetos con tipos de datos incompatibles.
La tabla 2-1 muestra los tipos de cable mds comunes.
Tabla 2-1. Tipos de cables comunes
Tipo de cable Escalar Array 1D Array 2D Color
Numérico - . Naranja (coma flotante),
Azul (ndmero entero)
Booleano @ | e N Verde
Cadena de smmrnnnnmn soconnaso rRRRsRARAR Rosa
caracteres

En LabVIEW se usan cables para conectar varios terminales entre si y pasar
datos a un VI. Debe conectar los cables a las entradas y salidas que sean
compatibles con los datos que se transfieren con el cable. Por ejemplo,

no puede cablear una salida de array a una entrada numérica. Ademads,

la direccién de los cables debe ser correcta. Debe conectar los cables s6lo
a una entrada y al menos a una salida. Por ejemplo, no puede cablear dos
indicadores entre si. Los componentes que determinan la compatibilidad del
cableado son el tipo de datos del control o el indicador y el tipo de datos
del terminal.

Tipos de datos

Los tipos de datos indican qué objetos, entradas y salidas puede cablear
entre si. Por ejemplo, si un conmutador tiene un borde verde, puede cablear
un conmutador a cualquier entrada con una etiqueta verde en un VI Express.
Si un mando tiene un borde naranja, puede cablear un mando a cualquier
entrada con una etiqueta naranja. Sin embargo, no puede cablear un mando
naranja a una entrada con una etiqueta verde. Tenga en cuenta que los cables
tienen el mismo color que el terminal.




Cableado automatico de ohjetos

Cuando mueve un objeto seleccionado cerca de otros objetos del diagrama
de bloques, LabVIEW traza cables temporales para mostrarle conexiones
vdlidas. Cuando suelta el botén del ratén para colocar el objeto en el
diagrama de bloques, LabVIEW conecta automdticamente los cables.
También puede cablear autométicamente objetos que ya estdn en el
diagrama de bloques. LabVIEW conecta los terminales que combinan mejor
y no conecta los que no combinan.

Cambie el cableado automdtico pulsando la barra espaciadora mientras
mueve un objeto con la herramienta de posicionamiento.

De forma predeterminada, el cableado automatico se activa cuando
selecciona un objeto de la paleta Functions o cuando copia un objeto que
ya estd en el diagrama de bloques pulsando la tecla <Ctrl> y arrastrando
el objeto. El cableado automatico se desactiva de forma predeterminada
cuando usa la herramienta de posicionamiento para mover un objeto que
ya estd en el diagrama de bloques.

Puede ajustar la configuracién del cableado automatico seleccionando
Tools»Options y después Block Diagram en la lista Category.

Cableado manual de objetos

Cuando pasa la herramienta de cableado sobre un terminal, aparecera

una ayuda con el nombre del terminal. Ademas, el terminal parpadea en

la ventana Context Help y en el icono para ayudarle a comprobar que
estd cableando en el terminal correcto. Para cablear objetos entre si, pase
la herramienta de cableado por el primer terminal, haga clic, pase el cursor
sobre el segundo terminal y haga clic de nuevo. Después de cablear, puede
hacer clic con el botén derecho en el cable y seleccionar Clean Up Wire
desde el menu contextual para que LabVIEW elija automdticamente una
ruta para el cable. Si tiene que eliminar cables rotos, pulse <Ctrl-B> para
eliminar todos los cables rotos del diagrama de bloques.




Paleta de funciones

La paleta Functions contiene los VIs, funciones y constantes que utiliza
para crear el diagrama de bloques. Se accede a la paleta Functions desde
el diagrama de bloques seleccionando View»Functions Palette. La paleta
Functions se divide en varias categorias; puede mostrar u ocultar categorias
seglin sus necesidades. La figura 2-20 muestra una paleta Functions con
todas las categorias mostradas y la categoria Programming expandida.
Durante este curso, trabajara principalmente en la categoria Programming,
pero también usard otras categorias o subpaletas.
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Figura 2-20. Paleta de funciones

Para mostrar o ocultar categorias, seleccione el botén View en la paleta y
seleccione o deseleccione la opcién Change Visible Categories. Aprenda
mds sobre el uso de la paleta Functions en el ejercicio 2-2.



Rarra de herramientas del diagrama de blogues

Cuando ejecuta un VI, aparece una serie de botones en la barra de
herramientas del diagrama de bloques que puede utilizar para depurar el VI.
La siguiente barra de herramientas aparece en el diagrama de bloques.
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Haga clic en el botén Highlight Execution para mostrar una animacion de
O
la ejecucidn del diagrama de blogues cuando ejecute el VI. Observe el flujo
fond
de datos a través del diagrama de bloques. Haga clic en el botén de nuevo
para desactivar el resaltado de la ejecucién.

Haga clic en el bot6n Retain Wire Values para guardar los valores de

los cables en cada punto del flujo de ejecucién de modo que cuando coloque
una sonda en el cable, pueda conservar inmediatamente el valor mds
reciente que pasoé por el cable. Debe ejecutar correctamente el VI al menos
una vez antes de poder conservar los valores de los cables.

Haga clic en el botdn Step Into para abrir un nodo y pausar la ejecucidn.
Haciendo clic en el botén Step Into de nuevo, se ejecuta la primera accién

y se pausa la ejecucion en la siguiente accion del subVI o de la estructura.
También puede pulsar las teclas <Ctrl> y la flecha abajo. Ejecutar paso a

paso un VI permite revisar el VI nodo a nodo. Cada nodo parpadea para (
indicar cudndo estd listo para ejecutarse.

Haga clic en el boton Step Over para ejecutar un nodo y pausar la ejecucién
en el siguiente nodo. También puede pulsar las teclas <Ctrl> y la flecha
derecha. Al pasar por encima del nodo, ejecuta el nodo pero no paso a paso. (

Haga clic en el boton Step Out para terminar de ejecutar el nodo actual y
pausar la ejecucion. Cuando se termina de ejecutar el VI, se atenta el botdn
Step Out. También puede pulsar las teclas <Ctrl> y la flecha arriba. Al salir

de un nodo, se completa la ejecucién paso a paso del nodo y se pasa al /
siguiente nodo.

Haga clic en el botén Clean Up Diagram para redirigir automaticamente (
todos los cables existentes y reordenar objetos del diagrama de bloques ‘
para generar un disefio mds limpio. Puede ajustar la configuracion de

las opciones de limpieza seleccionando Tools»Options para mostrar el
cuadro de didlogo Options y después Block Diagram: Cleanup en la lista
Category.

El botén Warning aparece si un VI incluye una advertencia y marcé la

casilla de verificacién Show Warnings en la ventana Error List. Una (
advertencia indica que existe un posible problema con el diagrama de

bloques, pero no impide que se ejecute el VI.




Ejercicio 2-1

Objetivo

Descripcion

Concepto: explorar un VI

Identificar las partes de un VI existente.

Ha recibido un VI de un empleado que registra los segundos que tarda un
avidn en llegar a un aeropuerto y convierte el tiempo en una combinacion de
horas/minutos/segundos. Debe evaluar este VI para ver si funciona como se
esperaba y poder mostrar el tiempo restante hasta que llegue el avién.

1. Abra Seconds Breakdown.vi en el directorio <Exercises>\
LabVIEW Basics I\Exploring a VI.

[3S]

En el panel frontal, identifique estos elementos:
O Control

O Indicador

Q Botén Run

 Icono

3. Para mostrar el panel frontal y el diagrama de bloques a la vez,
seleccione Window»Tile Up and Down.

4. En el diagrama de bloques, identifique estos elementos:
U Control
O Indicador
0 Constante
U Etiqueta libre
5. Pruebe el VI utilizando los valores de la tabla 2-2.
O Escriba el valor de entrada en el control Total Time in Seconds.

(L Haga clic en el botén Run.



U Compare en cada entrada las salidas dadas con las salidas de
la tabla 2-2. Si el VI funciona correctamente, deben coincidir.

Tahla 2-2. Testing Values for Seconds Breakdown.vi

Entrada

Salida

0 segundos

0 horas, 0 minutos, 0 segundos

60 segundos

0 horas, 1 minuto, O segundos

3.600 segundos

I hora, 0 minutos, 0 segundos

3.665 segundos

I hora, 1 minuto, 5 segundos

Fin del ejercicio 2-1




G. Bisqueda de controles, Vis y funciones

oo

Chever

Wigw

Cuando selecciona View»Controls o View»Functions para abrir
las paletas Controls y Functions, aparecen dos botones en la parte superior
de la paleta.

Search: cambia la paleta al modo de biisqueda para poder realizar
busquedas de texto y encontrar controles, VIs o funciones en las paletas.
Con la paleta en el modo de busqueda, haga clic en el botén Return para
salir del modo de btisqueda y volver a la paleta.

View: ofrece opciones para seleccionar un formato para la paleta actual,
mostrando u ocultando categorias para todas las paletas y clasificando
elementos de los formatos Text y Tree alfabéticamente. Seleccione
Options del menu contextual para mostrar la pagina Controls/Functions
Palettes del cuadro de didlogo Options, donde puede seleccionar un
formato para todas las paletas. Este boton sélo aparece si hace clic en

la chincheta de la esquina superior izquierda de una paleta para fijarla.

Hasta que se familiarice con la ubicacion de los Vs y las funciones, busque
la funcién o VI con el botén Search. Por ejemplo, si desea buscar la funcién
Random Number, haga clic en el botén Search en la paleta Functions y
empiece a escribir Random Number en el cuadro de texto de la parte
superior de la paleta. LabVIEW muestra todos los elementos coincidentes
que empiecen por el texto escrito o que lo contengan. Puede hacer clic en
uno de los resultados de buisqueda y arrastrarlo al diagrama de bloques,
como en la figura 2-21.

B ovneson

Q,Return ‘ o i |
random

ﬁahﬂém Number ifD-l) <¢Evpress Numeric>> im

Random Murber (0-1) < <Mumeric»> \
=)

I Search Options l I Help ]

Figura 2-21. Bisqueda de un objeto en la paleta Functions



Haga doble clic en el resultado de buisqueda para resaltar su ubicacién en
la paleta. Si se trata de un objeto que vaya a usar con frecuencia, puede
afiadirlo a su categoria Favorites. Haga clic con el botén derecho en el objeto
de la paleta y seleccione Add Item to Favorites, como se ve en

la figura 2-22.
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Figura 2-22. Afadir un elemento a la categoria Favorites de una paleta



Ejercicio 2-2 Concepto: navegar por paletas

Objetivo
Aprender a buscar controles y funciones.
Descripcion
1. Abraun Vlenblancoy seleccione View»Controls Palette en la ventana
del panel frontal.
2. Explore la paleta Controls.
(J Haga clic en el boton Search.
0 Escriba string control.
U Haga clic en un resultado de biisqueda y arrdstrelo a la ventana
del panel frontal para colocar el objeto.
3. Abra el diagrama de bloques y seleccione View»Functions Palette.
4. Explore la paleta Functions.
U Sitde el VI DAQ Assistant en la categoria Favorites.
— Busque el VI DAQ Assistant.
— En la paleta Functions, haga clic con el botén derecho en el VI
DAQ Assistant y seleccione Add Item to Favorites en el menu
contextual.
5. Practique accediendo a funciones similares.
O Coloque una funcién Add en el diagrama de bloques.
U Haga clic con el botén derecho en la funcién Add y observe que
dispone de una paleta Numeric.
@ Practique colocando funciones desde la paleta Numeric en
el diagrama de bloques.
@ Nota Para ver una demostracién del ejercicio anterior, abra Navigating

Palettes.exe en el directorio <Exercises>\LabVIEW Basics I\
Navigating Palettes.

Fin del ejercicio 2-2



H. Seleccidn de una herramienta

¥

Puede crear, modificar y depurar VIs utilizando las herramientas que ofrece
LabVIEW. Una herramienta es un modo de funcionamiento especial del
cursor del ratén. El modo de funcionamiento del cursor se corresponde con
el icono de la herramienta seleccionada. LabVIEW elige qué herramienta
seleccionar en funcién de la ubicacién actual del ratén.

Figura 2-23. Paleta Tools

Consejo Puede elegir manualmente la herramienta que necesita selecciondndola en
la paleta Tools. Seleccione View»Tools Palette para mostrar la paleta Tools.




Herramienta de operaciones

,ﬂ? Cuando el cursor del ratén cambia al icono mostrado a la izquierda,
* la herramienta de operaciones estd operativa. Use la herramienta de
operaciones para cambiar los valores de un control. Por ejemplo, en
la figura 2-24 la herramienta de operaciones mueve el puntero del control
deslizante horizontal. Cuando el ratén pasa por el puntero, el cursor accede
automdticamente a la herramienta de operaciones.
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Figura 2-24. Uso de la herramienta de operaciones

La herramienta de operaciones se utiliza principalmente en la ventana
del panel frontal, pero también puede utilizar esta herramienta de la ventana
del diagrama de bloques para cambiar el valor de una constante booleana.



Herramienta de pos

&

icionamiento

Cuando el cursor del ratén cambia al icono mostrado a la izquierda,

la herramienta de posicionamiento estd operativa. Use la herramienta

de posicionamiento para seleccionar objetos o cambiar su tamafio. Por
ejemplo, en la figura 2-25 la herramienta de posicionamiento selecciona

el control numérico Number of Measurements. Tras seleccionar un objeto,
puede moverlo, copiarlo o eliminarlo. Cuando el ratén pasa por el borde
de un objeto, el cursor accede automaticamente a la herramienta de
posicionamiento.

ﬁ Using Temperature.vi Front Panel

F:le Edit View Project Operate Tools Window Help

T S e I T

][5 17]

BPSEE

Delay (sac)

i t 1 P [ I
00 2.0 40060 80100

TemperatwreGrph . TempPlot NG
~ado-

A2
Q
L
e
@
=
T
q
u.

[ |
.0 10 0 20 0 ’40 1} 40 g 50 g, 60.0 fD 1] 8fJ g 90 0] IUU 0
Time: :

Figura 2-25. Uso de la herramienta de posicionamiento para
seleccionar un objeto




Si el ratén pasa por encima de un nodo de cambio de tamafio de un objeto,
el modo del cursor cambia para indicar que puede cambiar su tamafio, como
se ve en la figura 2-26. Observe que el cursor se encuentra sobre una esquina
del grafico XY en un nodo de cambio de tamafio y el modo del cursor
cambia a una flecha de dos puntas.

i3 Uising Temperature.vi Front Panel
1
|

i File Edit Yiew Project COperate Tools sindow  Help YEFP
i . -
i }r.{) ]@1 @ ] 13pt Application Font -« HE;,« ”TﬂEv ]]gv ”"“"v ]EE’

ber of Measuraments . Delay {sec)

4060 8.0 100

Temperature Graph Temp Plot - E{
o) . o )

- ........-

85,0~

Fahrenheit

70.0-3 \ i i
; 4,0 10 ] 40 0: JO D 40 0 SU 0 60 {1} D.D 80.0.-90.0 - 100.0
H : Tire : :

5}

Figura 2-26. Uso de la herramienta de posicionamiento para
cambiar el tamafio de un objeto

Puede utilizar la herramienta de posicionamiento en la ventana del panel
frontal y en el diagrama de bloques.



Herramienta de etiguetado

Cuando el cursor del ratén cambia al icono mostrado a la izquierda,

la herramienta de etiquetado estd operativa. Use la herramienta de
etiquetado para escribir texto en un control, para modificar texto y para crear
etiquetas libres. Por ejemplo, en la figura 2-27 la herramienta de etiquetado
escribe texto en el control numérico Number of Measurements. Cuando
el raton pasa por el interior del control, el cursor accede automdticamente a
la herramienta de etiquetado. Haga clic una vez para situar un cursor dentro
del control. A continuacién, haga doble clic para seleccionar el texto actual.
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Figura 2-27. Uso de la herramienta de etiguetado

Cuando no estd en una zona especifica de una ventana del panel frontal o
una ventana del diagrama de bloques que accede a un determinado modo
del ratén, el cursor aparecerd como una cruz. Si se habilita la seleccién de (f
herramienta automatica, puede hacer doble clic en cualquier espacio abierto
para acceder a la herramienta de etiquetado y crear una etiqueta libre.




Herramienta de cableado

Cuando el cursor del ratén cambia al icono mostrado a la izquierda,

la herramienta de cableado estd operativa. Use la herramienta de cableado
para cablear objetos entre si que estdn en el diagrama de bloques. Por
ejemplo, en la figura 2-28 la herramienta de cableado cablea el terminal
Number of Measurements al terminal de contaje para el bucle For. Cuando
el ratén pasa por el punto de salida o entrada de un terminal o por un cable,
el cursor accede automédticamente a la herramienta de cableado.
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Figura 2-28. Uso de la herramienta de cableado

La herramienta de cableado funciona principalmente con la ventana del
diagrama de bloques y cuando crea un panel de conectores en la ventana
del panel frontal.



Otras herramientas a las que se accede desde |a paleta

Puede acceder a las herramientas de operaciones, posicionamiento,
etiquetado y cableado directamente desde la paleta Tools, en lugar de usar
el modo de seleccidn automatica de la herramienta. Seleccione View»Tools
Palette para acceder a la paleta Tools.

Figura 2-29. La paleta Tools

El elemento superior de la paleta Tools es el botén Automatic Tool
Selection. Cuando se selecciona, LabVIEW elige autométicamente una
herramienta en funcién de la ubicacién de su cursor. Puede desactivar

la seleccion automatica de la herramienta deseleccionando el elemento o
seleccionando otro elemento de la paleta. Existen otras herramientas en
la paleta, descritas abajo:

Use la herramienta Object Shortcut Menu para acceder a un menu
contextual del objeto con el botén izquierdo del ratén.

Use la herramienta de desplazamiento para desplazarse por las ventanas sin
utilizar barras de desplazamiento.

Use la herramienta de puntos de interrupcién para establecer puntos de
interrupcién en VI, funciones, nodos, cables y estructuras para pausar
la ejecucién en esa ubicacion.

Use la herramienta de sonda para crear sondas en cables del diagrama de
bloques. Use la herramienta de sonda para comprobar valores intermedios
de un VI que produce resultados cuestionables o inesperados.

Use la herramienta de copiar color para copiar colores y pegarlos con
la herramienta de color.

Use la herramienta de color para colorear un objeto. La herramienta de color
también muestra los ajustes de color de primer plano y de fondo actuales.




Ejercicio 2-3 Concepto: seleccion de una herramienta

Objetivo

Descripcion

Familiarizarse con la seleccion automadtica de herramientas en LabVIEW.

Durante este ejercicio completard tareas en un panel frontal y en un

diagrama de bloques parcialmente creado. Estas tareas aportan experiencia

para usar la seleccién automadtica de herramientas.

1. AbraUsing Temperature.vi.
d Abra LabVIEW.

U Seleccione File»Open.

U Navegue al directorio <Exercises>\LabVIEW Basics T\

Using Temperature.

U Seleccione Using Temperature.vi y haga clic en OK.

La figura 2-30 muestra un ejemplo del panel frontal tras las modificaciones

a realizar. Se aumentard el tamaiio del gréfico tipo “waveform graph”,

se cambiard el nombre del control numérico, se cambiara el valor del control

numérico y se movera el puntero al control deslizante horizontal.
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Figura 2-30. Panel frontal del VI Using Temperature
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“

Expanda el gréfico tipo “waveform graph” horizontalmente con
la herramienta de posicionamiento.

U Mueva el cursor al borde izquierdo del grafico Wavetform Graph.

(' Mueva el cursor al nodo de cambio de tamaiio de la parte central
izquierda hasta que el cursor cambie a una doble flecha, como se ve
en la figura 2-31.
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Figura 2-31. Cambiar el tamafio del grafico Waveform Graph

O Arrastre el punto de reposicionamiento hasta que el grafico
Waveform Graph tenga el tamafio deseado.

Cambie el control numérico a Number of Measurements usando
la herramienta de etiquetado.

L Mueva el cursor al texto Numeric.
(Q Haga doble clic en la palabra Numeric.
1 FEscriba el texto Number of Measurements.

Complete la entrada haciendo clic en el botén Enter Text de la barra de
herramientas o haciendo clic fuera del control.

d Cambie el valor del control Number of Measurements a 20 usando
la herramienta de etiquetado.

W Mueva el cursor al interior del control numérico.

Cuando el cursor cambie al icono de la herramienta de etiquetado,
mostrado a la izquierda, haga clic con el botén del ratén.

(1 Escriba el texto 20.




@ Complete la entrada pulsando la tecla <Intro> en el teclado
numérico, haciendo clic en el boton Enter Text de la barra
de herramientas o haciendo clic fuera del control.

5. Cambie el valor del puntero en el control deslizante horizontal usando
la herramienta de operaciones.

U Mueva el cursor al puntero en el control deslizante.

O Cuando el cursor cambie al icono de la herramienta de operaciones,
mostrado a la izquierda, haga clic con el botén del ratdn y arrastre al
valor deseado.

(J Escriba un valor mayor que 0.

6. Intente cambiar el valor, el tamafio y el nombre de objetos hasta que
se familiarice con estas herramientas.

La figura 2-32 muestra un ejemplo del diagrama de bloques tras

las modificaciones a realizar. Se movera el terminal Number of
Measurements y se cableard el terminal hasta el terminal de contaje
del bucle For.
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Figura 2-32. Diagrama de blogues del VI Using Temperature
7. Abra el diagrama de bloques.

8. Mueva el terminal Number of Measurements con la herramienta
de posicionamiento.

J Mueva el cursor al terminal Number of Measurements.

U Mueva el cursor al terminal hasta que el cursor cambie a una flecha,
como se ve a la izquierda.

O Hagaclicy arrastre el terminal a la nueva ubicacién como se muestra
en la figura 2-32.



9. Cablee el terminal Number of Measurements al terminal de contaje
para el bucle For utilizando la herramienta de cableado.

Q
Q

Q
a

Mueva el cursor al terminal Number of Measurements.

Mueva el cursor a la derecha del terminal hasta que el cursor cambie
a un carrete de cable, como se ve a la izquierda.

Haga clic para iniciar el cable.
Mueva el cursor al terminal de contaje (N) del bucle For.

Haga clic en el terminal de contaje para terminar el cable.

10. Haga clic en el botén Run para ejecutar el V1.

El tiempo necesario para ejecutar este VI equivale a Number of
Measurements por Delay (Sec). Una vez que termine de ejecutarse
el VI, los datos aparecerdn en el grafico Temperature Graph.

11. Intente mover otros objetos, eliminar cables y volver a cablearlos y
cablear objetos y cables hasta que se familiarice con estas herramientas.

12

2. Seleccione File»Close para cerrar el VI y haga clic en el botén

Don’t save - All. No necesita guardar el VI.

Fin del ejercicio 2-3




|. Flujo de datos

LabVIEW sigue un modelo de flujo de datos para ejecutar VIs. Se ejecuta
un nodo del diagrama de bloques cuando recibe todas las entradas
necesarias. Cuando se ejecuta un nodo, produce datos de salida y pasa

los datos al siguiente nodo de la ruta del flujo de datos. El movimiento

de los datos a través de los nodos determina el orden de ejecucion de los VIs
y las funciones del diagrama de bloques.

Visual Basic, C++, JAVA y la mayoria del resto de lenguajes de
programacién basados en texto siguen un modelo de flujo de control

de la ejecucion del programa. En el flujo de control, el orden secuencial
de los elementos del programa determina el orden de ejecucién de un
programa.

Para ver un ejemplo de programacién de flujo de datos, piense en un
diagrama de bloques que suma dos nimeros y después resta 50, 00 del
resultado de la suma, como en la figura 2-33. En este caso, el diagrama

de bloques se ejecuta de izquierda a derecha, no porque los objetos estén
situados en ese orden, sino porque la funcién Subtract no puede ejecutarse
hasta que la funcién Add termine de ejecutarse y pase los datos a la funcién
Subtract. Recuerde que un nodo se ejecuta sélo cuando existen datos de
todos sus terminales de entrada y suministra datos a los terminales de salida
s6lo cuando el nodo termina su ejecucion.

Figura 2-33. Ejemplo de programacion de flujo de datos



En la figura 2-34, piense en qué segmento de codigo se ejecutaria primero,
la funcién Add, Random Number o Divide. No puede saberlo, ya que las
entradas de las funciones Add y Divide estdn disponibles a la vez, mientras
que la funcién Random Number no tiene entradas. En una situacién en

la que un segmento de c6digo debe ejecutarse antes que otro y en la que
no existe dependencia de datos entre las funciones, use otros métodos de
programacion, como clusters de errores, para forzar el orden de ejecucion.
Consulte laleccidn 5, Relacionar datos, para obtener informacién adicional
acerca de los clusters de errores.
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Figura 2-34. Ejemplo de flujo de datos para segmentos de cédigos multiples



Ejercicio 2-4 Concepto: flujo de datos

Objetivo

Descripcion

Comprender cémo el flujo de datos determina el orden de ejecucion en
un VL

1. Abra la simulacion Dataflow.exe en el directorio <Exercises>\
LabVIEW Basics I\Dataflow.

2. Siga las instrucciones que se le ofrecen. Esta simulacién demuestra

el flujo de datos.

Fin del ejercicio 2-4



J. Creacion de un Vi simnie

La mayoria de los VIs de LabVIEW desempefian tres tareas principales:

adquirir ciertos tipos de datos, analizar los datos adquiridos y presentar el
resultado. Cuando cada una de estas partes es simple, puede completar todo
el VI con muy pocos objetos en el diagrama de bloques. Los VIs Express

estdn disefiados especificamente para completar operaciones comunes y
muy utilizadas. En esta seccién aprenderd algunos VIs Express que
adquieren, analizan y presentan datos. Después aprenderd a crear un VI
simple que utiliza estas tres tareas, como se ve en la figura 2-35.
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Figura 2-35. Ventana del panel frontal y del diagrama de bloques de ejemplo

de adquisicion, andlisis y presentacion




Adquirir

Analizar

En la paleta Functions, los VIs Express estdn agrupados en la categoria
Express. Los VIs Express utilizan el tipo de datos dindmico para pasar datos
entre si.

Los VIs Express que se utilizan para la tarea Adquirir son: DAQ Assistant,
Instrument 1/0 Assistant, Simulate Signal y Read from Measurement File.

DAQ Assistant

El DAQ Assistant adquiere datos con un dispositivo de adquisicion de datos.
Debe utilizar este Express VI con frecuencia a lo largo de este curso.
Consulte la leccion 8, Adquisicion de datos, para obtener informacion
adicional acerca del DAQ Assistant. Hasta que aprenda més de la
adquisicién de datos, sélo usard un canal del dispositivo de adquisicion de
datos, cHO. Este canal se conecta a un sensor de temperatura del Accesorio
de sefiales DAQ. Puede tocar el sensor de temperatura para cambiar

la temperatura que lee.

instrument 1/0 Assistant

El Instrument I/O Assistant adquiere datos de control de instrumentos,
normalmente desde una interfaz GPIB o de serie. Consulte la leccion 9,
Control de instrumentos, para obtener informacién adicional acerca del
Instrument I/0O Assistant.

Simulate Signal

El VI Express Simulate Signal genera datos simulados como una onda
sinusoidal.

Read From Measurement File

El VI Express Read From Measurement File lee un archivo que se cred
utilizando el VI Express Write To Measurement File. Concretamente lee
los formatos de archivo LVM o TDM. Este VI Express no lee archivos
ASCII. Consulte la leccién 6, Almacenamiento de datos de medida, para
obtener informacion adicional acerca de leer datos de un archivo.

Los VIs Express utilizados para la tarea Analizar incluyen lo siguiente:
Amplitude and Level Measurements, Statistics, Tone Measurements, etc.

Amplitude and Level Measurements

El VI Express Amplitude and Level Measurements mide la tensién en
una sefial. Mide la CC, RMS, pico mdximo, pico minimo, de pico a pico,
promedio del ciclo y RMS del ciclo.



Presentar

Statistics

El VI Express Statistics calcula los datos estadisticos de una forma de onda.
Incluye los valores medio, suma, desviacién estdndar y extremos.

Spectral Measurements

El VI Express Spectral Measurements realiza la medicion espectral de una
forma de onda, como la magnitud y la densidad espectral de potencia.

Tone Measurements

El VI Express Tone Measurements busca un tnico tono con la mdxima
frecuencia o la mayor amplitud. También busca la frecuencia y la amplitud
de un Gnico tono.

Filter

El VI Express Filter procesa una sefial mediante filtros y ventanas. Los
filtros utilizados son: paso alto, paso bajo, paso banda, elimina banda y
suavizado. Las ventanas utilizadas son Butterworth, Chebyshev, Chebyshev
inverso, Eliptico y Bessel.

Presente resultados utilizando VIs Express que realicen una funcién, como
el VI Express Write to Measurement File o indicadores que presentan datos
en la ventana del panel frontal. Los indicadores que mds se suelen utilizar
para esta tarea son los graficos Waveform Chart, Waveform Graph y XY
Graph. Los VIs Express habituales son VI Express Write to Measurement
File, VI Express Build Text, DAQ Assistant e Instrument /O Assistant.
En este caso, el DAQ Assistant y el Instrument I/O Assistant proporcionan
datos de salida desde el ordenador al dispositivo DAQ o un instrumento
externo.

Write to Measurement File

El VI Express Write to Measurement File escribe un archivo en formato de
archivo LVM o TDMS. Consulte la leccidn 6, Almacenamiento de datos de
medida, para obtener informacién adicional acerca de escribir en archivos
de medida.

Build Text

El VI Express Build Text crea texto, normalmente para mostrar en

la ventana del panel frontal o para exportar a un archivo o instrumento.
Consulte la leccion 6, Almacenamiento de datos de medida, para obtener
informacidn adicional acerca de crear cadenas de caracteres.



Ejecutar un Vi
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Tras configurar los VIs Express y cablearlos, puede ejecutar el V1. Cuando
termine de crear el VI, haga clic en el botén Run en la barra de herramientas
para ejecutar el VL.

Mientras se estd ejecutando el VI, el icono del botén Run cambia a la figura
mostrada a la izquierda. Tras terminar la ejecucion, el botén Run cambia a
su estado original y los indicadores del panel frontal contendrdn datos.

Errores del boton Run

Si un VI no se ejecuta, es un VI roto o no ejecutable. El botén Run aparece
roto (se muestra a la izquierda) cuando el VI que estd creando o modificando
contiene errores.

Si el botén sigue apareciendo roto tras terminar de cablear el diagrama
de bloques, el VI estd roto y no puede ejecutarse.

Normalmente esto significa que una entrada necesaria no esté cableada o
que un cable estd roto. Pulse el botén Run roto para acceder a la ventana
Error list. La ventana Error list muestra cada error y describe el problema.
Puede hacer doble clic en un error para acceder a €l directamente. Consulte
la leccidn 3, Resolucion de problemas y depuracion de VIs, para obtener
informacién adicional acerca de depurar VIs.



Ejercicio 2-5 VI AAP Simple

Objetivo
Cree un VI simple que adquiera, analice y presente datos.

Escenario
Debe adquirir una onda sinusoidal durante 0,1 segundo, determinar y
mostrar el valor medio, registrar los datos y mostrar la onda sinusoidal
en un grafico.

Diseiio

La entrada de este problema es un canal analdgico de datos de onda
sinusoidal. Las salidas incluyen un grafico para los datos sinusoidales y
un archivo que registra los datos.

Diagrama de flujo

: ACQUIRE : ANALYZE ; PRESENT 5
E X E E E
Acquire Data —{  Display Data
| ‘ I Log Data E
5 5 v 5 :
Determine : Display Average :
! ! Average Value : Value '

Figura 2-36. Diagrama de flujo de VI AAP Simple



Arquitectura del programa: cuestionario
1. Adquirir: rodee con un circulo el VI Express mds indicado para adquirir
una onda sinusoidal de un dispositivo de adquisicion de datos.

DAQ Assistant El DAQ Assistant adquiere datos
mediante un dispositivo de adquisicién
de datos.

Instrument 1/O El Instrument /O Assistant adquiere

Assistant datos de control de instrumentos,
normalmente desde una interfaz GPIB
o de serie.

Express VI Simulate El VI Express Simulate Signal genera

Signal datos simulados como una onda
sinusoidal.

2. Analizar: rodee con un circulo el VI Express mds indicado para
determinar el valor medio de los datos adquiridos.

m VI Express Tone El VI Express Tone Measurements
DA | Measurements busca la frecuencia y la amplitud de
un unico tono.

VI Express Statistics El VI Express Statistics calcula los
datos estadisticos de una forma de onda.

mm | VI Express Amplitude | El VI Express Amplitude and Level
24 1 and Level Measurements mide la tensién en una
Measurements sefial.

VI Express Filter El VI Express Filter procesa una sefial
mediante filtros y ventanas.




3. Presentar: rodee con un circulo los VIs Express o los indicadores que
muestren mejor los datos en un gréfico y registren mejor esos datos en
un archivo.

DAQ Assistant El DAQ Assistant adquiere datos
mediante un dispositivo de adquisicién
de datos.

VI Express Write to El VI Express Write to Measurement

Measurement File

File escribe un archivo en formato de
archivo LVM o TDM.
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VI Express Build Text

El VI Express Build Text crea texto,
normalmente para mostrar en la ventana
del panel frontal o para exportar a un
archivo o instrumento.

Waveform Graph

El gréfico tipo “waveform graph”
muestra uno o mas puntos de
mediciones muestreadas
uniformemente.

Consulte la pdgina siguiente para mostrar las respuestas de este
cuestionario.




Arquitectura del programa: soluciones al cuestionario
1. Adquirir: use el DAQ Assistant para adquirir la onda sinusoidal desde
el dispositivo de adquisicion de datos.

2. Analizar: use el VI Express Statistics para determinar el valor medio
de la onda sinusoidal. Como esta sefial es ciclica, también podria utilizar
la opcién Cycle Average en el VI Express Amplitude and Level
Measurements para determinar el valor medio de la onda sinusoidal.

3. Presentar: use el VI Express Write to Measurement File para registrar
los datos y use un grafico tipo Waveform Graph para mostrar los datos
en la ventana del panel frontal.



Implementacidn
1. Prepare el hardware para generar una onda sinusoidal. Si no estd

utilizando hardware, salte al paso 2.

O Busque el Accesorio de sefiales DAQ y confirme visualmente que
esté conectado al dispositivo DAQ de su ordenador.

Q Con un cable, conecte el Analog In Channel 1 al Sine Function
Generator, como se ve en la figura 2-37.

U Configure el conmutador Frequency Range y el mando Frequency
Adjust en sus valores minimos.
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Figura 2-37. Conexidn para el Accesorio de sefiales DAQ
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2. Abra LabVIEW.

3. Abra un VI nuevo.




4. Guarde el VI como Simple AAP.vi.
U Seleccione File»Save.

U Navegue al directorio <Exercises>\LabVIEW Basics I\
Simple AAP.

1 Nombre el VI como Simple AAP.vi.
O Haga clic en OK.

En los siguientes pasos creard una ventana de panel frontal similar a
la de la figura 2-38.

Waveform Graph

oo
=,
b=
=
&
=
LN

Figura 2-38. Ventana de panel frontal de adquirir, analizar y presentar

5. Aifiada un grafico tipo “waveform graph” a la ventana del panel frontal
g p p
para mostrar los datos adquiridos.

O Acceda a la paleta Controls, si no estd ya abierta, desde el menu
LabVIEW seleccionando View»Controls Palette.

En la paleta Controls, seleccione la categoria Express.
Seleccione la categoria Graph Indicators en la categoria Express.

Seleccione el gréfico tipo “waveform graph”.

O 0O 0O O

Afiada el grafico a la ventana del panel frontal.



6. Afadaun indicador numérico a la ventana del panel frontal para mostrar
los valores medios.

O Contraiga la categoria Graph Indicators seleccionando Express
en la paleta Controls.

( Seleccione la categoria Numeric Indicators en la categoria
Express.

O Seleccione el indicador numérico.
O Coloque el indicador en el panel frontal.
U Escriba average Value en la etiqueta del indicador numérico.

En los siguientes pasos creard un diagrama de bloques similar al de
la figura 2-39.

I.ﬁ.r:niuire Dai:_él Analyze Data Present Data
» 7y — ;
- [1 (iﬁ ¢ TiLY
- S
- b k’ "’ x -

DAQ Assistant Statistics

data b jecer e b Signals fverage Yalue
— Arithretic Mean

Warveform Graph
i =

T o W

Write To
Measurement: File
Signals

Figura 2-39. Diagrama de bloques de adquirir, analizar y presentar
7. Abra el diagrama de bloques del VL.

U Seleccione Window»Show Block Diagram.

Nota Los terminales correspondientes a los nuevos objetos de la ventana del panel
frontal aparecen en el diagrama de bloques.



8. Adquiera una onda sinusoidal durante 0,1 segundos. Si tiene hardware
instalado, siga las instrucciones de la columna Hardware instalado
para adquirir los datos utilizando el DAQ Assistant. Si no tiene hardware
instalado, siga las instrucciones de la columna No hay hardware
instalado para simular adquirir los datos utilizando el VI Express

Simulate Signal.

Hardware instalado

No hay hardware instalado

1. En la paleta Functions, seleccione 1. En la paleta Functions, seleccione
la categoria Express. la categoria Express.

2. Seleccione Input en la categoria 2. Seleccione Input en la categoria
Express. Express.

3. Seleccione DAQ Assistant en 3. Seleccione Simulate Signal en
la categoria Input. la categoria Input.

4. Coloque el DAQ Assistanten el diagrama | 4. Coloque el VI Express Simulate Signal
de bloques. en el diagrama de bloques.

5. Espere a que se abra el cuadro de didlogo | 5. Espere a que se abra el cuadro de didlogo
DAQ Assistant. Simulate Signal.

6. Seleccione Acquire Signals»Analog 6. Seleccione Sine para el tipo de sefal.
Input»Voltage para el tipo de medicion.

7. Seleccione ail (canal de entrada 7. Configure la frecuencia de sefial en 100.
analégica 1) para el canal fisico.

8. Haga clic en el botén Finish. 8. En la seccién Timing, ajuste Samples

per second (Hz) en 1000.

9. En la seccién Timing Setting, seleccione | 9. En la seccién Timing, deseleccione
con el tabulador N Samples como Automatic para el nimero de muestras.
Acquisition Mode.

10. En la seccién Timing Settings, escriba 10. En la seccién Timing, ajuste Number
100 en Samples To Read. of samples en 100.

11. Introduzca 1000 en Rate (Hz). 11. Seleccione la seleccién Simulate

acquisition timing.

12. Haga clic en el botén OK. 12. Haga clic en el botén OK.

¥

Consejo Silee 100 muestras a 1.000 Hz, recuperard el valor de datos de 0,1 segundo.




9. Determine el valor medio de los datos adquiridos utilizando el
VI Express Statistics.

 Contraiga la paleta Input seleccionando Express en la paleta
Functions.

Seleccione la paleta Signal Analysis.

Seleccione el VI Express Statistics y afiddalo al diagrama
de bloques a la derecha del DAQ Assistant.

O Espere a que se abra el cuadro de didlogo del VI Express Statistics.
(' Marque la casilla de verificacion Arithmetic mean.
U Haga clic en OK.

10. Registre los datos sinusoidales generados en un archivo de medicién
de LabVIEW.

Q Seleccione Express en la paleta Functions.
 Seleccione la categoria Output.

Q Seleccione Write to Measurement File.

Q

Anada el VI Express Write to Measurement File al diagrama
de bloques bajo el VI Express Statistics.

(O Espere a que se abra el cuadro de didlogo del VI Express Write to
Measurement File.

Deje todos los ajustes de forma predeterminada.

Haga clic en OK.

@ Nota Los préximos ejercicios no detallan las indicaciones para encontrar funciones
concretas o controles en las paletas. Use la funcién de bisqueda de paletas para encontrar
funciones y controles.

11. Cablee los datos del DAQ Assistant (o VI Express Simulate Signal)
al VI Express Statistics.

( Coloque el cursor del ratén sobre la salida data del DAQ Assistant
(o la salida Sine del VI Express Simulate Signal) donde el cursor
cambie a la herramienta de cableado.

Q Haga clic en el botdn del ratén para iniciar el cable.




U Coloque el cursor del ratén sobre la entrada Signals del VI Express
Statistics y haga clic en el botén del ratén para terminar el cable.

12. Cablee los datos al indicador del grafico.

U Coloque el cursor del ratéon sobre el cable de salida data del DAQ
Assistant (o la salida Sine del VI Express Simulate Signal) donde
el cursor cambie a la herramienta de cableado.

Haga clic en el botén del ratén para iniciar el cable.

Coloque el cursor del ratén sobre el indicador graph y haga clic en
el botén del ratén para terminar el cable.

13. Cablee la salida Arithmetic Mean del VI Express Statistics al indicador
numérico Average Value.

U Coloque el cursor del ratén sobre la salida Arithmetic Mean del VI
Express Statistics donde el cursor cambia a la herramienta de
cableado.

Haga clic en el botén del ratén para iniciar el cable.

Coloque el cursor del ratén sobre el indicador numérico Average
Value y haga clic en el boton del raton para terminar el cable.

14. Cablee la salida data de la entrada Signals del VI Express Write
Measurement File.

U Coloque el cursor del ratén sobre el cable de salida data del DAQ
Assistant (o la salida Sine del VI Express Simulate Signal) donde
el cursor cambie a la herramienta de cableado.

Haga clic en el botén del ratén para iniciar el cable.
Coloque el cursor del ratén sobre la entrada Signals del VI Express

Write Measurement File y haga clic en el botdn del ratén para
terminar el cable.

@ Nota Los siguientes ejercicios no ofrecerdn indicaciones para cablear entre objetos.

15. Guarde el V1.



Prueba

1. Cambie a la ventana del panel frontal del VI.
2. Configure las propiedades del grafico para poder ver la onda sinusoidal.

U Haga clic con el botén derecho en el grifico tipo “waveform graph”
o o o
y seleccione X Scale»Autoscale X para desactivar la escala
automatica.

Q) Haga clic con el botén derecho en el grafico tipo “waveform graph”
y seleccione Visible Items»X Scrollbar.

O Use la herramienta de etiquetado para cambiar el Gltimo niimero de
la X Scale del grafico tipo “waveform graph™ a .1.

3. Guarde el VI.

4. Ejecute el VL.

U Haga clic en el botén Run en la barra de herramientas del panel
frontal.

El indicador del grafico debe mostrar una onda sinusoidal y el indicador
Average Value debe mostrar un nimero alrededor de cero. Si el VI no
se ejecuta segun lo esperado, revise los pasos de implementacién.

5. Cierre el VL.

Fin del ejercicio 2-5




Autorrevision: cuestionario

Consulte la figura 2-40 para responder a las preguntas de este cuestionario.

Murmber 1

Figura 2-40. Preguntas de flujos de datos

1. ;Qué funcidn se ejecuta primero: Add o Subtract?
a. Add
b. Subtract
c. No se sabe
2. ¢ Qué funcion se ejecuta primero: Sine o Divide?
a. Sine
b. Divide
c. No se sabe
3. ¢Qué funcidn se ejecuta primero?
a. Random Number
b. Divide
c. Add
d. No se sabe
4. ;Qué funcidn se ejecuta en ultimo lugar: Random, Add o Subtract?
a. Random Number
b. Subtract
c. Add
d. No se sabe
5. (Cudles son las tres partes de un VI?
Ventana del panel frontal
Ventana del diagrama de bloques

Proyecto

a0 o op

Panel de iconos y conectores







Autorrevision: respuestas al cuestionario

Result

Hurmber 4

1. ;Qué funciodn se ejecuta primero: Add o Subtract?
a. Add
b. Subtract

c. No se sabe

o

¢ Qué funcidn se ejecuta primero: Sine o Divide?
a. Sine
b. Divide
c. No se sabe
3. ¢Qué funcitn se ejecuta primero?
a. Random Number
b. Divide
c. Add
d. No se sabe
4. ;Qué funcién se ejecuta en tltimo lugar: Random, Add o Subtract?
a. Random Number
b. Subtract
Add
d. No se sabe
5. (Cudles son las tres partes de un VI?
a. Ventana del panel frontal
b. Ventana del diagrama de bloques
¢. Proyecto

d. Panel de iconos y conectores



